Go Back  R/C Tech Forums > General Forums > Radio and Electronics
Post your bad experiences using VENOM products lol > Post your bad experiences using VENOM products lol

Post your bad experiences using VENOM products lol

Reply

Old 01-30-2009, 07:15 AM
  #1  
Tech Elite
Thread Starter
iTrader: (58)
 
speedemall's Avatar
 
Join Date: Nov 2005
Location: hagerstown,MD
Posts: 2,427
Trader Rating: 58 (100%+)
Default Post your bad experiences using VENOM products lol

I was thinking today and just wondering how many horror stories there were pertaining to Venom products as I'm sure pretty much everyone has used them at one point.If you have a story lets hear it.I'll start..........

2400 AA batteries caught fire while in a wall charger,ruined two batteries,the charger,and my wall

2 of their fireball motors LITTERALLY turned into fireballs while running in my vehicles,both caught fire!!

2 3300-3600 battery packs,1 burst into flames and exploded,the other completely melted itself out of the pack.

Keep in mind these items were all used correctly and properly maintained,still they all failed
speedemall is offline  
Reply With Quote
Old 01-30-2009, 08:23 AM
  #2  
Tech Apprentice
 
1lowtaco's Avatar
 
Join Date: Dec 2005
Location: Frederick , MD
Posts: 84
Default

I've only had there battery packs, never had a problem. Not that greatof performance but never had them explode.
1lowtaco is offline  
Reply With Quote
Old 01-30-2009, 09:00 AM
  #3  
Tech Elite
Thread Starter
iTrader: (58)
 
speedemall's Avatar
 
Join Date: Nov 2005
Location: hagerstown,MD
Posts: 2,427
Trader Rating: 58 (100%+)
Default

Originally Posted by 1lowtaco View Post
I've only had there battery packs, never had a problem. Not that greatof performance but never had them explode.
Hey bo!!! Whatchu doin up on her?!!!?? Ain't heard from you in a bit.Call me

You never had a pack explode because you learned a lesson on the first pack lol.Look how many products it took for me to realise its junk
speedemall is offline  
Reply With Quote
Old 01-30-2009, 10:24 AM
  #4  
Tech Fanatic
iTrader: (8)
 
Hide's Avatar
 
Join Date: Sep 2007
Location: London
Posts: 931
Trader Rating: 8 (100%+)
Default

Had my 7 cell packs up to over 200F!
Hide is offline  
Reply With Quote
Old 01-30-2009, 11:13 AM
  #5  
Tech Elite
Thread Starter
iTrader: (58)
 
speedemall's Avatar
 
Join Date: Nov 2005
Location: hagerstown,MD
Posts: 2,427
Trader Rating: 58 (100%+)
Default

Originally Posted by Hide View Post
Had my 7 cell packs up to over 200F!
while charging??
speedemall is offline  
Reply With Quote
Old 01-30-2009, 11:43 AM
  #6  
Tech Fanatic
iTrader: (8)
 
Hide's Avatar
 
Join Date: Sep 2007
Location: London
Posts: 931
Trader Rating: 8 (100%+)
Default

Originally Posted by speedemall View Post
while charging??
Nope, after a hard bash in my E-Maxx, binned them after that.
Hide is offline  
Reply With Quote
Old 01-30-2009, 02:35 PM
  #7  
Tech Addict
iTrader: (30)
 
Join Date: May 2004
Location: Hawaii
Posts: 690
Trader Rating: 30 (100%+)
Default

Speedemall, not to discredit that fact that you had a couple of Venom's products go bad on you and in dangerous fashion, I think it would be helpful if you could provide some additional info such as what rate you were charging your packs, which charger were you using, gear ratio for the Fireball motors, etc. You may not think you weren't abusing these products, but may be you were pushing them close to their reasonable limits? Perhaps, there is something wrong with your charger?

This is just my two cents from my experiences as well as those of others here in Hawaii. I have heard of stories of the Venom batteries exploding and the Fireball motors catching fire. However, never heard of any of this happening locally. I've owned both their battery packs and Fireball motors and know several people that have and still use these products. No one, locally, as far as I know, has had any issues as described above. I, also, own a Venom Pro Charger which is pretty much like all of their products a rebadged product made in China. However, this isn't any different from a lot of manufacturers, today, that do the exact same thing.

Myself, several local racers, & LHS customers (over here in Hawaii) have bought numerous Venom battery packs without any incident of them catching fire or burning. I will admit that they aren't the greatest packs around, but they are the top sellers locally due to the low price. The only ones we found to be decent were the 3000 mah packs which seemed to work really well for racing with stock motors. However, the cell life was pretty short and they die so you have to buy new packs. The other packs were a good value for the price, but they don't perform all that well when compared to other brands of the same mah rating.

As for those Venom AA's, my friend has had two sets of the 2400 mah AA's for the last year which he uses for his M8. He hasn't had any issues with them. The other thing to consider is that he uses the Energizer 15-minute charger for them which probably isn't the best thing for the batteries.

In regards to the Fireball motors, there were a lot of these sold locally to replace the stock motors in the RC18 because at one point the stock AE motors were hard to get. No one including myself had any incident of any of these catching fire.
wrxnfx is offline  
Reply With Quote
Old 01-31-2009, 12:39 PM
  #8  
Tech Elite
Thread Starter
iTrader: (58)
 
speedemall's Avatar
 
Join Date: Nov 2005
Location: hagerstown,MD
Posts: 2,427
Trader Rating: 58 (100%+)
Default

[QUOTE=wrxnfx;5365203]Speedemall, not to discredit that fact that you had a couple of Venom's products go bad on you and in dangerous fashion, I think it would be helpful if you could provide some additional info such as what rate you were charging your packs, which charger were you using, gear ratio for the Fireball motors, etc. You may not think you weren't abusing these products, but may be you were pushing them close to their reasonable limits? Perhaps, there is something wrong with your charger?

QUOTE]

Okay the rate of charge I used on the packs was 3.0 amps and no higher due to the fact that I wanted run time,not voltage this was done a the duratrax ICE charger.The gear ratio on the car I do not remember since it was four years ago,I know for a fact that the car was not overgeared due to me equating correct ratio on my calculator which I always do at the track for all of my vehicles.These products were not pushed hard due to my knowledge of the quality of their products IE:you get what you pay for.I mean a $14.99 fireball versus a $38.00 trinity motor,which do you think will last longer and be better quality? A lesson I learned after running venom stuff,never skimp when it comes to your gear.I know some people have had good luck with their products but I just wanted to know if anyone else had problems.
speedemall is offline  
Reply With Quote
Old 07-28-2012, 02:19 PM
  #9  
Tech Initiate
iTrader: (3)
 
SquirlyNUTZ's Avatar
 
Join Date: Jun 2012
Location: EL PASO, USA
Posts: 24
Trader Rating: 3 (100%+)
Default

I purchased a Venom Pro Charger on their website. Received it broken, sent it back at my own expense. They denied me a refund, I'm already in $16 more than I paid in shipping costs. They sent the new charger to my billing address.
I am Military. Why send it to a different address that what I originally had it sent?
I had also clearly printed a return shipping address on the returned package as directed to in their warranty policy. Still got it wrong. Someone is really failing them in Customer Service.

Last edited by SquirlyNUTZ; 07-30-2012 at 01:53 PM. Reason: Turns out they contacted me in a hurry and we worked out an agreement. They were quick to fix the mistake.
SquirlyNUTZ is offline  
Reply With Quote
Old 07-30-2012, 01:26 PM
  #10  
Tech Adept
iTrader: (18)
 
OldGuydust's Avatar
 
Join Date: Jun 2012
Location: Capital of Chihuahua Mexico, El paso , TX.
Posts: 212
Trader Rating: 18 (100%+)
Default

I hope you get it sorted bro.

I have an old green pro charger from them that the fan went out on and they sent me a new fan free of charge real quick like..
I still use the charger to this day! ( Its just like the red ones they sell now..)

Anyhow I cant be happier with my Hitec 4x monster and 500W PS.. LOL!!!
OldGuydust is offline  
Reply With Quote

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Thread Tools
Search this Thread

Contact Us Archive Advertising Cookie Policy Terms of Service