Go Back  R/C Tech Forums > General Forums > Radio and Electronics
Sparks come out every time I connect a battery. >

Sparks come out every time I connect a battery.

Like Tree4Likes
  • 1 Post By anthonyscardina
  • 3 Post By DirkW

Sparks come out every time I connect a battery.

Old 10-08-2021, 07:34 AM
  #1  
Tech Rookie
Thread Starter
 
Join Date: Oct 2021
Posts: 2
Exclamation Sparks come out every time I connect a battery.

I have traxxas e revo 2.0 and I switched connectors to XT90, bu when I connecting batterys sparks come out. Can someone help me please?
Xayogs is offline  
Old 10-11-2021, 09:50 AM
  #2  
Tech Fanatic
iTrader: (26)
 
GerryH's Avatar
 
Join Date: Nov 2009
Posts: 839
Trader Rating: 26 (100%+)
Default

That's normal. The capacitors on the ESC side cause it. If you plug the battery in, unplug and plug back in. You should notice there were no sparks when you plugged back in because the capacitors were charged.
GerryH is offline  
Old 10-12-2021, 03:30 AM
  #3  
Tech Master
iTrader: (12)
 
Join Date: Dec 2009
Location: Hoffman Estates, IL
Posts: 1,035
Trader Rating: 12 (100%+)
Default

Get the XT90 anti spark plugs for your batteries.
the rc guy likes this.
anthonyscardina is offline  
Old 10-12-2021, 06:23 AM
  #4  
Tech Lord
 
Roelof's Avatar
 
Join Date: Aug 2007
Location: Holland
Posts: 10,956
Default

Originally Posted by anthonyscardina View Post
Get the XT90 anti spark plugs for your batteries.
Very good advise to someone owning a Traxxas and so a high chance it has Traxxas ID connectors and a Traxxas ID charger.....
So do explain all the other things he has to do like how to create balancing connectors to the batteries, modify the charger or better get a new normal charger etc.
Roelof is offline  
Old 10-12-2021, 06:33 AM
  #5  
Tech Master
iTrader: (1)
 
DirkW's Avatar
 
Join Date: Dec 2013
Location: Germany
Posts: 1,743
Trader Rating: 1 (100%+)
Default

OP said that he switched to XT90...
DirkW is offline  
Old 10-12-2021, 01:15 PM
  #6  
Tech Lord
 
Roelof's Avatar
 
Join Date: Aug 2007
Location: Holland
Posts: 10,956
Default

Originally Posted by DirkW View Post
OP said that he switched to XT90...
Sharp, missed that.
Roelof is offline  
Old 02-04-2022, 02:06 PM
  #7  
Tech Rookie
 
mikewalker's Avatar
 
Join Date: Mar 2021
Location: Berlin
Posts: 11
Default

Hello, I don't think I can solve your problem. But a funny story happened. Only the ignition coils sparkled, I just threw them away and bought new ones here best coils for ford f150 .Now there is a spark, everything works properly!

Last edited by mikewalker; 02-10-2022 at 02:04 AM.
mikewalker is offline  

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information -

Copyright 2021 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.