Savox repair.

Old 01-15-2020, 04:47 PM
  #1  
Tech Master
Thread Starter
iTrader: (7)
 
Join Date: Jun 2011
Location: Illinois
Posts: 1,516
Trader Rating: 7 (100%+)
Default Savox repair.

I have many savox servos that are in need of repair. Every single one does the same thing from the 1258 to 2273. They all stopped turning. I have taken them all apart. The motor all turn spin when I take the gears out but will not turn left or right. I played with the black thing that stick in the horn gear sorry do not know the name of these things. To get them to stop spinning. I believe it finds center. I took one of these black thing apart cleaned it and then hot iron it back together. This was no luck at all. I did try the one 2271 I ripped apart put it back together plugged it in and the motor sprn so fast it smoked the board by the motor. All of the gears work fine I hooked all these up straight lipo to the rx so there is no reason for a brown out at all. So what I'm wondering is there some fuse on these boards that go poof that I can simply replace or just solder one end to the next and bypass said fuse. Cause some off these are about a year old or less. I have tried y tub with no luck. Gonna maybe switch brands if I can not figure out why they go so fast.
imrob is offline  
Old 01-15-2020, 06:55 PM
  #2  
Tech Regular
iTrader: (25)
 
GerryH's Avatar
 
Join Date: Nov 2009
Posts: 363
Trader Rating: 25 (100%+)
Default

Did you check all the gears for missing teeth?
GerryH is offline  
Old 01-15-2020, 07:10 PM
  #3  
Tech Master
Thread Starter
iTrader: (7)
 
Join Date: Jun 2011
Location: Illinois
Posts: 1,516
Trader Rating: 7 (100%+)
Default

None of the teeth are missing at all. All the gear are fine I even check the small gear on the motor that does not spin at all either. Something else is going out on them and I'm not sure I was saving them for parts to hopefully fix one someday. Will after about 4 years of I have a total of 6 that cant remember if the where steering or throttle. Just getting back into the hobby after a 5 year break. Found them in my junk box and finally decide to look at them. All off them same thing 1258tg and 2271 and 2273 all spin while plugged into the rx but give them a left or right turn nothing. I guessing there all about a year old I had so much problem with savox warranty I gave up with that. This being said once I run out of there I will be switching to someone that stand behind there year warranty. I lost the 1258 than I went to over kill and grabbed the 2271 and 2273 for all my cars. Even 2wd sct.
imrob is offline  
Old 01-16-2020, 09:03 PM
  #4  
Tech Fanatic
iTrader: (2)
 
RazorRC's Avatar
 
Join Date: Oct 2017
Posts: 895
Trader Rating: 2 (100%+)
Default

You connected a lipo straight to the receiver? Some of the servos are rated at only 6V, so they're not going to be happy if you send 8.4V to them!
RazorRC is offline  

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information

Copyright 2018 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.