Go Back  R/C Tech Forums > General Forums > Radio and Electronics
LOSI mini 8ight T Beeping ESC help >

LOSI mini 8ight T Beeping ESC help

LOSI mini 8ight T Beeping ESC help

Old 07-15-2018, 10:33 PM
  #1  
Tech Regular
Thread Starter
 
D3mOnIcRc8e's Avatar
 
Join Date: Jan 2012
Location: Moreno Valley Ca.
Posts: 281
Default LOSI mini 8ight T Beeping ESC help

So my ESC ( Stock ) on my losi mini 8 t is beeping when i turn it on and gold the set button to change battery types. Not sure what the issue is but i also dont get any receiver funtion at all any more ??? what could it be ?
D3mOnIcRc8e is offline  
Old 07-17-2018, 04:27 PM
  #2  
Tech Regular
Thread Starter
 
D3mOnIcRc8e's Avatar
 
Join Date: Jan 2012
Location: Moreno Valley Ca.
Posts: 281
Default

No one have any idea what the issue could be ??
D3mOnIcRc8e is offline  
Old 07-18-2018, 12:41 PM
  #3  
Tech Regular
 
racknpinion's Avatar
 
Join Date: Aug 2017
Posts: 432
Default

Originally Posted by D3mOnIcRc8e View Post
No one have any idea what the issue could be ??

I seem to recall my stock Dynamite ESC doing something similar when I had my DB. It could be fried, but double check that it's plugged into the correct port on the receiver. Have you tried recalibrating? It could be stuck in calibration mode too, which will beep until you press the SET button. But you have to do some steps in specific sequences. Check the manual and it goes through the procedure. Horizon is also pretty good about helping too if you call them.
racknpinion is offline  
Old 07-18-2018, 09:49 PM
  #4  
Tech Regular
Thread Starter
 
D3mOnIcRc8e's Avatar
 
Join Date: Jan 2012
Location: Moreno Valley Ca.
Posts: 281
Default

Originally Posted by racknpinion View Post
I seem to recall my stock Dynamite ESC doing something similar when I had my DB. It could be fried, but double check that it's plugged into the correct port on the receiver. Have you tried recalibrating? It could be stuck in calibration mode too, which will beep until you press the SET button. But you have to do some steps in specific sequences. Check the manual and it goes through the procedure. Horizon is also pretty good about helping too if you call them.
i believe it might be dead, it was after a crash that this happened and now it wont turn back on, receiver is fine just like it was when it was working, i unplugged the motor in case it was a motor issue and it still does it. when i start it up to get into the set up thats when it just beeps and does not stop. when i turn it on regular it just contently blinks red but i have not response to anything.
D3mOnIcRc8e is offline  
Old 07-19-2018, 10:45 PM
  #5  
Tech Regular
 
racknpinion's Avatar
 
Join Date: Aug 2017
Posts: 432
Default

Originally Posted by D3mOnIcRc8e View Post
i believe it might be dead, it was after a crash that this happened and now it wont turn back on, receiver is fine just like it was when it was working, i unplugged the motor in case it was a motor issue and it still does it. when i start it up to get into the set up thats when it just beeps and does not stop. when i turn it on regular it just contently blinks red but i have not response to anything.

Bummer. Yeah, it could be toast, but I’d still suggest calling Horizon to see what they say. They have always been super helpful and if it’s a new car, they may even send out a free replacement. Wouldn’t hurt to call. I always get better results that vs. email.
racknpinion is offline  
Old 07-24-2018, 03:38 PM
  #6  
Tech Regular
Thread Starter
 
D3mOnIcRc8e's Avatar
 
Join Date: Jan 2012
Location: Moreno Valley Ca.
Posts: 281
Default

Yeah i had got it used about a year and a half ago, so no such luck, they said they could repair it, but i decided to upgrade to the

NEW Traxxas 3370 Velineon VXL-3m Waterproof ESC w/ 380 Brushless Motor

D3mOnIcRc8e is offline  

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information -

Copyright © 2021 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.