Go Back  R/C Tech Forums > General Forums > Radio and Electronics
Icharger x6 Mini 30A Discharge >

Icharger x6 Mini 30A Discharge

Like Tree95Likes

Icharger x6 Mini 30A Discharge

Reply

Old 09-07-2018, 01:13 PM
  #61  
Tech Adept
 
Join Date: Apr 2005
Posts: 156
Default

Originally Posted by AndyArdmore View Post
Correct. To use the Discharge+ function on the ICharger, you will need a new resistor bank. You can make your own if you want.

The Discharge+ function on the charger requires a specific resistance to achieve the desired discharge rate. The X6 itself can dissipate up to 30W maximum. To extend this, we need to use external resistors with heatsinks. Assuming that we allow the X6 to dissipate 30W, and the rest will be dissipated by the resistor bank we make, we can use the following formula to calculate the minimum resistance of our bank:

Resistance minimum = (((Vmax * Id) - P) / Id^2 ) , where Vmax is the max battery voltage, Id is the discharge current, and P is the 30W dissipated from the X6.

This results in the following results for:

2S batteries:
10 Amps: 0.54 Ohms, 54 Watts
20 Amps: 0.345 Ohms, 138 Watts
30 Amps: 0.247 Ohms, 222 Watts

1S batteries:
10 Amps: 0.12 Ohms, 12 Watts
20 Amps: 0.135 Ohms, 54 Watts
30 Amps: 0.107 Ohms, 97 Watts

For the desired discharge rate, you will need a resistor bank of the correct value, and rated for the power dissipation. For 30 Amp, 2S discharge, it looks like 4 x 1 Ohm resistors in parallel, each rated for at least 60W, should work. Be sure to attach these resistors to a large heatsink, to dissipate the heat.

Cheers.
Andy - So if I wanted to discharge a 1s LiPo at 20 Amps, I would need 2 x .5 Ohm resistors in parallel, rated at 50W?
Micro_Racer is offline  
Reply With Quote
Old 09-07-2018, 01:32 PM
  #62  
Tech Initiate
iTrader: (1)
 
Join Date: Jul 2017
Posts: 42
Trader Rating: 1 (100%+)
Default

Originally Posted by Micro_Racer View Post
Andy - So if I wanted to discharge a 1s LiPo at 20 Amps, I would need 2 x .5 Ohm resistors in parallel, rated at 50W?
yes that's what I'm thinking I'll find out as soon as my .5 ohm resistors get it
Wjones1040 is offline  
Reply With Quote
Old 09-07-2018, 05:05 PM
  #63  
Tech Initiate
 
Join Date: Aug 2018
Posts: 21
Default

Originally Posted by Micro_Racer View Post
Andy - So if I wanted to discharge a 1s LiPo at 20 Amps, I would need 2 x .5 Ohm resistors in parallel, rated at 50W?
No. Please read my post again. For 1S at 20 amps, you would need a total resistance of 0.135 Ohms. You could use 2 x 0.27 Ohm resistors in parallel, rated for at least 25W.
Micro_Racer likes this.
AndyArdmore is offline  
Reply With Quote
Old 09-07-2018, 09:37 PM
  #64  
Tech Master
iTrader: (31)
 
Join Date: Mar 2009
Location: Santa Clarita, CA
Posts: 1,977
Trader Rating: 31 (100%+)
Default

Originally Posted by Wjones1040 View Post
Yes that's what I'm thinking
so you get 4 of these?
https://www.ebay.com/itm/1-Ohm-100W-...MAAOSwfjRZ5azf

then maybe get a few of these to cool it down?
https://www.ebay.com/itm/5W-10W-High....c100005.m1851

and what type of glue do you use for the heatsink / fan to attached to the resistors ?
Phillip F is online now  
Reply With Quote
Old 09-08-2018, 12:12 PM
  #65  
Tech Master
iTrader: (31)
 
Join Date: Mar 2009
Location: Santa Clarita, CA
Posts: 1,977
Trader Rating: 31 (100%+)
Default

Originally Posted by RLPowerSupplies View Post
or you could just get one of these and call it a day. https://www.rlpower.net/collections/...silver-edition
would you have an adapter plugs so it will work on the X6?
Phillip F is online now  
Reply With Quote
Old 09-08-2018, 06:51 PM
  #66  
Tech Adept
iTrader: (4)
 
Join Date: Mar 2009
Posts: 181
Trader Rating: 4 (100%+)
Default

Originally Posted by Wjones1040 View Post
Yes that's what I'm thinking
Hey Will I got the resistors and it worked perfect, thanks for the video and demo, this helped a lot.
mrod is offline  
Reply With Quote
Old 09-08-2018, 11:53 PM
  #67  
Tech Master
iTrader: (31)
 
Join Date: Mar 2009
Location: Santa Clarita, CA
Posts: 1,977
Trader Rating: 31 (100%+)
Default

Originally Posted by RLPowerSupplies View Post
This is how I did it for now but Im working on a product to make it easy for people.



does it power the fans as well?

Phillip F is online now  
Reply With Quote
Old 09-09-2018, 10:52 AM
  #68  
Tech Initiate
iTrader: (1)
 
Join Date: Jul 2017
Posts: 42
Trader Rating: 1 (100%+)
Default

Originally Posted by mrod View Post
Hey Will I got the resistors and it worked perfect, thanks for the video and demo, this helped a lot.
Good deal... Waiting for my .5's to show up for my 1s discharge.😊
Wjones1040 is offline  
Reply With Quote
Old 09-09-2018, 11:34 AM
  #69  
Tech Elite
iTrader: (242)
 
Join Date: Sep 2009
Location: Central Wisconsin USA
Posts: 3,748
Trader Rating: 242 (100%+)
Default

I just love my GFX!!!
hanulec and RLPowerSupplies like this.
Andy Koback is offline  
Reply With Quote
Old 09-09-2018, 01:45 PM
  #70  
Tech Initiate
iTrader: (1)
 
Join Date: Jul 2017
Posts: 42
Trader Rating: 1 (100%+)
Default

Originally Posted by Andy Koback View Post
I just love my GFX!!!
me too....
Wjones1040 is offline  
Reply With Quote
Old 09-11-2018, 06:10 AM
  #71  
Tech Adept
 
Join Date: Apr 2005
Posts: 156
Default

Originally Posted by Wjones1040 View Post
I have one, it did not work
what size wire rod are you using to connect the resistors?
Micro_Racer is offline  
Reply With Quote
Old 09-12-2018, 06:42 AM
  #72  
Tech Rookie
 
Join Date: Feb 2011
Posts: 2
Default

Hey wjones1040 where do you get the heatsinks from? Part number if possible please!
TheJudge359 is offline  
Reply With Quote
Old 09-12-2018, 04:02 PM
  #73  
Tech Apprentice
iTrader: (6)
 
Join Date: Aug 2011
Location: louisville, ky
Posts: 73
Trader Rating: 6 (100%+)
Default

ok, i have tried every beta firmware that i can find and tried 3,4,5 1ohm resisters, still can not get this charger to discharge at 30a on a 2cell lipo. what am i doing wrong? can someone please help me out before i throw this thing in the lake
jessesnellen is offline  
Reply With Quote
Old 09-12-2018, 04:23 PM
  #74  
Tech Fanatic
iTrader: (46)
 
Join Date: Oct 2008
Location: Spokane, WA
Posts: 769
Trader Rating: 46 (100%+)
Default

Originally Posted by jessesnellen View Post
ok, i have tried every beta firmware that i can find and tried 3,4,5 1ohm resisters, still can not get this charger to discharge at 30a on a 2cell lipo. what am i doing wrong? can someone please help me out before i throw this thing in the lake
How do you have the resistors wired?
What is the charger showing the discharge current as?
Extra discharge mode is enabled?
biz77 is offline  
Reply With Quote
Old 09-12-2018, 05:12 PM
  #75  
Tech Apprentice
iTrader: (6)
 
Join Date: Aug 2011
Location: louisville, ky
Posts: 73
Trader Rating: 6 (100%+)
Default

extra discharge enabled
shows 3.4amps when discharging
wired in parallel with 5-1ohm (just like all the other discharge banks)
jessesnellen is offline  
Reply With Quote

Thread Tools
Search this Thread

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service