Go Back  R/C Tech Forums > General Forums > Radio and Electronics
Icharger x6 Mini 30A Discharge >

Icharger x6 Mini 30A Discharge

Like Tree95Likes

Icharger x6 Mini 30A Discharge

Reply

Old 09-04-2018, 09:50 PM
  #46  
Tech Master
iTrader: (31)
 
Join Date: Mar 2009
Location: Santa Clarita, CA
Posts: 1,977
Trader Rating: 31 (100%+)
Default

I'm just waiting for someone to figure out and sell the 30A discharger .. .before I buy this icharger x6.
Phillip F is offline  
Reply With Quote
Old 09-05-2018, 07:02 AM
  #47  
Tech Master
 
moparSRT's Avatar
 
Join Date: Oct 2013
Location: Tampa Bay FL
Posts: 1,233
Default

Originally Posted by RLPowerSupplies View Post
That is awesome, only thing keeping me from buying the X6 was the lack of discharge ( im not buying a tiny charger to carry a huge and heavy car battery to the track).
Just ordered a X6 and some 1ohm 100w resistors

What will I do with all the extra pit space

moparSRT is offline  
Reply With Quote
Old 09-05-2018, 09:06 AM
  #48  
Tech Prophet
iTrader: (83)
 
Wildcat1971's Avatar
 
Join Date: Apr 2012
Location: Arizona
Posts: 17,310
Trader Rating: 83 (100%+)
Default

Originally Posted by Phillip F View Post
I'm just waiting for someone to figure out and sell the 30A discharger .. .before I buy this icharger x6.
Just get the skyrc discharger.....
Wildcat1971 is offline  
Reply With Quote
Old 09-05-2018, 04:16 PM
  #49  
R/C Tech Elite Member
 
JayL's Avatar
 
Join Date: Mar 2006
Location: Ca
Posts: 3,043
Default

could you make a resistor with switches to turn banks on and off, then you could choose 10,20,30a discharge?
JayL is offline  
Reply With Quote
Old 09-05-2018, 09:39 PM
  #50  
Tech Initiate
iTrader: (1)
 
Join Date: Jul 2017
Posts: 42
Trader Rating: 1 (100%+)
Default X6 30 amp discharge

Here you go! hope it helps!

Wjones1040 is online now  
Reply With Quote
Old 09-06-2018, 02:06 AM
  #51  
Tech Master
iTrader: (31)
 
Join Date: Mar 2009
Location: Santa Clarita, CA
Posts: 1,977
Trader Rating: 31 (100%+)
Default

Originally Posted by Wjones1040 View Post
Here you go! hope it helps!

https://youtu.be/QrkW0xE7zao

sweet...thank you so much.

https://goo.gl/images/6imyCk
I have this used in my Icharger 308duo. I wonder if this can be used with the X6 and power the fans using the power supply.
Phillip F is offline  
Reply With Quote
Old 09-06-2018, 02:21 AM
  #52  
Tech Initiate
iTrader: (1)
 
Join Date: Jul 2017
Posts: 42
Trader Rating: 1 (100%+)
Default

Originally Posted by Phillip F View Post
sweet...thank you so much.

https://goo.gl/images/6imyCk
I have this used in my Icharger 308duo. I wonder if this can be used with the X6 and power the fans using the power supply.
I have one, it did not work
Wjones1040 is online now  
Reply With Quote
Old 09-06-2018, 04:03 PM
  #53  
Tech Initiate
iTrader: (1)
 
Join Date: Jul 2017
Posts: 42
Trader Rating: 1 (100%+)
Default 1s help

Originally Posted by RLPowerSupplies View Post
Good job!
Thanks!
need help with the 1s 30 amp discharge!
Wjones1040 is online now  
Reply With Quote
Old 09-06-2018, 06:49 PM
  #54  
Tech Adept
iTrader: (4)
 
Join Date: Mar 2009
Posts: 181
Trader Rating: 4 (100%+)
Default

Originally Posted by Wjones1040 View Post
Thanks!
need help with the 1s 30 amp discharge!
I tried this with my existing resistor bank by disconecting the resistors and I couldnt get it to go above 2 amps on the charger discharge, the resister bank is the one you were talking about, are the resistors just the wrong ones on that unit or does it have something to do with the fans, or the firmware on the charger, not really sure, can you shed some light on this for me. Also are you the same will Jones that I used to race 10th scale gas with in the midwest series. Mark Rodney.
mrod is offline  
Reply With Quote
Old 09-06-2018, 07:49 PM
  #55  
Tech Initiate
iTrader: (1)
 
Join Date: Jul 2017
Posts: 42
Trader Rating: 1 (100%+)
Default

Originally Posted by mrod View Post
I tried this with my existing resistor bank by disconecting the resistors and I couldnt get it to go above 2 amps on the charger discharge, the resister bank is the one you were talking about, are the resistors just the wrong ones on that unit or does it have something to do with the fans, or the firmware on the charger, not really sure, can you shed some light on this for me. Also are you the same will Jones that I used to race 10th scale gas with in the midwest series. Mark Rodney.
Yes! Yes! Yes! Mark!

to answer your question yes wrong resistors you have to order (1 ohm) 100w, 50w, 25w how many watts you want, but it has to be a 1 ohm resistors.
Wjones1040 is online now  
Reply With Quote
Old 09-06-2018, 07:52 PM
  #56  
Tech Initiate
iTrader: (1)
 
Join Date: Jul 2017
Posts: 42
Trader Rating: 1 (100%+)
Default

Originally Posted by RLPowerSupplies View Post
Probably you need half the ohms since it's half the voltage.
Wow your right just ordered some 0.5 ohms
Thank you! I'll see if that's the trick
Wjones1040 is online now  
Reply With Quote
Old 09-06-2018, 10:04 PM
  #57  
Tech Adept
iTrader: (4)
 
Join Date: Mar 2009
Posts: 181
Trader Rating: 4 (100%+)
Default

Originally Posted by Wjones1040 View Post
Yes! Yes! Yes! Mark!

to answer your question yes wrong resistors you have to order (1 ohm) 100w, 50w, 25w how many watts you want, but it has to be a 1 ohm resistors.
I thought it was you i recognized your voice in the video, and thought to myself, I know this guy. Thanks for the info. what is the wattage oh the resistors of the bank that doesnt work. I plug that one directly into my battery and it discharges them, but I actually think it is a 40 amp discharge, and that is problably the issue since the x6 only discharges up to 30. I did think that taking some of the resistors off would lower the rate but then it wouldnt go above 2 or 3 amps of discharge. Thanks for posting this it is not easy to understand sometimes and it seem like some of the people didnt want to share simple images of what they did. Not everyone has the technical knowledge of electronics to understand all of the calculations that some of these guys were talking about.
mrod is offline  
Reply With Quote
Old 09-06-2018, 10:47 PM
  #58  
Tech Master
iTrader: (31)
 
Join Date: Mar 2009
Location: Santa Clarita, CA
Posts: 1,977
Trader Rating: 31 (100%+)
Default

Originally Posted by Wjones1040 View Post
Here you go! hope it helps!

https://youtu.be/QrkW0xE7zao
so you get 4 of these?
https://www.ebay.com/itm/1-Ohm-100W-...MAAOSwfjRZ5azf

then maybe get a few of these to cool it down?
https://www.ebay.com/itm/5W-10W-High....c100005.m1851

Last edited by Phillip F; 09-06-2018 at 11:06 PM.
Phillip F is offline  
Reply With Quote
Old 09-06-2018, 11:07 PM
  #59  
Tech Master
iTrader: (31)
 
Join Date: Mar 2009
Location: Santa Clarita, CA
Posts: 1,977
Trader Rating: 31 (100%+)
Default

Originally Posted by Wjones1040 View Post
I have one, it did not work
Do you think why it's not working because the resistors are not 1 ohm each?
Phillip F is offline  
Reply With Quote
Old 09-07-2018, 09:19 AM
  #60  
Tech Initiate
iTrader: (1)
 
Join Date: Jul 2017
Posts: 42
Trader Rating: 1 (100%+)
Default

Originally Posted by Phillip F View Post
Do you think why it's not working because the resistors are not 1 ohm each?
Yes that's what I'm thinking
Wjones1040 is online now  
Reply With Quote

Thread Tools
Search this Thread

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service