Go Back  R/C Tech Forums > General Forums > Racing Forum
Tamiya Championship Series >

Tamiya Championship Series

Like Tree818Likes

Tamiya Championship Series

Old 03-04-2008, 10:45 AM
  #7711  
Tech Regular
 
quantum's Avatar
 
Join Date: Dec 2001
Posts: 415
Default

Originally Posted by Hebiki
hey i finished my GT2 A3 main. and i even made it entertaining!

i seriously think there's something wrong with the esc in my GT1 car. that kept happening in practice too.
are you using a brushless esc?
so far it seems that at high levels of competition, the brushless esc's have been finicky, or outright failing. I know some factory guys who've gone through 3 esc's in one race weekend.
i sincerely hope this is not the case ... otherwise as far as i can tell, the brushless scene has just shifted the motor war to the esc war
quantum is offline  
Old 03-04-2008, 10:46 AM
  #7712  
Tech Master
iTrader: (1)
 
maxepower's Avatar
 
Join Date: Apr 2004
Location: Aliso Viejo, Calif.
Posts: 1,641
Trader Rating: 1 (100%+)
Default TCS RACE!

Thanks Fred and the entire Tamiya crew for putting on a great race and staying on time Sunday so we could get out before dark.
Special thanks to Charlie S. and John at Novak for all the power necessary to make the "A" for me and Timmy. Thanks to Kevin and Muchmore for giving us the charging power we needed, at very last minute.
Chris for trading his MRE to me and eventually to Timmy with his skills put him in the winners circle.
I must also mention that with one Orion 3600 lipo pack for Timmy and I only had one 3200 in mini and one 4800 in GT-2 ran all weekend and the batteries never missed a beat and provided more than enough power to finish! It was close in the triple "A" mains but still one pack did the trick for me and Tim.
Fun fun fun weekend, very proud of Timmy. I guess the acorn doesn't fall far from the tree! heheheh! I had my chances went from 9th to 2nd twice in the mains but couldn't keep it together for 5 min.
Like Timmy said track will still be open I think at least into April so come on down and enjoy it while you can!
maxepower is offline  
Old 03-04-2008, 11:14 AM
  #7713  
Tech Fanatic
iTrader: (54)
 
Join Date: May 2005
Location: CA
Posts: 782
Trader Rating: 54 (100%+)
Default

Yes I have, twice. The car just lost control and came back after a few seconds.
Yellowtaro is offline  
Old 03-04-2008, 12:17 PM
  #7714  
Tech Lord
iTrader: (26)
 
Hebiki's Avatar
 
Join Date: Aug 2003
Location: Chino, CA
Posts: 12,922
Trader Rating: 26 (100%+)
Default

Originally Posted by quantum
are you using a brushless esc?
so far it seems that at high levels of competition, the brushless esc's have been finicky, or outright failing. I know some factory guys who've gone through 3 esc's in one race weekend.
i sincerely hope this is not the case ... otherwise as far as i can tell, the brushless scene has just shifted the motor war to the esc war
Originally Posted by Yellowtaro
Yes I have, twice. The car just lost control and came back after a few seconds.
at first i thought it was the receiver. but i swapped receivers..and it still failed. so that took the receiver out of the question.

it happened 5-6 times during practice. and each time during the GT1 A-mains. like timmy said, i didnt finish a main. my other esc worked flawlessly in GT2. so my theory is something is busted with my esc.

i'll just get it serviced. i just need to wait until the Ko Propo brushless ESC comes out.
Hebiki is offline  
Old 03-04-2008, 03:33 PM
  #7715  
Tech Fanatic
iTrader: (54)
 
Join Date: May 2005
Location: CA
Posts: 782
Trader Rating: 54 (100%+)
Default

Funny thing is that the car that glitched was my GT-2 which was had a Novak esc and my LRP broke (shut down) at the end of race 30 on my Gt-1 car..... My LRP was barely 3 months old and I took good care of it.
Yellowtaro is offline  
Old 03-04-2008, 04:29 PM
  #7716  
Tech Master
iTrader: (1)
 
Join Date: Jul 2004
Location: MI
Posts: 1,544
Trader Rating: 1 (100%+)
Default TCS @ Trackside

Could any one link me to the pics from Scotties?
I heard theres a ton of them of all cars ... HELP!!
John St.Amant is offline  
Old 03-04-2008, 05:45 PM
  #7717  
Tech Elite
iTrader: (8)
 
rccardr's Avatar
 
Join Date: Aug 2003
Location: The Secret Underground Laboratory
Posts: 2,353
Trader Rating: 8 (100%+)
Default

Who would ever use such a stupid and evil screen name as John St. Amant? What twisted mind would ever THINK to do such a thing? What evil lurks behind the otherwise innocent.....oh. It's John.

Try this link, man:
http://flickr.com/photos/[email protected]/
rccardr is offline  
Old 03-04-2008, 06:44 PM
  #7718  
Tech Master
iTrader: (44)
 
Join Date: Nov 2003
Location: Huntsville, Alabama
Posts: 1,660
Trader Rating: 44 (100%+)
Default

I'm a few days late but still wanted to send props out to Fred, Gary, Larry, Andrew, and the Tamiya crew. I had a great time, as always. Mini was tough, as usual. My Swift was traction rolling so bad I switched to the short-bus to finish up on Sunday. The Tamtech On-road was once again a total blast. Too bad it never made it past the TCS cut list.

I left my box 'O gear at my SoCal LoCal, just in case you can swing a venue at the Spectrum or other great Orange County location. In the immortal words of your Gubernator Arnold --- "I'll be back!"

Bill "Don't call me Dotty" Doty
minimadman2003 is offline  
Old 03-04-2008, 07:43 PM
  #7719  
Tech Master
 
Three's Avatar
 
Join Date: Feb 2005
Location: Madphis, Tn.
Posts: 1,485
Default

Sounds like everyone had way too much fun.

Last edited by Three; 03-05-2008 at 05:25 AM.
Three is offline  
Old 03-05-2008, 10:36 AM
  #7720  
Tech Lord
iTrader: (26)
 
Hebiki's Avatar
 
Join Date: Aug 2003
Location: Chino, CA
Posts: 12,922
Trader Rating: 26 (100%+)
Default

someone tell that green Ferrari he's going the wrong way!

Hebiki is offline  
Old 03-05-2008, 02:15 PM
  #7721  
Tech Fanatic
iTrader: (11)
 
SirSwiftAlot's Avatar
 
Join Date: Jul 2007
Location: SOCAL the fastest mini cooper guys in the nation
Posts: 862
Trader Rating: 11 (100%+)
Default

What a great weekend of racing wana give a huge round of applause to Gary, Fred, Larry, and all the other boys in tech if it were'nt for you guys we wouldn't have this oppurtunity. Thanks to Grandpa for letting me use one of his motors that he prchased form Doc (GO RED DOT POWER) Doc thanks for your amusement in the pits. I would also like to thank Orlando for the great sportsmanship on the stand ( you know what I mean ) glad your car finally hooked up and I don't mind helping someone out even if they are my competitor it just makes me want to drive even harder. I didn't realize that I won a speedcontroller for winning MINI I thought it was a servo huge PROPS to KO PROPO. Vintage class was sweeeeet hope we get a class for Union City me and the boys are heading up for TCS in June. Thanks to Devon for teching the motors and keeping "everyone" honest, sorry dylan's car didn't handle that well and to Marty Hageman - Knock Knock ?

If anyone was curious I was running a mid chassis with a Lipo what was everyone else running in MINI?
SirSwiftAlot is offline  
Old 03-05-2008, 03:03 PM
  #7722  
Tech Elite
 
Join Date: Oct 2006
Posts: 2,367
Default

Originally Posted by SirSwiftAlot
If anyone was curious I was running a mid chassis with a Lipo what was everyone else running in MINI?
I was running very slow.
Granpa is offline  
Old 03-05-2008, 09:58 PM
  #7723  
Tech Champion
iTrader: (107)
 
lbckevin's Avatar
 
Join Date: Jan 2003
Location: Orange County, CA
Posts: 5,731
Trader Rating: 107 (99%+)
Default

I ran lipo and brushless, but my car only lasted for a minute...then poof....there went another speed control.
lbckevin is offline  
Old 03-05-2008, 10:12 PM
  #7724  
Tech Elite
 
Join Date: Oct 2006
Posts: 2,367
Default

Originally Posted by lbckevin
I ran lipo and brushless, but my car only lasted for a minute...then poof....there went another speed control.
I thot brushless was maintenance free. Give me a 15,000 @ 5v Mabuchi any day. Mabuchi --- $17 Brushless Esc $ ????? Probably more than a Mabuchi. That's for Mini racing.
Granpa is offline  
Old 03-06-2008, 09:33 AM
  #7725  
Tech Master
iTrader: (6)
 
240Z's Avatar
 
Join Date: Mar 2008
Posts: 1,119
Trader Rating: 6 (100%+)
Default TCS scoring

I am kind of new to the TCS race scoring system. It all seemed to make sense to me till I looked at the results for the Spec Novice class.

http://www.tamiyausa.com/tcs_races/l..._AAA_Mains.PDF

I have a problem with the A3 main in particular. James won that race. Fred did not realize that his laps were not being counted and said he had fixed it in the middle of the race, but the posted number of laps must not be correct. I believe the posted time is correct but he completed 14 laps, not the 12 laps shown.

If he had been posted as finishing first in A3, how would that have affected his over all placing?

Do the posted results for A1 and A2 make sense to anyone?
240Z is offline  

Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service -

Copyright © 2024 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.