FS: Sanwa M17

Old 09-16-2019, 08:51 AM
  #1  
Tech Elite
Thread Starter
iTrader: (47)
 
K_King's Avatar
 
Join Date: Jul 2006
Location: San Diego, CA
Posts: 4,233
Trader Rating: 47 (100%+)
Default FS: Sanwa M17

Sold

Only issue is the stupid plug they used broke off my 1st day with it, you can glue it back on as I did, but it's just a silly piece they included.

Rx was never used as well.

Any other questions please ask.

Thank you




Last edited by K_King; 09-16-2019 at 01:40 PM.
K_King is offline  
Old 09-16-2019, 09:16 AM
  #2  
Tech Regular
iTrader: (13)
 
Flyintaco138's Avatar
 
Join Date: Dec 2011
Posts: 256
Trader Rating: 13 (93%+)
Default

PM sent
Flyintaco138 is offline  
Old 09-16-2019, 10:23 AM
  #3  
Tech Regular
iTrader: (13)
 
Flyintaco138's Avatar
 
Join Date: Dec 2011
Posts: 256
Trader Rating: 13 (93%+)
Default

Money sent
Flyintaco138 is offline  
Old 09-16-2019, 10:47 AM
  #4  
Tech Addict
iTrader: (13)
 
Join Date: Nov 2016
Posts: 727
Trader Rating: 13 (100%+)
Default

Damn. Missed another one
Baha x is offline  
Old 09-16-2019, 01:39 PM
  #5  
Tech Elite
Thread Starter
iTrader: (47)
 
K_King's Avatar
 
Join Date: Jul 2006
Location: San Diego, CA
Posts: 4,233
Trader Rating: 47 (100%+)
Default

Sold
K_King is offline  

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information -

Copyright © 2022 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.