Go Back  R/C Tech Forums > General Forums > Oval, Larger Scales and More
HiTec HS-7980TH.... Whose Running One? >

HiTec HS-7980TH.... Whose Running One?

HiTec HS-7980TH.... Whose Running One?

Reply

Old 12-06-2015, 02:18 PM
  #1  
Tech Adept
Thread Starter
 
Join Date: Apr 2015
Location: Long Island NY
Posts: 119
Default HiTec HS-7980TH.... Whose Running One?

I picked up one of these servo's in the spring time for my throttle/brake and it's been constant issues with it glitching. Right out of the packaging it gave me trouble. I had to wrap it well in electrical tape just to keep it from touching my alloy servo tray otherwise it glitches. Once the tape get's some dust or sand around it the problem comes back. Also get on and off glitching when I run 7.4v. I should have sent it back months ago but it was working on and off so I didn't wanna deal with any down time sending it back to them. Since I'm just about done for the season (and the servo completely burnt out today) here I plan on sending it in for replacement....... My question for those of you who use/used this servo, have you experienced any of the problems I have? I'm debating on whether or not to just sell it and go with something different after I send it in...... It seems to be a good servo when working, plenty of torque for my cable brakes but it does seem to get a bit warmer then any other servo I have/had. I just really don't wanna deal with anymore glitching.


Any input would be appreciated. Thanks
Lone Racer is offline  
Reply With Quote

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Thread Tools
Search this Thread

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service