R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Nitro On-Road > Onroad Nitro Engine Zone

Reply
 
Thread Tools Search this Thread
Old 03-29-2013, 10:32 PM   #1
Tech Master
 
BigC2007's Avatar
 
Join Date: Sep 2007
Posts: 1,459
Trader Rating: 6 (100%+)
Default Help with ....... Novarossi 35 Plus 21 LC/WC09

Enjoy running in the 2013 Airtronics GP at GLARCRC this past weekend, but my 966 keep running rich after the 2nd or 3rd lap, after this I brought it in and leaned it out and again ran great for another 3-4 laps then again it seem like it would start to run rich again.

Before the mains I installed a new glow plug and check all fuel lines and again after 4 laps it seem to start running rich again. Any help on this problem would be greatly appreciated.

P.S This is my 1st time running this motor and I did notice it has a 3 screw adjustment on it maybe I need to adjust all 3?
__________________
BigC

1 Corinthians 1:18
For the message of the cross is foolishness to those who are perishing, but to us who are being saved it is the power of God.
BigC2007 is offline   Reply With Quote
Old 03-30-2013, 07:49 AM   #2
Tech Master
 
Grinder's Avatar
R/C Tech Elite Subscriber
 
Join Date: Feb 2003
Posts: 1,857
Trader Rating: 2 (100%+)
Default

Quote:
Originally Posted by BigC2007 View Post
Enjoy running in the 2013 Airtronics GP at GLARCRC this past weekend, but my 966 keep running rich after the 2nd or 3rd lap, after this I brought it in and leaned it out and again ran great for another 3-4 laps then again it seem like it would start to run rich again.

Before the mains I installed a new glow plug and check all fuel lines and again after 4 laps it seem to start running rich again. Any help on this problem would be greatly appreciated.

P.S This is my 1st time running this motor and I did notice it has a 3 screw adjustment on it maybe I need to adjust all 3?
Is it fully run in? How much fuel have you run through the engine in total?
__________________
www.murnanmodified.com
Grinder is offline   Reply With Quote
Old 03-30-2013, 08:49 AM   #3
Tech Champion
 
Roelof's Avatar
 
Join Date: Aug 2007
Location: Holland
Posts: 6,284
Send a message via ICQ to Roelof
Default

Check the seal on the tank cap and try another exhaust
__________________
The quality of an answer comes with the quality of the question.
Roelof is offline   Reply With Quote
Old 03-30-2013, 11:00 AM   #4
Tech Master
 
BigC2007's Avatar
 
Join Date: Sep 2007
Posts: 1,459
Trader Rating: 6 (100%+)
Default

Quote:
Originally Posted by Grinder View Post
Is it fully run in? How much fuel have you run through the engine in total?
I believe a little less then 1 gallon has gone threw it.
__________________
BigC

1 Corinthians 1:18
For the message of the cross is foolishness to those who are perishing, but to us who are being saved it is the power of God.
BigC2007 is offline   Reply With Quote
Old 03-30-2013, 11:01 AM   #5
Tech Master
 
BigC2007's Avatar
 
Join Date: Sep 2007
Posts: 1,459
Trader Rating: 6 (100%+)
Default

Quote:
Originally Posted by Roelof View Post
Check the seal on the tank cap and try another exhaust
Thanks I well try both.
__________________
BigC

1 Corinthians 1:18
For the message of the cross is foolishness to those who are perishing, but to us who are being saved it is the power of God.
BigC2007 is offline   Reply With Quote
Old 03-30-2013, 11:16 AM   #6
Tech Champion
 
nitrodude's Avatar
 
Join Date: Aug 2002
Location: Oxnard, CA
Posts: 5,845
Trader Rating: 5 (100%+)
Default

Quote:
Originally Posted by BigC2007 View Post
I believe a little less then 1 gallon has gone threw it.
Its still breaking in, thats why it goes rich. It takes about a gallon for a Novarossi to be fully broken in. Its pretty close though.
__________________
Steven Muller
AKA El Pibe RUFAST? HAHA!!!
Ronin Speed Parts
nitrodude is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 03:46 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net