Like Tree7Likes

2013 Torque line by Picco

Reply

Old 12-29-2017, 10:50 AM
  #511  
Tech Master
iTrader: (13)
 
Join Date: Jan 2004
Posts: 1,376
Trader Rating: 13 (100%+)
Default

does anybody remember the rod part # to this .12?
Attached Thumbnails 2013 Torque line by Picco-picco3.gif  
Brian Bosley is offline  
Reply With Quote
Old 12-31-2017, 07:08 AM
  #512  
Tech Regular
iTrader: (5)
 
danthrc's Avatar
 
Join Date: Jan 2007
Location: Katy Texas
Posts: 494
Trader Rating: 5 (100%+)
Default

Guys I have a question. Im not completely new at Nitro .21 engines as I used to run them in off road years ago. I just took up 8th scale open and run the Picco Team R1. On my first race a few weeks back it ran flawless and smooth with the tune that I had on it in all of the qualifiers, in fact I made the A out of about 20 racers. When we got to the main and I made the first pit stop and re fuled, I had the dreaded flame out when I got to the back straight which is about 6 seconds after the pit stop (at speed) ran great till I was full tilt and then "flame" Is this more related to the low needle tune or the high needle? Car had a great smoke trail and would come off around 140 after 5 min. Any advice would help.
danthrc is offline  
Reply With Quote
Old 12-31-2017, 01:11 PM
  #513  
Tech Elite
 
fyrstormer's Avatar
 
Join Date: Mar 2014
Location: Maryland, Near DC, USA
Posts: 3,757
Default

If you were running "full tilt" then it must've been the HSN that was incorrectly adjusted. If it stalled when you let off the throttle, even for a split second, then that would be an incorrect LSN or idle-gap adjustment.
fyrstormer is offline  
Reply With Quote
Old 12-31-2017, 05:19 PM
  #514  
Tech Regular
iTrader: (5)
 
danthrc's Avatar
 
Join Date: Jan 2007
Location: Katy Texas
Posts: 494
Trader Rating: 5 (100%+)
Default

Originally Posted by fyrstormer View Post
If you were running "full tilt" then it must've been the HSN that was incorrectly adjusted. If it stalled when you let off the throttle, even for a split second, then that would be an incorrect LSN or idle-gap adjustment.
Yes, full tilt. Out of the pits we go about 80ft to a sweeper that leads to the back long straight. Throttling wide open out of the sweeper about the moment it hit enough RPM to hit second is when it flamed.
Would it be a symptom of too lean or too rich on HSN? I don't think I was too lean with the smoke trail and temps I was running.
danthrc is offline  
Reply With Quote
Old 12-31-2017, 08:23 PM
  #515  
Tech Master
iTrader: (6)
 
BigC2007's Avatar
 
Join Date: Sep 2007
Posts: 1,542
Trader Rating: 6 (100%+)
Default

Originally Posted by danthrc View Post
Yes, full tilt. Out of the pits we go about 80ft to a sweeper that leads to the back long straight. Throttling wide open out of the sweeper about the moment it hit enough RPM to hit second is when it flamed.
Would it be a symptom of too lean or too rich on HSN? I don't think I was too lean with the smoke trail and temps I was running.
Is this s new picco ? if not how much fuel ran threw it ?
BigC2007 is offline  
Reply With Quote
Old 01-01-2018, 07:49 AM
  #516  
Tech Regular
iTrader: (5)
 
danthrc's Avatar
 
Join Date: Jan 2007
Location: Katy Texas
Posts: 494
Trader Rating: 5 (100%+)
Default

Originally Posted by BigC2007 View Post
Is this s new picco ? if not how much fuel ran threw it ?

Its the R1 Team DLC CER. First race with it. Only 4 race tanks after full and proper break in. 5th race with it was the main.
danthrc is offline  
Reply With Quote
Old 01-01-2018, 01:46 PM
  #517  
Tech Fanatic
iTrader: (4)
 
Join Date: Feb 2002
Location: Greenwood, IN
Posts: 933
Trader Rating: 4 (100%+)
Default

Originally Posted by danthrc View Post
Its the R1 Team DLC CER. First race with it. Only 4 race tanks after full and proper break in. 5th race with it was the main.
What car is it in?
windellmc is offline  
Reply With Quote
Old 01-01-2018, 02:08 PM
  #518  
Tech Regular
iTrader: (5)
 
danthrc's Avatar
 
Join Date: Jan 2007
Location: Katy Texas
Posts: 494
Trader Rating: 5 (100%+)
Default

Originally Posted by windellmc View Post
What car is it in?
Serpent 977 EVO II
danthrc is offline  
Reply With Quote
Old 03-22-2018, 03:00 AM
  #519  
Tech Adept
 
Join Date: Apr 2006
Posts: 204
Default Pipe for Picco R1 Team?

Hi guys, got myself a Picco .21 R1 Team for the 8th scale onroad recently.

Question is what pipe best matches the engine?

My LHS has access to REDS pipe and not picco, wondering if the REDS pipe would work well?
lance04 is offline  
Reply With Quote
Old 03-22-2018, 06:55 PM
  #520  
Tech Regular
iTrader: (13)
 
Join Date: Feb 2014
Location: Canberra
Posts: 298
Trader Rating: 13 (100%+)
Default

Originally Posted by lance04 View Post
Hi guys, got myself a Picco .21 R1 Team for the 8th scale onroad recently.

Question is what pipe best matches the engine?

My LHS has access to REDS pipe and not picco, wondering if the REDS pipe would work well?
I think they are the same pipes...just badged differently.
jtrmx250 is offline  
Reply With Quote
Old 03-23-2018, 03:26 AM
  #521  
Tech Addict
 
Join Date: Dec 2010
Location: Sweden
Posts: 637
Default

Originally Posted by lance04 View Post
Hi guys, got myself a Picco .21 R1 Team for the 8th scale onroad recently.

Question is what pipe best matches the engine?

My LHS has access to REDS pipe and not picco, wondering if the REDS pipe would work well?
Hipex 2069, Reds 2113, Picco 2120, should all be the same pipe.
NitroVein is offline  
Reply With Quote
Old 03-23-2018, 05:52 AM
  #522  
Tech Adept
 
Join Date: Apr 2006
Posts: 204
Default

Originally Posted by NitroVein View Post
Hipex 2069, Reds 2113, Picco 2120, should all be the same pipe.
Noted and also thanks to jtrmx250 for replying. Appreciate it! Got myself a Reds2113 today
lance04 is offline  
Reply With Quote
Old 03-24-2018, 06:53 AM
  #523  
Tech Master
iTrader: (1)
 
GREGORY!'s Avatar
 
Join Date: Jun 2006
Location: Greece
Posts: 1,085
Trader Rating: 1 (100%+)
Default

Originally Posted by Brian Bosley View Post
does anybody remember the rod part # to this .12?
#1532 for the modified rod,
#1420 for the normal one.
GREGORY! is offline  
Reply With Quote
Old 09-01-2018, 12:33 PM
  #524  
Tech Adept
 
Join Date: Apr 2009
Location: Ukraine
Posts: 102
Default

Hello guys, I have Picco .12 EMX WC, I use Hypex 2669 pipe with 30mm manifold. Engine is new, just after breaking-in.
I have huge problems with acceleration. Top speed is good but bottom range is very poor.
I use 16% fuel and 0.6 mm shim under head.
Glow plug is novarossi C6TGF.

Can someone advise some base setting for 16% fuel?
B.S. is offline  
Reply With Quote
Old 09-01-2018, 02:06 PM
  #525  
Tech Master
iTrader: (1)
 
GREGORY!'s Avatar
 
Join Date: Jun 2006
Location: Greece
Posts: 1,085
Trader Rating: 1 (100%+)
Default

Originally Posted by B.S. View Post
Hello guys, I have Picco .12 EMX WC, I use Hypex 2669 pipe with 30mm manifold. Engine is new, just after breaking-in.
I have huge problems with acceleration. Top speed is good but bottom range is very poor.
I use 16% fuel and 0.6 mm shim under head.
Glow plug is novarossi C6TGF.

Can someone advise some base setting for 16% fuel?
why 0.6mm shimming for 16% nitro?
GREGORY! is offline  
Reply With Quote

Thread Tools
Search this Thread

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service