R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Nitro On-Road > Onroad Nitro Engine Zone

Reply
 
Thread Tools Search this Thread
Old 08-12-2010, 08:13 PM   #1
Tech Adept
 
NitroChef tC3's Avatar
 
Join Date: Jul 2010
Location: Buford, Ga
Posts: 122
Default Problems tuning a max xxl3

I am tuning my xxl3 and am having problems... Seems like I have to tune it every 30 min.. My buddy just put a picco 7 port in his ride and seems to have no problems keeping a tune.. Is this typical for this motor?? I get it running good and then about three quarters through the tank it will stall.. Then has problems starting... Have to prime the engine alot... Any tips, comments , feedback will be greatly appreciated.... This is my first slide carb and " nice" motor...
__________________
Team Associated Ntc3 +
Novarossi max xxl3 .12..
Ofna in-line dual chamber pipe..
Ae factory team shocks..
Bsr foams
NitroChef tC3 is offline   Reply With Quote
Old 08-12-2010, 08:40 PM   #2
Tech Elite
 
Phil Trotta's Avatar
 
Join Date: Feb 2005
Posts: 2,452
Trader Rating: 4 (100%+)
Default

Quote:
Originally Posted by NitroChef tC3 View Post
I am tuning my xxl3 and am having problems... Seems like I have to tune it every 30 min.. My buddy just put a picco 7 port in his ride and seems to have no problems keeping a tune.. Is this typical for this motor?? I get it running good and then about three quarters through the tank it will stall.. Then has problems starting... Have to prime the engine alot... Any tips, comments , feedback will be greatly appreciated.... This is my first slide carb and " nice" motor...
Bottom end may be too lean open it up a few hours
__________________
PHIL TROTTA
Phil Trotta is offline   Reply With Quote
Old 08-12-2010, 09:08 PM   #3
Tech Master
 
el salvador's Avatar
 
Join Date: May 2006
Location: Western Seattle Bucko!
Posts: 1,072
Trader Rating: 7 (100%+)
Default

Make sure the Carb is completely seated and the retaining screw is sufficiently tight! Exhaust seals in good condition, ect.
__________________
ARC R8 X2/ Max RP9 or O.S. R2101 ,Capricorn LAB C02-TOP Elite R, ARC R11....

"Every Cemetery in Chicago Votes Democrat!"
el salvador is offline   Reply With Quote
Old 08-12-2010, 11:30 PM   #4
Tech Elite
 
stefan's Avatar
 
Join Date: Aug 2001
Location: Bavaria, Germany
Posts: 3,273
Send a message via AIM to stefan
Default

Quote:
Originally Posted by NitroChef tC3 View Post
I am tuning my xxl3 and am having problems... Seems like I have to tune it every 30 min.. My buddy just put a picco 7 port in his ride and seems to have no problems keeping a tune.. Is this typical for this motor?? I get it running good and then about three quarters through the tank it will stall.. Then has problems starting... Have to prime the engine alot... Any tips, comments , feedback will be greatly appreciated.... This is my first slide carb and " nice" motor...
Hi there,

are you running at the Sugar Bowl?

Two things come to mind:

Is you glow plug ok? Which plug are you running?

Secondly, I (and many others at the Bowl) always had engine problems when running the NTC3.
Main problem is, that the carburator sits directly behind the engine and gets no cooling air, but all the heat from the cooling head.
The other major problem of this particular car was the exhaust system.
This pipe was not the best 10 years ago with the relatively low powered engines at the time.
I just can't imagine that it would work with the current breed of engines, especially top of the line stuff like the XXL3.

We have done the strangest attempts to run regular pipes on that car, where the pipes came out óf the rear window, but nothing ever worked really good.
I think that was the main reason why the car died away.
stefan is offline   Reply With Quote
Old 08-13-2010, 02:01 AM   #5
Tech Adept
 
gfilos's Avatar
 
Join Date: Aug 2008
Location: Greece
Posts: 230
Default

Quote:
Originally Posted by NitroChef tC3 View Post
I am tuning my xxl3 and am having problems... Seems like I have to tune it every 30 min.. My buddy just put a picco 7 port in his ride and seems to have no problems keeping a tune.. Is this typical for this motor?? I get it running good and then about three quarters through the tank it will stall.. Then has problems starting... Have to prime the engine alot... Any tips, comments , feedback will be greatly appreciated.... This is my first slide carb and " nice" motor...
try richen it a bit. Tune the high speed needle until motor runs fine, smoke is visible and temps are about 110-130C.
Then bring the car in pits, let it idle for 7-8 sec and do a full throttle for 2-3 sec at a stand. If it revs up immediately, richen a bit the low-speedneedle. Repeat the test until motor revs up but goes slightly rich first before increasing its rpms. Hope i made myself clear. If car come to pits with increased idle and then idle drops also richen the low-speed needle.
__________________
Serpent 720 09 mega zx 12 dsII+, Serpent 733 nova 353 tuned/sirio XXXV
Futaba, Graupner, Hudy, RB fuel

Last edited by gfilos; 08-13-2010 at 02:17 AM.
gfilos is offline   Reply With Quote
Old 08-15-2010, 08:05 PM   #6
Tech Adept
 
NitroChef tC3's Avatar
 
Join Date: Jul 2010
Location: Buford, Ga
Posts: 122
Default Thanks

Thanks for the tips... My next day out at the track I will try them out... Also I am running with a dynamite platinum competition #8 cold glow plug.. It's all the hobby shop had... Could this be a factor?? Are these any good?? Any suggestions on plugs...? Just don't understand why it will run and then just sto p after a few laps... What is a good temp to run this motor???
__________________
Team Associated Ntc3 +
Novarossi max xxl3 .12..
Ofna in-line dual chamber pipe..
Ae factory team shocks..
Bsr foams
NitroChef tC3 is offline   Reply With Quote
Old 08-15-2010, 09:35 PM   #7
Tech Master
 
Join Date: Dec 2005
Location: (Holiday, Fl.) (CST.Allentown, Pa.)
Posts: 1,252
Trader Rating: 24 (100%+)
Default

Quote:
Originally Posted by NitroChef tC3 View Post
Thanks for the tips... My next day out at the track I will try them out... Also I am running with a dynamite platinum competition #8 cold glow plug.. It's all the hobby shop had... Could this be a factor?? Are these any good?? Any suggestions on plugs...? Just don't understand why it will run and then just sto p after a few laps... What is a good temp to run this motor???
novarossi plugs
RANDY SMOOTH is offline   Reply With Quote
Old 08-15-2010, 10:48 PM   #8
Tech Adept
 
NitroChef tC3's Avatar
 
Join Date: Jul 2010
Location: Buford, Ga
Posts: 122
Default

Quote:
Originally Posted by RANDY SMOOTH View Post
novarossi plugs
Is there a particular one I should run??
__________________
Team Associated Ntc3 +
Novarossi max xxl3 .12..
Ofna in-line dual chamber pipe..
Ae factory team shocks..
Bsr foams
NitroChef tC3 is offline   Reply With Quote
Old 08-16-2010, 12:39 AM   #9
Tech Adept
 
gfilos's Avatar
 
Join Date: Aug 2008
Location: Greece
Posts: 230
Default

Quote:
Originally Posted by NitroChef tC3 View Post
Is there a particular one I should run??
i would go with a nova C6TGF. i am assumming youre running 16%nitro correct?
__________________
Serpent 720 09 mega zx 12 dsII+, Serpent 733 nova 353 tuned/sirio XXXV
Futaba, Graupner, Hudy, RB fuel
gfilos is offline   Reply With Quote
Old 08-16-2010, 09:14 AM   #10
Tech Adept
 
NitroChef tC3's Avatar
 
Join Date: Jul 2010
Location: Buford, Ga
Posts: 122
Default

Quote:
Originally Posted by gfilos View Post
i would go with a nova C6TGF. i am assumming youre running 16%nitro correct?
Currently running 20% ... how do I change.. Is there a process..
__________________
Team Associated Ntc3 +
Novarossi max xxl3 .12..
Ofna in-line dual chamber pipe..
Ae factory team shocks..
Bsr foams
NitroChef tC3 is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 03:11 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net