Like Tree2Likes
  • 1 Post By hansi31
  • 1 Post By mstrfahrenheit

Help starting engine

Reply

Old 02-09-2018, 09:10 PM
  #1  
Tech Adept
Thread Starter
iTrader: (2)
 
Join Date: Mar 2012
Location: San Diego
Posts: 101
Trader Rating: 2 (100%+)
Default Help starting engine

This is embarrassing but I can't get my engine to fire...

This is my first nitro build (Losi 8T). I had my motor broken in by Adam Drake and got everything installed today, I should be ready to go.

I put the glow plug on (confirmed its charged and lighting up), place the truggy on the starter, open the carb, push down, and.... nothing.

I'm not exactly sure what is supposed to happen. I've never used a starter.

The flywheel doesn't appear to be spinning and I can't even rotate it by hand. It does seem fuel has been sucked into the tube.

I'm really not sure what to even check. Help!#?
mstrfahrenheit is offline  
Reply With Quote
Old 02-09-2018, 09:18 PM
  #2  
Tech Adept
Thread Starter
iTrader: (2)
 
Join Date: Mar 2012
Location: San Diego
Posts: 101
Trader Rating: 2 (100%+)
Default

After researching I may have hydrolocked it, thats why it wont rotate. Found some instructions on how to deal with that, will give it a try in the am.

I also don't think I primed as per what I just read... Growing pains I guess
mstrfahrenheit is offline  
Reply With Quote
Old 02-09-2018, 09:37 PM
  #3  
Tech Addict
iTrader: (1)
 
Join Date: Dec 2016
Posts: 524
Trader Rating: 1 (100%+)
Default

Did you heat the engine to about 200 degrees before starting?

Last edited by Cardiak; 02-09-2018 at 10:30 PM.
Cardiak is offline  
Reply With Quote
Old 02-09-2018, 11:32 PM
  #4  
Tech Initiate
 
Join Date: Mar 2016
Location: Norway
Posts: 35
Default

Untighten your plug half out, and then put your igniter on. Push the car down, it will spoil some fuel but it doesn't matter. When it starts tighten your plug, and then you're ready to go.
Or just replace your plug..
Thats my opinion😀
Sorry for bad English, but hope you understand😀
Houmb likes this.
hansi31 is offline  
Reply With Quote
Old 02-10-2018, 03:23 AM
  #5  
Tech Master
iTrader: (89)
 
Join Date: Dec 2010
Location: Sonora, California
Posts: 1,247
Trader Rating: 89 (100%+)
Default

Definitely need to heat it up. My protek samurai after 15 tanks will not turn over without heating it up. A heat gun or engine warmer is a must.
b121774 is online now  
Reply With Quote
Old 02-10-2018, 03:20 PM
  #6  
Tech Master
iTrader: (6)
 
Join Date: Oct 2008
Location: Houston, TX
Posts: 1,195
Trader Rating: 6 (100%+)
Default

to prime the engine for starting, place the truggy down on the box. Do not put the glow ignitor on the plug. Hold your finger over the exhaust and press down on the truck. Look for the fuel to go into the inlet of the high speed needle. You should be good to go then.
Evoking1230 is offline  
Reply With Quote
Old 02-10-2018, 09:48 PM
  #7  
Tech Adept
Thread Starter
iTrader: (2)
 
Join Date: Mar 2012
Location: San Diego
Posts: 101
Trader Rating: 2 (100%+)
Default

alright, freed it up out of hydrolock.

wasn't heating so i picked up a heat gun this evening. Will try again in the am.

thanks!
stanleyw808 likes this.
mstrfahrenheit is offline  
Reply With Quote
Old 02-11-2018, 12:17 PM
  #8  
Tech Adept
Thread Starter
iTrader: (2)
 
Join Date: Mar 2012
Location: San Diego
Posts: 101
Trader Rating: 2 (100%+)
Default

That did it! Heating then priming and she started like a champ.

Thanks guys.
mstrfahrenheit is offline  
Reply With Quote

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Thread Tools
Search this Thread

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service