R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Nitro On-Road

Reply
 
Thread Tools Search this Thread
Old 02-24-2007, 01:49 PM   #4441
Tech Elite
 
Kodak Hodak's Avatar
 
Join Date: Nov 2006
Location: South Australia, Australia
Posts: 2,159
Trader Rating: 10 (100%+)
Send a message via MSN to Kodak Hodak Send a message via Yahoo to Kodak Hodak Send a message via Skype™ to Kodak Hodak
Default

Quote:
Originally Posted by razzor
Hey guys ,i found a pdf on my pc that I forgot about.I think this is a essential addition to any racers tool box for diagnosing setup issues.
Its by Serpent for the 710 but applies universally.
Cant believe I forgot about this.

Hey Cheers Razzor, noted, printed and filed in my trusty folder that i carry!!!!

Speak soon guys - I HAVE GONE rACING
__________________
★ DORMANT RC RACER ★
Kodak Hodak is offline   Reply With Quote
Old 02-24-2007, 07:28 PM   #4442
Tech Elite
 
nitrobeast's Avatar
 
Join Date: Apr 2006
Location: Colonia, NJ
Posts: 2,340
Trader Rating: 41 (100%+)
Default

Quote:
Originally Posted by Serpentd
Razzor Dude, at least it was trimmed out well. Impressive. Sounds as though the engine was just right as well since it probably ran out of fuel.

I have about 10+ planes including my pride and joy F16 Pusher prop. The only issue I have ever had is a dead spot on an ailoron servo. Managed to do a soft landing in a field with minimal damage. I am too scared to take up my pusher prop F16 for a lot of reasons. For example the 50 hours of detail and work alone for the cockpit, you can imagine the hours and money into this plane. More the hours then anything. It took over 9 months to build with me working on it every night after work. I know I will fly it one of these days. I love to fly RC planes, but it's a way different feeling then our cars. Will post a few pics.

Anyway, back to Nitrobeast's problem here. OK dude, I have given it a lot of thought and here is my suggestion to you.

1. Take out ALL of the radio equipment in the car. Even take it off of the radio tray to where all you have is your radio equipment and nothing more. We need to start with basics I think.

2. Then hook up everything to receiver just as it would be in the car. Plug your servos and everything in.

3. Bind the radio to receiver.

4. I'm not sure of the distance that it will start to clitch, but turn on radio and plug in battery to receiver so everything is operational. I would go outside and set your radio down and start walking away until it starts to glitch. If it glitches next to the radio, put the radio about 5 or 10 feet away and don't worry about going outside at this point.

5. Observe what is glitching, Like servo 1 or servo 2 etc. Unplug the servo that glitches and try it in the slot of the other servo that doesn't glitch. Observe what is going on. Also, try the good or your Hitec servo in the other receiver slot. Observe your findings.

6. Keep trying all the different combos to narrow down what is going on. Even try your other servos, battery's or recievers if need be. I think you understand what I am saying here. All we're trying to do is what you already have been doing but out of the car.

7. After you think you found the issue and have a stable platform, then go outside and do the radio test. See how far you can walk away from the radio with the radio equipment in your hand before you glitch because of weak signal. I would recommend to put the radio at chest level or so to get an accurate reading as though you were driving without a drivers stand. But use you best judgement on this.

8. If or when you find something that works, reinstall the equipment back in the radio tray and then do the "radio" walk test again to see if you can go the same distance as before.

9. Finally install in your car and redo the radio test one last time for good measure.

I hope this all makes sence my friend.

Dude, I know this has been a pain in the ass for you. This is the best thing that I could think of to try and help you diagnose your problem. Please keep us posted on your results. Because we might need to invest in explosives or an Exosism or something after all this. Best of luck bro!!! Later.
First off i want to start by thanking you for taking the time to think/write all of this.

Second off i want to tell you guys it is the damn receivers. Something is up with 3 of my receivers but only in this car. 1 of my receivers works great in this car and it happens to be the one that i got recently. As of now 3 hours in it has not glitched once. If i put any other receiver in it starts to glitch.
I am still not convinced that this is the cure because i have done this months ago and it works fine for a while and then starts glitching again.
I have not mounted it back to the car but i dont think that will cause any problems since it happens out of the car.

I was reading on spektrum site and they mention something about "shut down" and it has to do with ESD. Maybe this is whats going on with all of mine? Maybe the graphite is causing something like this?

Until it happens again i am gonna try to 4get about this...lol

I wanted to thank everyone who took time to try and help me...thank you all

Now on 2 tuning..
nitrobeast is offline   Reply With Quote
Old 02-24-2007, 07:31 PM   #4443
Tech Elite
 
nitrobeast's Avatar
 
Join Date: Apr 2006
Location: Colonia, NJ
Posts: 2,340
Trader Rating: 41 (100%+)
Default

Quote:
Originally Posted by razzor
Hey guys ,i found a pdf on my pc that I forgot about.I think this is a essential addition to any racers tool box for diagnosing setup issues.
Its by Serpent for the 710 but applies universally.
Cant believe I forgot about this.
WOW thats the best information i have seen on here as far as tuning goes.

I guess this is a rookie question but can you guys explain understeer and oversteer?

thanks
nitrobeast is offline   Reply With Quote
Old 02-24-2007, 08:29 PM   #4444
Tech Fanatic
 
Serpentd's Avatar
 
Join Date: Jul 2004
Location: Evans, CO. USA
Posts: 798
Default

Quote:
Originally Posted by nitrobeast
First off i want to start by thanking you for taking the time to think/write all of this.

Second off i want to tell you guys it is the damn receivers. Something is up with 3 of my receivers but only in this car. 1 of my receivers works great in this car and it happens to be the one that i got recently. As of now 3 hours in it has not glitched once. If i put any other receiver in it starts to glitch.
I am still not convinced that this is the cure because i have done this months ago and it works fine for a while and then starts glitching again.
I have not mounted it back to the car but i dont think that will cause any problems since it happens out of the car.

I was reading on spektrum site and they mention something about "shut down" and it has to do with ESD. Maybe this is whats going on with all of mine? Maybe the graphite is causing something like this?

Until it happens again i am gonna try to 4get about this...lol

I wanted to thank everyone who took time to try and help me...thank you all

Now on 2 tuning..
Dude, no problem! You are very welcome. The cool part is that you got it figured out.You are lucky to have enough radio parts to help diagnose this sort of thing. Dude, to only have one GOOD receiver out of four is VERY odd!! These are all Spektrum right? Is the one that worked any different then the others? meaning that one was Pro and the others were the "older" style or what? I ask this because I have 4-6 different Spektrum recievers...most are Pro but a few are not. I have only used two of these recievers in cars that I have raced. So I am concerned about the reliability here. Obviously moving to spektum TX, I have been converting my important cars to this. But How the hell can 1 out of 4 work?? I will get on the Spektrum web sight and research what you were talking about with "shut down". But this is not very cool. What do you plan on doing with 3 bad receivers? Because in my opinion, all 4 should work fine in ANY car. I never had your issues with FM. I don't want to run into your issues either.

I hope you plan on sending the 3 bad receivers in for repair or replacement, because that is totally unacceptable. Did you happen to do anything to the receivers yourself to kill them, or are they manufacturer defects? I'm just curious on what you think the problem with these things are. I still need to do my own research but curious to what you or others find out.

Anyway bro, I am very pleased to hear you located the colprate and can safely move on. Keep us posted on how the stability is on this bad boy! Later!
__________________
Blessed are the SIC
Serpentd is offline   Reply With Quote
Old 02-24-2007, 08:53 PM   #4445
Tech Elite
 
Pattojnr's Avatar
 
Join Date: Apr 2006
Location: Perth Australia
Posts: 4,594
Trader Rating: 19 (100%+)
Default

Hey SerpentD, i have had 3 text messages from Frankie, while he was racing this morning. seems to be all good news so far. good pace shown from the G4S crew, and frankie is one. Rob and frankie on 25 laps, and frankie has done a PB lap time. so i think things are going well over in Adelaide today, lets see how they do for te finals. all good news tonight i hope.
__________________
Serpent - Walter RC
Serpent E Power ..... Serpent 747 Reds M3T
Serpent 966-TE Reds M7T .... S411ERYX Speedpassion 3.5T, T-Shox
Serpent 811-TE REDs R5T
Pattojnr is offline   Reply With Quote
Old 02-24-2007, 08:54 PM   #4446
Tech Rookie
 
mdelosrey's Avatar
 
Join Date: Dec 2006
Location: SF
Posts: 11
Send a message via AIM to mdelosrey
Default

Hello g4s'ers

First order of business, I just wanted to say hello and introduce myself. I have been lurking this thread ever since SerpentD convinced me to get my Impulse back together. I got that running and it has been really gratifying. Last Christmas my girlfriend bought me G4S RTR. I am very pleased with the car so far. I plan on getting a G4S kit soon as I want to use the rtr as a parts car. I am very impressed by everyone's G4S' on this thread. Here is the Impulse by the way, Its still running the Mega .12. and am looking for a radio to replace the AM futaba it temporarily uses. Any inputs on that would be great. So far I am leaning towards the Helios. Anyway thats all. Hello everyone and hopefully I can contribute one day.




mdelosrey is offline   Reply With Quote
Old 02-24-2007, 09:34 PM   #4447
Tech Elite
 
nitrobeast's Avatar
 
Join Date: Apr 2006
Location: Colonia, NJ
Posts: 2,340
Trader Rating: 41 (100%+)
Default

Quote:
Originally Posted by Serpentd
Dude, no problem! You are very welcome. The cool part is that you got it figured out.You are lucky to have enough radio parts to help diagnose this sort of thing. Dude, to only have one GOOD receiver out of four is VERY odd!! These are all Spektrum right? Is the one that worked any different then the others? meaning that one was Pro and the others were the "older" style or what? I ask this because I have 4-6 different Spektrum recievers...most are Pro but a few are not. I have only used two of these recievers in cars that I have raced. So I am concerned about the reliability here. Obviously moving to spektum TX, I have been converting my important cars to this. But How the hell can 1 out of 4 work?? I will get on the Spektrum web sight and research what you were talking about with "shut down". But this is not very cool. What do you plan on doing with 3 bad receivers? Because in my opinion, all 4 should work fine in ANY car. I never had your issues with FM. I don't want to run into your issues either.

I hope you plan on sending the 3 bad receivers in for repair or replacement, because that is totally unacceptable. Did you happen to do anything to the receivers yourself to kill them, or are they manufacturer defects? I'm just curious on what you think the problem with these things are. I still need to do my own research but curious to what you or others find out.

Anyway bro, I am very pleased to hear you located the colprate and can safely move on. Keep us posted on how the stability is on this bad boy! Later!
I own 3 3000 and 1 pro. The pro i just bought because i could not get the 3000 to work always. The 3000 is the one thats working for me know but that one is also new. I bought a spektrum dx2 on ebay and sold an old receiver i had that didnt work in this car and the 2 servos that came in the kit because i didnt need them. After all said and done i paid $40 bucks for a new remote and receiver. This is the one working for me now.

I plan on sending the other 3 in for the software upgrade they mention on spektrums site. Hopefully that will work and this will not be a problem again.
nitrobeast is offline   Reply With Quote
Old 02-24-2007, 09:36 PM   #4448
Tech Elite
 
nitrobeast's Avatar
 
Join Date: Apr 2006
Location: Colonia, NJ
Posts: 2,340
Trader Rating: 41 (100%+)
Default

Quote:
Originally Posted by Serpentd
Dude, no problem! You are very welcome. The cool part is that you got it figured out.You are lucky to have enough radio parts to help diagnose this sort of thing. Dude, to only have one GOOD receiver out of four is VERY odd!! These are all Spektrum right? Is the one that worked any different then the others? meaning that one was Pro and the others were the "older" style or what? I ask this because I have 4-6 different Spektrum recievers...most are Pro but a few are not. I have only used two of these recievers in cars that I have raced. So I am concerned about the reliability here. Obviously moving to spektum TX, I have been converting my important cars to this. But How the hell can 1 out of 4 work?? I will get on the Spektrum web sight and research what you were talking about with "shut down". But this is not very cool. What do you plan on doing with 3 bad receivers? Because in my opinion, all 4 should work fine in ANY car. I never had your issues with FM. I don't want to run into your issues either.

I hope you plan on sending the 3 bad receivers in for repair or replacement, because that is totally unacceptable. Did you happen to do anything to the receivers yourself to kill them, or are they manufacturer defects? I'm just curious on what you think the problem with these things are. I still need to do my own research but curious to what you or others find out.

Anyway bro, I am very pleased to hear you located the colprate and can safely move on. Keep us posted on how the stability is on this bad boy! Later!
I own 3 3000 and 1 pro. The pro i just bought because i could not get the 3000 to work always. The 3000 is the one thats working for me know but that one is also new. I bought a spektrum dx2 on ebay and sold an old receiver i had that didnt work in this car and the 2 servos that came in the kit because i didnt need them. After all said and done i paid $40 bucks for a new remote and receiver. This is the one working for me now.

I plan on sending the other 3 in for the software upgrade they mention on spektrums site. Hopefully that will work and this will not be a problem again.

I am very glad i figured it out because opening day is 4/22. 2 months might seems like its far away but its not since i have not driving this car on a track since September. Cant wait.
nitrobeast is offline   Reply With Quote
Old 02-24-2007, 10:59 PM   #4449
Tech Fanatic
 
Serpentd's Avatar
 
Join Date: Jul 2004
Location: Evans, CO. USA
Posts: 798
Default

Quote:
Originally Posted by Pattojnr
Hey SerpentD, i have had 3 text messages from Frankie, while he was racing this morning. seems to be all good news so far. good pace shown from the G4S crew, and frankie is one. Rob and frankie on 25 laps, and frankie has done a PB lap time. so i think things are going well over in Adelaide today, lets see how they do for te finals. all good news tonight i hope.
Patto my bro!!! Dude, thank you so much for the update. I appreciate you taking your time to keep me and everyone posted. Especially me, you know with my concerns of Frankies new engine being enough power for him to hang with the Nova's and Sirio's and Max's...or what ever he races against. Plus me telling him that OS is probably the easiest and one of the most consistant engines to tune and keep a good tune. I just want him to be competative and be happy with the engine since I am responsible for his ultimate decision on the TZ. He may have had some other influence about getting this engine, but it still lies on my shoulders if you know what I mean.

Anyway bro, did you not race this weekend? When is your next race? And when do you think you might be getting some extra ponies for your car? You need an engine yourself by the sounds of it. However for other reasons then our friend Hodak. Dude, keep me posted of any ground breaking news. HMMM, "ground breaking" isn't what I meant. I look forward to hear about todays update! Talk with you soon my friend!
__________________
Blessed are the SIC
Serpentd is offline   Reply With Quote
Old 02-24-2007, 11:24 PM   #4450
Tech Elite
 
Pattojnr's Avatar
 
Join Date: Apr 2006
Location: Perth Australia
Posts: 4,594
Trader Rating: 19 (100%+)
Default

Quote:
Originally Posted by Serpentd
Patto my bro!!! Dude, thank you so much for the update. I appreciate you taking your time to keep me and everyone posted. Especially me, you know with my concerns of Frankies new engine being enough power for him to hang with the Nova's and Sirio's and Max's...or what ever he races against. Plus me telling him that OS is probably the easiest and one of the most consistant engines to tune and keep a good tune. I just want him to be competative and be happy with the engine since I am responsible for his ultimate decision on the TZ. He may have had some other influence about getting this engine, but it still lies on my shoulders if you know what I mean.

Anyway bro, did you not race this weekend? When is your next race? And when do you think you might be getting some extra ponies for your car? You need an engine yourself by the sounds of it. However for other reasons then our friend Hodak. Dude, keep me posted of any ground breaking news. HMMM, "ground breaking" isn't what I meant. I look forward to hear about todays update! Talk with you soon my friend!
inbetwwen the update, Rob (Toy000) rang me, with all good news. finals were not happening yet, but was looking promising, and from Robs point of view Frankies motor was awesome. coupled with the nova pipe i think he has a new friend, Rob was fighting for an A main possy, and Frankie wasnt far off the pace. Paul was doing ok as well (gascar) so seems to be a good day out for the G4orce crew
As for me , no racing today, went down the track to paint and some general maintanence , as we had a busy bee day. next sunday for me. and i may have a surprise on the day as well. PM you bro !
__________________
Serpent - Walter RC
Serpent E Power ..... Serpent 747 Reds M3T
Serpent 966-TE Reds M7T .... S411ERYX Speedpassion 3.5T, T-Shox
Serpent 811-TE REDs R5T
Pattojnr is offline   Reply With Quote
Old 02-24-2007, 11:37 PM   #4451
Tech Fanatic
 
Serpentd's Avatar
 
Join Date: Jul 2004
Location: Evans, CO. USA
Posts: 798
Default

[QUOTE=mdelosrey]Hello g4s'ers

First order of business, I just wanted to say hello and introduce myself. I have been lurking this thread ever since SerpentD convinced me to get my Impulse back together. I got that running and it has been really gratifying. Last Christmas my girlfriend bought me G4S RTR. I am very pleased with the car so far. I plan on getting a G4S kit soon as I want to use the rtr as a parts car. I am very impressed by everyone's G4S' on this thread. Here is the Impulse by the way, Its still running the Mega .12. and am looking for a radio to replace the AM futaba it temporarily uses. Any inputs on that would be great. So far I am leaning towards the Helios. Anyway thats all. Hello everyone and hopefully I can contribute one day.QUOTE]

Dude WELCOME to our KICK ASS, not so average or sane family on here! Dude I think I remember talking to you a few months back. Were you the one that I was going to set aside some Serpent parts for? Shit dude, I finally found some of them, then things got hectic with work and life in general and totally spaced out the parts. I think I found them for the most part. So if you are that guy, I trully appologize for not keeping in touch. I am one to always follow through with my word. If you are still in need of those parts, let me know.

However it sounds as though you might be heading in a new direction, yes? The G4S direction?? Dude, if that's the case then SWEET!!!

As far as a radio recommendation, I think your Helios plan sounds PERFECT!. My latest radio is M11. I upgraded from M8 of 7 years or so. I loved the M8, so it seemed natual to go with the M11. Well, it is a very sweet radio. However it tends to be on the heavy side and balance seems to be a bit top heavy as well. I still like the radio VERY much. But I am actually planning on moving on to the Helio's with the Spektrum setup and also the steering dropdown adapter. Probably will go with a Lipo as well. I know a few dudes on here run with the Helios or JR Z-1 and are VERY happy with it. I have heard that the LCD screen is smaller then average, but other then that it is suppose to be an excelent radio all around. I don't think you will be disapointed if this ends up being your decision. As I said earlier, I plan on getting this radio very soon myself.

Well bro, welcome aboard! Don't make yourself a stranger by any means. Really look forward to seeing you on our G4S thread! Later for now!
__________________
Blessed are the SIC
Serpentd is offline   Reply With Quote
Old 02-24-2007, 11:42 PM   #4452
Tech Fanatic
 
Serpentd's Avatar
 
Join Date: Jul 2004
Location: Evans, CO. USA
Posts: 798
Default

Quote:
Originally Posted by Pattojnr
inbetwwen the update, Rob (Toy000) rang me, with all good news. finals were not happening yet, but was looking promising, and from Robs point of view Frankies motor was awesome. coupled with the nova pipe i think he has a new friend, Rob was fighting for an A main possy, and Frankie wasnt far off the pace. Paul was doing ok as well (gascar) so seems to be a good day out for the G4orce crew
As for me , no racing today, went down the track to paint and some general maintanence , as we had a busy bee day. next sunday for me. and i may have a surprise on the day as well. PM you bro !
!!! ...
__________________
Blessed are the SIC
Serpentd is offline   Reply With Quote
Old 02-25-2007, 01:53 AM   #4453
Tech Elite
 
Kodak Hodak's Avatar
 
Join Date: Nov 2006
Location: South Australia, Australia
Posts: 2,159
Trader Rating: 10 (100%+)
Send a message via MSN to Kodak Hodak Send a message via Yahoo to Kodak Hodak Send a message via Skype™ to Kodak Hodak
Default

Hey Guys,

I will give the run down of Round 4 Little Hampton , South Australia Nitro Tourer:

Two Group A & B

3 Heats of 10mins race + 1 B Final & 1 A Final!!

Ok here how my day unfolded:

First Heat race, sweet as smooth start no trouble and got a clean groove going it was a good car to drive and had a ball having some real power under my belt!!

I finished first heat in 3rd at an Avearge lap time of 25.7, i reduced my average from last round by wait for it 5 seconds big big improvement!!! PB laptime of the day was 22.4 - yes i was stoked!!!

Heat Race 2 - I had a great start got into second place and went on my way to the finish with a 4th place due to servo glitch stuck on failsafe then ran down to pull plug out, and back in, and it came good, Weird but its got me back from 7th to win in 4th position!! Again avearge lapping was 25.5 and best lap time in that race was 22.6 not bad at all for race two on a nice sunny day!!!

Race Heat 3 - Great start again in 2nd and was doing really well till disaster hit me T-BONE "MADAGASCAR" thank you for the dent in pipe, broken reciver and out of race after 8 laps - next time dude learn to respect faster drivers and if your going to pass me do it properey!! You know i flamed you for good reasons you really pissed me off with busted exhaust "No excuses" just learn to drive around not into them Ya Bannanana!!!!

Final B i qualifed 4th due to other races in 3rd and 4th so i was consitant!!! Can you believe i made the finish in 3rd, i am still pinching myself, in the build up to the finals i had the top deck out, reciver out, new one in and had to some how make it all go in right with no dramas - it was like i was racing the clock as the finals was approaching!!!

Anways, i got it done just in time to spare to have a can of Coke and relax!! The finals came and off i went in position 4th to build my way up to 3rd where i really stayed for the whole race!!!

Once again THE MADAGAS CAR i was chasing lost control coming through the chicane and i T-Boned him not delibirate as he was just there and no place to move!! Car ws ok kept going and so did he thou i was in front, i stayed out in 3rd and kept my noce clean for the rest of th race!!! So proud to make 3rd in Group B which gave me entry to the real drivers in Group A!!!

Group A Finals, qualifd 10th, and was ready to race my own race!!!

Pretty much let all the great driver through with respect and stayed out of harms way!!! i had a bit of a nervouse drive in the Group A final but like pattojnr knows LOL it will settle down in future meets!!!

Final results for the A Final:

1. Mugen MTX4
2. Mugen MTX4
3. MUGEN MTX4
4. G4S - Rob "Toy000" well done next time rob
5. Mugen MTX4
6. MUGN MTX4
7. G4S - Andrew - Debut race well done
8. G4s - Frankie 'Kodak Hodak" Whoo Hoo
9. Mugen MTX4
10. G4S - Gascar "Pauly" Stripped second gear again, such bad luck

Anyway guys, here is the great news, we doing ok, but i am wrapped to be anywhere near the group A. and Group B was rewarding!!!!

Speak Soon, and post away!
Cheers Frankie
__________________
★ DORMANT RC RACER ★
Kodak Hodak is offline   Reply With Quote
Old 02-25-2007, 01:59 AM   #4454
Tech Elite
 
Kodak Hodak's Avatar
 
Join Date: Nov 2006
Location: South Australia, Australia
Posts: 2,159
Trader Rating: 10 (100%+)
Send a message via MSN to Kodak Hodak Send a message via Yahoo to Kodak Hodak Send a message via Skype™ to Kodak Hodak
Default

O yeah B Final results:

1.Mugen MTX4
2. G4S - Rob "Toy00" well done Siro
3. G4S - Frankie "Kodak Hodak" OS TZ
4. G4S - Madagascar "Kosta" MAX Engine
5. Mugen MTX4
6. GPX4
7. Mugen Mtx4
8. G4S - Shano

cheers - i am stuffed
__________________
★ DORMANT RC RACER ★
Kodak Hodak is offline   Reply With Quote
Old 02-25-2007, 02:01 AM   #4455
Tech Elite
 
Pattojnr's Avatar
 
Join Date: Apr 2006
Location: Perth Australia
Posts: 4,594
Trader Rating: 19 (100%+)
Default

congrats to all G4S drivers, on a sucsessfull days racing.
i cant put my finger on it, but did you say Kosta was off the pace and t boned you? so you had the position not him ? sounds like his car is a missile in a straight line but Madagascar, there are corners as well dude. work on car setup then worry about speed. and great result for Rob as well. to split up those mugens is great. im sure the rest are feeling the pressure of the G4orce crew. keep up the good work guys
__________________
Serpent - Walter RC
Serpent E Power ..... Serpent 747 Reds M3T
Serpent 966-TE Reds M7T .... S411ERYX Speedpassion 3.5T, T-Shox
Serpent 811-TE REDs R5T
Pattojnr is offline   Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
FS: Team Magic G4 - LRP Z12R Team Spec 2 - Add RX/TX LogiK Australia For Sale/Trade 1 08-03-2007 02:00 AM
Team Magic G4s MaDaGAS CAR Australia For Sale/Trade 29 05-07-2007 03:30 AM
Brian Berry Joins Team Phenix/Team Magic Motorman Nitro On-Road 27 03-07-2006 05:51 AM
team magic g4 + elephant R/C Items: For Sale/Trade 4 04-26-2004 07:34 AM
Team Magic G4 "Black Magic" tennessee Nitro On-Road 32 04-20-2003 11:40 AM



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 02:25 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net