R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Nitro On-Road

Reply
 
Thread Tools Search this Thread
Old 11-11-2005, 09:21 AM   #1
Tech Rookie
 
Join Date: Nov 2005
Posts: 3
Default Engine stalls without the glow starter ??!....

Ok sorry for all the questions guys....but after being able to start the engine....

i found that once i take the glow starter out the engine just stalls....

ive searched for topics like this but i just cant find it ??!

the engine stalls if i just leve it to neutral for a while...

ive tried adjusting the needle valve and things etc..

any help would be very much appreciated

thank you
alexlai50 is offline   Reply With Quote
Old 11-11-2005, 09:36 AM   #2
Tech Elite
 
esham's Avatar
 
Join Date: Feb 2003
Location: racing line - push to the limit
Posts: 2,942
Default

It might due to defective plug. The plug is damage.
__________________
Kyosho R4/V1RRREvo2/ OSpeed>Nova353T & S/Evo4M>Nova-KeepOnS
Transponder Pokok Cherry- [email protected]
Kelab Peminat Kereta Kawalan Jauh Ipoh, Perak
esham is offline   Reply With Quote
Old 11-11-2005, 02:57 PM   #3
Moderator
 
Jpilone's Avatar
R/C Tech Charter Subscriber
 
Join Date: Nov 2002
Location: Very Nice!
Posts: 1,660
Send a message via AIM to Jpilone
Default

get a new glow plug, that's a typical symptom
__________________
-Jarrod Pilone
Pro R/C Photographer
http://www.jpsportspics.com
Jpilone is offline   Reply With Quote
Old 11-11-2005, 04:43 PM   #4
Tech Champion
 
asw7576's Avatar
 
Join Date: Sep 2004
Posts: 5,792
Default

Could be engine is too rich and/or idle speed is too low.

Lean the mixture by one more turn and increase idle by another 15 or 30 min turn.
asw7576 is offline   Reply With Quote
Old 11-11-2005, 11:45 PM   #5
Tech Adept
 
MRX_joe21's Avatar
 
Join Date: Oct 2005
Location: San Valley Crew
Posts: 189
Send a message via Yahoo to MRX_joe21
Default

Quote:
Originally Posted by alexlai50
Ok sorry for all the questions guys....but after being able to start the engine....

i found that once i take the glow starter out the engine just stalls....

ive searched for topics like this but i just cant find it ??!

the engine stalls if i just leve it to neutral for a while...

ive tried adjusting the needle valve and things etc..

any help would be very much appreciated

thank you
Too rich at the btom...
MRX_joe21 is offline   Reply With Quote
Old 11-12-2005, 12:00 AM   #6
Tech Regular
 
Speeds Gonzo's Avatar
 
Join Date: Jul 2005
Location: Oxnard, Ca
Posts: 342
Trader Rating: 22 (100%+)
Default

Ok, it all depends on how new or old the engine is. If you rev it up and it takes too long to spool up then it is too rich. On the other hand if it revs fast then bogs and sounds like it's gonna quit, then it's too lean. Like others stated, it could be your idle it wont hurt to raise it up as long as the clutch doesn't engage. If the motor is in the process of being broken in then this type of behavior is somewhat normal. If the engine has more than two gallons through it, then a new piston/sleave might be needed. Good luck!
Speeds Gonzo is offline   Reply With Quote
Old 11-12-2005, 03:46 AM   #7
Tech Master
 
hav_lova's Avatar
 
Join Date: Jan 2005
Location: Sydney Model Autosports (SMA)
Posts: 1,387
Trader Rating: 4 (100%+)
Default

Change your glo-plug simple
__________________
Just playing with bigger toys now...
serpentrc.com.au
hav_lova is offline   Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
engine stalls when off throttle. NitroWD Onroad Nitro Engine Zone 8 06-21-2008 08:08 AM
Engine stalls Mag-Racer Monster Trucks 5 06-20-2008 04:08 AM
Engine stalls w/o igniter deputy139 Rookie Zone 8 05-02-2006 07:31 PM
Engine stalls w/o igniter deputy139 Electric Off-Road 6 04-30-2006 01:41 PM
Engine started without glow starter!! deanspoors Nitro On-Road 14 04-08-2003 11:10 PM



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 01:45 PM.


Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net