R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Nitro On-Road

Reply
 
Thread Tools Search this Thread
Old 09-06-2008, 02:44 AM   #3076
Tech Addict
 
Join Date: Sep 2007
Location: Canberra, where the best clay is
Posts: 536
Trader Rating: 7 (100%+)
Default

hey

just after a part number for the engine mount for the 960 08 so i can mount my RB as the holes in the mount are to close together
rcmad2700 is offline   Reply With Quote
Old 09-06-2008, 02:49 AM   #3077
Tech Addict
 
Greg M's Avatar
 
Join Date: Jan 2005
Location: New Zealand
Posts: 527
Trader Rating: 6 (100%+)
Default

I think there is only one, plus I've got an RB in mine with the standard mount?
Greg M is offline   Reply With Quote
Old 09-06-2008, 06:15 PM   #3078
Tech Addict
 
Join Date: Sep 2007
Location: Canberra, where the best clay is
Posts: 536
Trader Rating: 7 (100%+)
Default

yer just looked at the measurments on the RB web site and the speedline XA is the same as the C6 so i dont know what is going wrong with the mount
rcmad2700 is offline   Reply With Quote
Old 09-06-2008, 06:18 PM   #3079
Tech Addict
 
Join Date: Sep 2007
Location: Canberra, where the best clay is
Posts: 536
Trader Rating: 7 (100%+)
Default

oh i didnt see that you are running a C5 but i think they are the same
(i hope)
rcmad2700 is offline   Reply With Quote
Old 09-07-2008, 06:41 PM   #3080
Tech Addict
 
Join Date: Sep 2007
Location: Canberra, where the best clay is
Posts: 536
Trader Rating: 7 (100%+)
Default

just really need to knoe what engine mount will fit the RB Xenon ALPHA as the standared one aint gonna work.
rcmad2700 is offline   Reply With Quote
Old 09-07-2008, 07:26 PM   #3081
Tech Elite
 
kschu's Avatar
 
Join Date: Mar 2007
Location: Kota Kinabalu,Sabah
Posts: 4,598
Trader Rating: 16 (100%+)
Send a message via MSN to kschu
Default

hi guys, i'm new to 1/8th scale as im playing 1/10 s400 before... im using 960 with 08 conversion...

my question now is , wat should i do if i encounter traction roll ?? wat setting should i need to apply on d car?? the track is very grip as the race organise will spray sugar treatment on the track before the race start.

thanks
__________________
Give the best while u can !
kschu is offline   Reply With Quote
Old 09-07-2008, 08:44 PM   #3082
Tech Master
 
soc123_au's Avatar
R/C Tech Charter Subscriber
 
Join Date: Jul 2003
Location: Penrith Australia
Posts: 1,554
Trader Rating: 2 (100%+)
Default

Quote:
Originally Posted by rcmad2700 View Post
just really need to knoe what engine mount will fit the RB Xenon ALPHA as the standared one aint gonna work.
The mono block mounts the Alpha with no problems. I pulled my C6 out & bolted the alpha straight in.

For all those having meshing issues, stick a .5 shim behind the flywheel cone, meshes perfectly & you can still get heaps of adjustment in clutch gap. I have done this & run .9 gap & still use shims.
__________________
Serpent Radio Control Models
Auswide Hobbies
JPM Racing
soc123_au is offline   Reply With Quote
Old 09-07-2008, 08:47 PM   #3083
Tech Addict
 
Join Date: Sep 2007
Location: Canberra, where the best clay is
Posts: 536
Trader Rating: 7 (100%+)
Default

mmmm well mine and my bros havnt been macheened properly as the mouning hols dont line up even. i have the front 2 screws in and the rear is out looking fromt the exhust side off the engine the left is .5 mm out and the right is like 1.5mm out
rcmad2700 is offline   Reply With Quote
Old 09-07-2008, 08:48 PM   #3084
Tech Master
 
soc123_au's Avatar
R/C Tech Charter Subscriber
 
Join Date: Jul 2003
Location: Penrith Australia
Posts: 1,554
Trader Rating: 2 (100%+)
Default

Quote:
Originally Posted by Pattojnr View Post
i have a lipo on the way to lower the tank a little, so i should get rid of my carb issue. thanks.
You need to turn the carb to change the angle & then adjust the ball at the end of the slide. Its a bit fiddly to get right but you can run the car with a standard 5 cell flat pack. Lipos are a better option though & the AAA packs have a tendency to come apart with the vibrations.
__________________
Serpent Radio Control Models
Auswide Hobbies
JPM Racing
soc123_au is offline   Reply With Quote
Old 09-07-2008, 08:53 PM   #3085
Tech Master
 
soc123_au's Avatar
R/C Tech Charter Subscriber
 
Join Date: Jul 2003
Location: Penrith Australia
Posts: 1,554
Trader Rating: 2 (100%+)
Default

Quote:
Originally Posted by rcmad2700 View Post
mmmm well mine and my bros havnt been macheened properly as the mouning hols dont line up even. i have the front 2 screws in and the rear is out looking fromt the exhust side off the engine the left is .5 mm out and the right is like 1.5mm out
Sounds like you may have a bad engine mount, if you contact your local Serpent importer I am sure they will sort it for you.

Just something else to try first, have you tried mounting the engine into the mount off the chassis? I have ground my mount down to give more clearance for adjusting mesh etc. It is possible your engine is twisting slightly because of the tight clearances.
__________________
Serpent Radio Control Models
Auswide Hobbies
JPM Racing
soc123_au is offline   Reply With Quote
Old 09-08-2008, 05:16 AM   #3086
Tech Elite
 
Pattojnr's Avatar
 
Join Date: Apr 2006
Location: Perth Australia
Posts: 4,594
Trader Rating: 19 (100%+)
Default

just finished up the paint. , here it is
Attached Thumbnails
Serpent 960....-960-08.jpg  
__________________
Serpent - Walter RC
Serpent E Power ..... Serpent 747 Reds M3T
Serpent 966-TE Reds M7T .... S411ERYX Speedpassion 3.5T, T-Shox
Serpent 811-TE REDs R5T
Pattojnr is offline   Reply With Quote
Old 09-08-2008, 09:31 AM   #3087
Tech Elite
 
duneland's Avatar
 
Join Date: Sep 2004
Location: NW Indiana, USA
Posts: 2,403
Default

Quote:
Originally Posted by kschu View Post
hi guys, i'm new to 1/8th scale as im playing 1/10 s400 before... im using 960 with 08 conversion...

my question now is , wat should i do if i encounter traction roll ?? wat setting should i need to apply on d car?? the track is very grip as the race organise will spray sugar treatment on the track before the race start.

thanks
There are many things you can do to keep the car off it's lid. You are lucky that the problem is excessive grip rather than the reverse!
Here are a number of things you can do;
Small tires... Lowest ride height track surface will allow... Stiffer springs... Harder compound tires... Change roll centers (raise the inboard lower hinge pins to the highest location and shim the upper-front arm mounts upward)... Stiffer sway bar settings... Make sure the body is mounted as low as possible without significant tire contact... Reduce the number of holes in shock pistons, ie. if you have 4 hole pistons, go to 2 or 1...
duneland is offline   Reply With Quote
Old 09-08-2008, 06:31 PM   #3088
Tech Elite
 
kschu's Avatar
 
Join Date: Mar 2007
Location: Kota Kinabalu,Sabah
Posts: 4,598
Trader Rating: 16 (100%+)
Send a message via MSN to kschu
Default

Quote:
Originally Posted by duneland View Post
There are many things you can do to keep the car off it's lid. You are lucky that the problem is excessive grip rather than the reverse!
Here are a number of things you can do;
Small tires... Lowest ride height track surface will allow... Stiffer springs... Harder compound tires... Change roll centers (raise the inboard lower hinge pins to the highest location and shim the upper-front arm mounts upward)... Stiffer sway bar settings... Make sure the body is mounted as low as possible without significant tire contact... Reduce the number of holes in shock pistons, ie. if you have 4 hole pistons, go to 2 or 1...
ok, i will try it up...thanks for your advise...

below is my 1st race with 1/8th
http://www.youtube.com/watch?v=ypnAl8tOO38
__________________
Give the best while u can !
kschu is offline   Reply With Quote
Old 09-09-2008, 09:38 AM   #3089
Tech Elite
 
duneland's Avatar
 
Join Date: Sep 2004
Location: NW Indiana, USA
Posts: 2,403
Default

I watched your video, and you were getting around quite well for your first run. However, I didn't see any signs of excess traction. Actually, it looked a bit loose. You had one flip near the end, that was induced by contact with the curb/berm. It looked as though your pit man is responsible for marshalling your car! Bummer, you lost a lot of time on those two crashes..
Keep it up!
Where is the track btw?
duneland is offline   Reply With Quote
Old 09-09-2008, 01:11 PM   #3090
Tech Master
 
fly_wheel's Avatar
 
Join Date: Oct 2007
Location: sabah lor
Posts: 1,039
Trader Rating: 9 (100%+)
Default

the track is in sabah, malaysia...
fly_wheel is offline   Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Serpent 705 J_Longbrake Nitro On-Road 4252 02-23-2015 12:34 AM
Serpent 710 Ron C. Nitro On-Road 23347 03-16-2010 02:47 PM
WTB: NIB Serpent 710 aN4rK1 R/C Items: Wanted to Buy 3 06-16-2006 09:23 PM
Trade in Your Old Serpent 710 Parts for New Serpent 710 Parts fast_it710 R/C Items: For Sale/Trade 0 09-17-2004 12:27 AM
Serpent Impulse w/MT-12 and Serpent Starter box - cheap Solara R/C Items: For Sale/Trade 2 03-07-2003 03:01 PM



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 12:04 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net