R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Nitro On-Road

Reply
 
Thread Tools Search this Thread
Old 05-22-2004, 10:05 AM   #12196
Tech Regular
 
Ducati998's Avatar
 
Join Date: Jan 2003
Location: Colorado
Posts: 289
Default

Thank to all you guy that replied to my question!
Ducati998 is offline   Reply With Quote
Old 05-22-2004, 12:33 PM   #12197
Tech Master
 
rcmike's Avatar
 
Join Date: Apr 2002
Location: plano,tx
Posts: 1,706
Trader Rating: 40 (100%+)
Default 16 x 19 side belt ratio

Can someone post the link to this topic,cant seem to find in search funtion. Want to read about pros and cons with it" THANKS
rcmike is offline   Reply With Quote
Old 05-22-2004, 01:59 PM   #12198
Tech Master
 
Grinder's Avatar
R/C Tech Elite Subscriber
 
Join Date: Feb 2003
Posts: 1,857
Trader Rating: 2 (100%+)
Default

I have been using the conversion for some time now. I use the conversion usually during a main, sometimes during qualifying. I really do not see much handling difference. I have noticed that if I use the conversion with the rear tires the same size as the front it wears out the front 16 tooth pulley faster than normal and is harder on the front belt, but I like it. Keeps my car handling very consistently throughout a long main.
__________________
www.murnanmodified.com
Grinder is offline   Reply With Quote
Old 05-22-2004, 03:09 PM   #12199
B
Tech Master
 
Join Date: May 2003
Location: NorCal
Posts: 1,159
Trader Rating: 7 (100%+)
Default Re: 3-Racing Universals

Quote:
Originally posted by gonzoY5
Everyone bashes the 3-Racing Universals but I've only broken one in 6 months of racing, and that was when I clipped a barrier on a top speed sweeper. I also tore off my Upper and Lower arms so it wasn't a soft hit. I think those people that call them so cheap need to stop crashing so much.

And even if they're not the same quality as the Mugen Uni's you can get them here http://www.jplracing.com/shop/ for $11 a pair. Even if they don't last as long you can still get 3 pairs for the cost of one of the "better" quality ones.
Some others have different experience with them. Most peopl's 3Racing universals break upon a small tap, or sometimes, when even nothing seemed to have happened, and the universals just blew up.

Guess u got a good one.
B is offline   Reply With Quote
Old 05-22-2004, 03:11 PM   #12200
B
Tech Master
 
Join Date: May 2003
Location: NorCal
Posts: 1,159
Trader Rating: 7 (100%+)
Default

Quote:
Originally posted by BrainTeased
Im using a Q-world no probs at all uses one motor setup.
yah. i use the same one for many years now. It has never failed me, and it is still running strong.

Best R/C investment yet
B is offline   Reply With Quote
Old 05-22-2004, 03:47 PM   #12201
Tech Master
 
Join Date: Nov 2003
Location: South FLorida
Posts: 1,104
Trader Rating: 2 (100%+)
Send a message via AIM to Profoxcg
Default

do you guys know if I can use my serpent started boc for when I build my mugen?
Profoxcg is offline   Reply With Quote
Old 05-22-2004, 05:10 PM   #12202
Q
Tech Apprentice
 
Q's Avatar
 
Join Date: Feb 2004
Location: socal--crystal park
Posts: 61
Default

Quote:
Originally posted by Ducati998
Hi! I was wondering what starter box do you guys use? Thinking of getting a new one. ThanK!
I use associated starter box and it works well with mtx-3. you have to turn the motor inside which is no problem.
Q is offline   Reply With Quote
Old 05-22-2004, 05:41 PM   #12203
Tech Elite
 
Sow&Steady's Avatar
 
Join Date: Dec 2003
Location: Va Va Voom!
Posts: 4,104
Default

Quote:
Originally posted by Profoxcg
do you guys know if I can use my serpent started boc for when I build my mugen?
You can but you'll need to manually line up your chassis each time.

Maybe you can do a hack mod job on the rear guide.
__________________
http://3hobby.net REVISITED V2 - Its on steroids!
https://www.facebook.com/ssteady
Sow&Steady is offline   Reply With Quote
Old 05-22-2004, 07:44 PM   #12204
Tech Fanatic
 
TOEBSTER2's Avatar
 
Join Date: Jun 2003
Location: DePere, WI
Posts: 993
Trader Rating: 3 (100%+)
Default

I just got my MTX-3 finished today, but my only problem is what the heck are you supposed to use for a reciever pack. The directions aren't very clear on that. I fiddled with different packs all morning. The only thing that will fit could be phone size cells or like five AAA batteries. Anyone know for sure.
__________________
Crookid Creations
TOEBSTER2 is offline   Reply With Quote
Old 05-22-2004, 08:02 PM   #12205
Tech Regular
 
gonzoY5's Avatar
 
Join Date: Mar 2004
Location: Miami, FL
Posts: 392
Default

Bingo...that's exactly what it is. 5 cell AAA pack in a 3x2 hump configuration.
gonzoY5 is offline   Reply With Quote
Old 05-22-2004, 08:05 PM   #12206
Tech Master
 
BrainTeased's Avatar
 
Join Date: Jan 2004
Location: Melbourne
Posts: 1,342
Trader Rating: 4 (100%+)
Default

Quote:
Originally posted by TOEBSTER2
I just got my MTX-3 finished today, but my only problem is what the heck are you supposed to use for a reciever pack. The directions aren't very clear on that. I fiddled with different packs all morning. The only thing that will fit could be phone size cells or like five AAA batteries. Anyone know for sure.
Yea i was told to use 5 AAA batteries! but i was thinking if they were 1.5V each that would = to 7.5 volts! but for size yea AAA's or you can get the hump packs which are a smaller type of cell and work great, and works out to 6 Volts.
__________________
www.feralbatteries.com.au
BrainTeased is offline   Reply With Quote
Old 05-22-2004, 08:08 PM   #12207
Tech Elite
 
Roger's Avatar
 
Join Date: Feb 2003
Posts: 2,312
Trader Rating: 10 (100%+)
Default

I just got my new chassis today and I will take some pix of it for you guys. The chassis is made by PRP. 7075 4mm chassis with 4mm carbon fiber shock towers. The chassis is CNC cut. It's pretty clean.
__________________
http://nitrokb.netne.net/profiles/RogerSerafin.html
Roger is offline   Reply With Quote
Old 05-22-2004, 08:15 PM   #12208
Tech Regular
 
Ducati998's Avatar
 
Join Date: Jan 2003
Location: Colorado
Posts: 289
Default

I finally got my mtx-3 started today after manage to turn my wheel on the Associated box, now I won't have to get a new one. Anyway the problem is that after starting up my engine for a while it run for about couples of minutes then it dies. Then when I tried to start it up again it die right away. I tried to adjust the high speed, but it don't seem to work. Do you guy no what maybe the problem? I'm thinking it maybe the glow plug gone bad, but what do you guy think? Thank!
Ducati998 is offline   Reply With Quote
Old 05-22-2004, 08:25 PM   #12209
Tech Master
 
BrainTeased's Avatar
 
Join Date: Jan 2004
Location: Melbourne
Posts: 1,342
Trader Rating: 4 (100%+)
Default

Quote:
Originally posted by Ducati998
I finally got my mtx-3 started today after manage to turn my wheel on the Associated box, now I won't have to get a new one. Anyway the problem is that after starting up my engine for a while it run for about couples of minutes then it dies. Then when I tried to start it up again it die right away. I tried to adjust the high speed, but it don't seem to work. Do you guy no what maybe the problem? I'm thinking it maybe the glow plug gone bad, but what do you guy think? Thank!
Does it idle loud or really sluggish? try to play with your low speed screw as thats what your car is running at when you start it. also when you say it runs for a coupler of mins do you mean driving for a couple of mins or idling for a coupler of mins?
__________________
www.feralbatteries.com.au
BrainTeased is offline   Reply With Quote
Old 05-22-2004, 08:33 PM   #12210
Tech Regular
 
Ducati998's Avatar
 
Join Date: Jan 2003
Location: Colorado
Posts: 289
Default

Quote:
Originally posted by BrainTeased
Does it idle loud or really sluggish? try to play with your low speed screw as thats what your car is running at when you start it. also when you say it runs for a coupler of mins do you mean driving for a couple of mins or idling for a coupler of mins?

It idel pretty loud. Today when starting it I did not run the car. I just added fuel and fired it up to make sure it run. The first time I started it up it idel for a while just sitting there then it dies all sudden then after that I have a bit rouble fireing it up again. I'm runnign a turbo plug, I tried to take the plug out and connect it with the glow plug ignitor, the plug wire didn't turn too bright but I'm not sure if turbo plug suppose to do that, I never used a turbo plug before. I'll try to play the low speed and see, thank!
Ducati998 is offline   Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
MUGEN MBX5R/MUGEN MBX5T PROSPEC/TRAXXAS RACE REVO Jason Halvorson R/C Items: For Sale/Trade 14 01-12-2008 10:32 AM
Mugen 5T Chassis, Mugen 46 Tooth Pinion, Associated Ride Height Gauge bretzkej R/C Items: For Sale/Trade 1 08-19-2007 06:31 PM
USA's Most Wanted FOR SALE Mugen MBX5R,Losi 8 comp, and Mugen MBX5T Prospec Truggy nobike R/C Items: For Sale/Trade 69 04-28-2007 07:45 PM
Another MTX3 prospec w lots of parts and an optional Mugen X12 w Mugen pipe Scott Fisher R/C Items: For Sale/Trade 11 11-21-2005 05:45 PM
drake xxx nt and mugen mst-1+extras......Looking for a kanai 2 or maybe mugen buggy [email protected] R/C Items: For Sale/Trade 5 06-30-2003 09:31 PM



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 05:56 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net