R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Nitro On-Road

Reply
 
Thread Tools Search this Thread
Old 01-28-2013, 05:52 PM   #1
Tech Fanatic
 
Join Date: Jan 2013
Location: Central Florida
Posts: 896
Trader Rating: 17 (95%+)
Default What happened with my gears? TC3

I was showing my car tonight to a potential buyer and during the run the car shut off. After closer inspection it appears that my gears snapped out of whack. I also pulled out a couple springs?

The engine on the car is a Nova Rossi C12 if it matters and here is a picture. Please help so I can trade this car.
Pintobean11 is offline   Reply With Quote
Old 01-28-2013, 06:04 PM   #2
Tech Champion
 
nitrodude's Avatar
 
Join Date: Aug 2002
Location: Oxnard, CA
Posts: 5,844
Trader Rating: 5 (100%+)
Default

It looks like the clutchbell came off and it bent the second.gear bell on the transmission. Did you loctite the screw holding the bell to the engine?
__________________
Steven Muller
AKA El Pibe RUFAST? HAHA!!!
Ronin Speed Parts
nitrodude is offline   Reply With Quote
Old 01-28-2013, 06:12 PM   #3
Tech Fanatic
 
Join Date: Jan 2013
Location: Central Florida
Posts: 896
Trader Rating: 17 (95%+)
Default

I am very new to this and recently purchased this car about a month ago. I took it to a local hobby shop to have them give it a 1 over and they claimed all they had to do was put in a new glo plug. What do I need to do to get this running again?
Pintobean11 is offline   Reply With Quote
Old 01-28-2013, 07:01 PM   #4
Tech Fanatic
 
esckalayd's Avatar
 
Join Date: Mar 2011
Location: Orlando, FL
Posts: 920
Trader Rating: 11 (100%+)
Default

Quote:
Originally Posted by Pintobean11 View Post
I am very new to this and recently purchased this car about a month ago. I took it to a local hobby shop to have them give it a 1 over and they claimed all they had to do was put in a new glo plug. What do I need to do to get this running again?
I see you are in central florida. Did you happen to go to Superior Hobbies? These guys are the best in the state if not one of the best hobby shops in the U.S.

You will need to tightened down that clutchbell screw and loctite it. Might also want to look into a new 1st and 2nd gear. Should be a cheap fix.
__________________
---------------------------------------------------------------------------------
Anthony Schimizzi AKA ~The Rookie~
| Serpent America - DeSoto Racing |
esckalayd is offline   Reply With Quote
Old 01-28-2013, 07:10 PM   #5
Tech Rookie
 
Join Date: Jan 2013
Posts: 4
Default

Your heat sync looks like it also was put on wrong. The notches for the engine mounts are facing the front and rear not on the sides.

Have fun driving. Ive had the same thing happen I once
tubasteve is offline   Reply With Quote
Old 01-28-2013, 07:12 PM   #6
Tech Fanatic
 
Join Date: Jan 2013
Location: Central Florida
Posts: 896
Trader Rating: 17 (95%+)
Default

Quote:
Originally Posted by esckalayd View Post
I see you are in central florida. Did you happen to go to Superior Hobbies? These guys are the best in the state if not one of the best hobby shops in the U.S.

You will need to tightened down that clutchbell screw and loctite it. Might also want to look into a new 1st and 2nd gear. Should be a cheap fix.
I initially took it to Graves but have been to Superior. With my little knowledge in RC's but willingness to try anything, could I fix it?
Pintobean11 is offline   Reply With Quote
Old 01-28-2013, 08:05 PM   #7
Tech Fanatic
 
esckalayd's Avatar
 
Join Date: Mar 2011
Location: Orlando, FL
Posts: 920
Trader Rating: 11 (100%+)
Default

Quote:
Originally Posted by Pintobean11 View Post
I initially took it to Graves but have been to Superior. With my little knowledge in RC's but willingness to try anything, could I fix it?
Yeah I am sure you could. Grab the manual, if you don't have it, here ya go :

http://www.teamassociated.com/pdf/ca...tc3_manual.pdf

Look at page 6 and 16.

Also, for more information go here:

http://www.teamassociated.com/manuals/NTC3/

With these two resources i am sure you can fix it. If you are still struggling, go into Superior and tell them you are looking for a little help. Whether its Andy, Mike, Seth, or whoever, someone will be able to help you out
__________________
---------------------------------------------------------------------------------
Anthony Schimizzi AKA ~The Rookie~
| Serpent America - DeSoto Racing |
esckalayd is offline   Reply With Quote
Old 01-28-2013, 08:10 PM   #8
Tech Fanatic
 
esckalayd's Avatar
 
Join Date: Mar 2011
Location: Orlando, FL
Posts: 920
Trader Rating: 11 (100%+)
Default

Quote:
Originally Posted by tubasteve View Post
Your heat sync looks like it also was put on wrong. The notches for the engine mounts are facing the front and rear not on the sides.

Have fun driving. Ive had the same thing happen I once
Remember the way this motor is mounted, the crankshaft points towards the back of the car. Therefore you want the cooling fins to be open front to back (like in the picture). Other nitro touring cars i would agree with you on, NT1, CO1, etc, but for the NTC3, this is the correct head placement
__________________
---------------------------------------------------------------------------------
Anthony Schimizzi AKA ~The Rookie~
| Serpent America - DeSoto Racing |
esckalayd is offline   Reply With Quote
Old 01-28-2013, 09:23 PM   #9
Tech Fanatic
 
Join Date: Jan 2013
Location: Central Florida
Posts: 896
Trader Rating: 17 (95%+)
Default

I was able to get everything taken apart. My problem is that somehow the clutch shoe and spring came loose causing the gears to move. I am taking the clutch shoe and spring to Superior to hopefully have them help me out.
Pintobean11 is offline   Reply With Quote
Old 01-29-2013, 07:40 AM   #10
Tech Fanatic
 
esckalayd's Avatar
 
Join Date: Mar 2011
Location: Orlando, FL
Posts: 920
Trader Rating: 11 (100%+)
Default

Quote:
Originally Posted by Pintobean11 View Post
I was able to get everything taken apart. My problem is that somehow the clutch shoe and spring came loose causing the gears to move. I am taking the clutch shoe and spring to Superior to hopefully have them help me out.
Thats good, the clutch shoe and spring probably got loose b/c of the set screw that holds the clutch bell and everything on the crankshaft in place. If Superior doesn't have the parts, the are for sure on the internet. I would check amianhobbies or even team associated website.
__________________
---------------------------------------------------------------------------------
Anthony Schimizzi AKA ~The Rookie~
| Serpent America - DeSoto Racing |
esckalayd is offline   Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Hpi Pro 4 Barry White Electric On-Road 16065 Yesterday 07:32 PM



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 03:52 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net