R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Nitro On-Road

Reply
 
Thread Tools Search this Thread
Old 03-23-2003, 02:17 AM   #2146
Tech Master
 
squizzytaylor's Avatar
 
Join Date: Jun 2002
Location: Toronto NSW Australia
Posts: 1,119
Default

That is a neat looking car.........but we have lynched people around here for mentioning the names HPI and Mugen Seiki let alone putting them on thier Kyosho!

gt

squizzytaylor is offline   Reply With Quote
Old 03-23-2003, 02:53 AM   #2147
Tech Regular
 
Brett's Avatar
 
Join Date: Jun 2002
Location: Shellharbour NSW Australia
Posts: 348
Default Re: Brett

Quote:
Originally posted by sausage_link
What inch up mean??? ive wondered that for so long... and i think the take offs are 26mm ... coz ive got mine on a set of 26mm rims and they fit good

gsir have u tried flaring the manifold end so that its shaped like a horn slightly
lol u dont want your engine moving... i didnt put lock tite on the first time and the engine moved and grinded my spur gear down
inch up buy the explanation from proline is :

Improving on the most popular design in touring car racing, this Inch Up Velocity is specially designed for Nitro touring. Improvements include clearance for Mugen, Serpent, and AE 1:10 Nitro steering and hub assemblies, and a strengthened center hub for added support and stiffness
Brett is offline   Reply With Quote
Old 03-23-2003, 03:03 AM   #2148
Tech Master
 
sausage_link's Avatar
 
Join Date: Jun 2002
Location: Melb, Australia
Posts: 1,025
Send a message via ICQ to sausage_link
Default

i see
sausage_link is offline   Reply With Quote
Old 03-23-2003, 04:54 AM   #2149
Tech Adept
 
xGSiR's Avatar
 
Join Date: Jan 2003
Location: Sydney, Australia
Posts: 230
Default

man you sure keep your car clean!

could i use WD40 to clean my engine?
the outside is kinda getting dirty.
xGSiR is offline   Reply With Quote
Old 03-23-2003, 07:31 AM   #2150
Tech Regular
 
NitroNut's Avatar
 
Join Date: Aug 2002
Location: Madison, WI
Posts: 303
Default

sexc shocks, mattter of fact sexc car
NitroNut is offline   Reply With Quote
Old 03-23-2003, 03:21 PM   #2151
Tech Rookie
 
eNiGmA's Avatar
 
Join Date: Mar 2003
Location: Walnut, California
Posts: 9
Send a message via AIM to eNiGmA
Default

squizzytaylor: i didnt know that, ill have them removed immediately (so many people have mistaken this car for a mugen )

xGSiR: wd40 works well both inside and out. You can also use it on the chassis, just make sure you get the dirt off first then spray, the wd40 can keep dirt from sticking to parts.

NitroJoe: i am not stupid enough to pay $80 just for v1r shocks . They are NEO
eNiGmA is offline   Reply With Quote
Old 03-23-2003, 03:49 PM   #2152
Tech Elite
 
AMGRacer's Avatar
 
Join Date: Oct 2001
Location: Brisbane, Australia
Posts: 3,939
Default

Nice car eNiGmA.

A few minor comments. The floating mount is around the wrong way, it should face the other way. Also the front body mounts should be attached to the downward angled part, not the front bumper.
AMGRacer is offline   Reply With Quote
Old 03-23-2003, 09:41 PM   #2153
Tech Adept
 
NitroJoe's Avatar
 
Join Date: Oct 2002
Location: Madison, Dairy Land
Posts: 121
Default

Quote:
Originally posted by eNiGmA
squizzytaylor: i didnt know that, ill have them removed immediately (so many people have mistaken this car for a mugen )

xGSiR: wd40 works well both inside and out. You can also use it on the chassis, just make sure you get the dirt off first then spray, the wd40 can keep dirt from sticking to parts.

NitroJoe: i am not stupid enough to pay $80 just for v1r shocks . They are NEO
Do you have the Part # and website. thanks a lot
NitroJoe is offline   Reply With Quote
Old 03-23-2003, 09:43 PM   #2154
Tech Adept
 
NitroJoe's Avatar
 
Join Date: Oct 2002
Location: Madison, Dairy Land
Posts: 121
Default NEO

Anybody know who make NEO kit? thanks
NitroJoe is offline   Reply With Quote
Old 03-23-2003, 09:51 PM   #2155
Tech Adept
 
phildee's Avatar
 
Join Date: Jan 2003
Location: Geelong, Vic, Australia
Posts: 191
Send a message via ICQ to phildee
Default

My new pipe and wheels/tires came today, havent tried it yet, but at least it looks cool
Attached Images
File Type: jpg new pipe.jpg (42.5 KB, 66 views)
phildee is offline   Reply With Quote
Old 03-23-2003, 10:06 PM   #2156
Tech Adept
 
xGSiR's Avatar
 
Join Date: Jan 2003
Location: Sydney, Australia
Posts: 230
Default

woah so thats the eagle red tune pipe.

red ain't my colour >.<
xGSiR is offline   Reply With Quote
Old 03-23-2003, 10:13 PM   #2157
Tech Addict
 
Join Date: Dec 2002
Location: Melbourne
Posts: 585
Default

Quote:
Originally posted by phildee
My new pipe and wheels/tires came today, havent tried it yet, but at least it looks cool
That's my pipe .
V-One S Racer is offline   Reply With Quote
Old 03-23-2003, 10:40 PM   #2158
Tech Master
 
squizzytaylor's Avatar
 
Join Date: Jun 2002
Location: Toronto NSW Australia
Posts: 1,119
Default

Quote:
Originally posted by V-One S Racer
That's my pipe .
Any luck with the car yet ?

gt

squizzytaylor is offline   Reply With Quote
Old 03-23-2003, 10:53 PM   #2159
Tech Addict
 
Join Date: Dec 2002
Location: Melbourne
Posts: 585
Default

Quote:
Originally posted by squizzytaylor
Any luck with the car yet ?

gt

I re-pulled the engine apart and followed the instructions thoroughly when i I put it together. Then went to try it out today... it started, ran for a few seconds... then stalled. Then I re-started it and it did the same thing. Then I went to start it again and the pull starter shits itself ! So I pulled the pullstarter off and put it back on, then I try to start it again... same process of stalling and the pullstarter shitting itself !

I inspected the pullstarter closely and it looks like I'll need a new one of them. To make matters worse... my carby is screwed, there's plastic missing around the low-end needle and it's got cracks in too many places to mention!

Hmmm..... what does that tell you ?
V-One S Racer is offline   Reply With Quote
Old 03-23-2003, 10:57 PM   #2160
Tech Master
 
squizzytaylor's Avatar
 
Join Date: Jun 2002
Location: Toronto NSW Australia
Posts: 1,119
Default

Quote:
Originally posted by V-One S Racer
I re-pulled the engine apart and followed the instructions thoroughly when i I put it together. Then went to try it out today... it started, ran for a few seconds... then stalled. Then I re-started it and it did the same thing. Then I went to start it again and the pull starter shits itself ! So I pulled the pullstarter off and put it back on, then I try to start it again... same process of stalling and the pullstarter shitting itself !

I inspected the pullstarter closely and it looks like I'll need a new one of them. To make matters worse... my carby is screwed, there's plastic missing around the low-end needle and it's got cracks in too many places to mention!

Hmmm..... what does that tell you ?
I can help out with a carb, but I lost half my pullstart bits when I dissasembled it for someone on here about 2-3 months ago.

Let me know

gt

squizzytaylor is offline   Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
All my FS in this thread Vincent_666 Australia For Sale/Trade 11 06-30-2007 03:13 AM
HK for sale thread/wanted to buy thread....finally Got Xray? Hong Kong Racing 1 04-06-2006 09:37 PM



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 06:09 AM.


Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net