R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Nitro On-Road

Reply
 
Thread Tools Search this Thread
Old 03-03-2003, 12:12 AM   #1561
Tech Master
 
sausage_link's Avatar
 
Join Date: Jun 2002
Location: Melb, Australia
Posts: 1,025
Send a message via ICQ to sausage_link
Default

so howz everyone been

thinking of getting a 350z body for my S
sausage_link is offline   Reply With Quote
Old 03-03-2003, 12:14 AM   #1562
Tech Master
 
sausage_link's Avatar
 
Join Date: Jun 2002
Location: Melb, Australia
Posts: 1,025
Send a message via ICQ to sausage_link
Default

if i start racing and i get anyone being a cunt im gunna thro my car at them
sausage_link is offline   Reply With Quote
Old 03-03-2003, 12:19 AM   #1563
Tech Addict
 
Join Date: Dec 2002
Location: Melbourne
Posts: 585
Default

Quote:
Originally posted by sausage_link
so howz everyone been

thinking of getting a 350z body for my S
I'm good !
V-One S Racer is offline   Reply With Quote
Old 03-03-2003, 12:20 AM   #1564
Tech Addict
 
Join Date: Dec 2002
Location: Melbourne
Posts: 585
Default

Quote:
Originally posted by sausage_link
cunt
You are one and you have one sausage !
V-One S Racer is offline   Reply With Quote
Old 03-03-2003, 12:38 AM   #1565
Tech Regular
 
Brett's Avatar
 
Join Date: Jun 2002
Location: Shellharbour NSW Australia
Posts: 348
Default

so how are u getting thes parts and shat soo cheap ????????
Brett is offline   Reply With Quote
Old 03-03-2003, 12:40 AM   #1566
Tech Champion
 
nitrodude's Avatar
 
Join Date: Aug 2002
Location: Oxnard, CA
Posts: 5,845
Trader Rating: 5 (100%+)
Default

I have tried the 350Z on my NTC3 and I dont recomend it. If its just for show go right ahead, its a beatiful car, but for racing, it handles like crap. It doesnt even have wing mounts, you just have to drill the holes wherever. You're going to want to trow it like a cunt

Thanks,

Steven Muller
Maximum Perforamance Parts
nitrodude is offline   Reply With Quote
Old 03-03-2003, 01:10 AM   #1567
Tech Master
 
sausage_link's Avatar
 
Join Date: Jun 2002
Location: Melb, Australia
Posts: 1,025
Send a message via ICQ to sausage_link
Default

i just had a lucky run today, i was driving my car, barely any fuel left in the tank, then the response slowed down and i lost alot of my braking and the car just stopped and i had slowed it down, my reciever battery went flat, sure was lucky
sausage_link is offline   Reply With Quote
Old 03-03-2003, 01:22 AM   #1568
Tech Master
 
squizzytaylor's Avatar
 
Join Date: Jun 2002
Location: Toronto NSW Australia
Posts: 1,119
Default

Quote:
Originally posted by nitrodude
I have tried the 350Z on my NTC3 and I dont recomend it. If its just for show go right ahead, its a beatiful car, but for racing, it handles like crap. It doesnt even have wing mounts, you just have to drill the holes wherever. You're going to want to trow it like a cunt

Thanks,

Steven Muller
Maximum Perforamance Parts


I saw one of these today (a real one) and can I say that finally there is a car in existence that makes even the Leyland P76 look good! Man.. the designer of the 350z was obviously incapable of an original thought and must have taken seriously wicked drugs that never totally wore off.

my 10c

gt

squizzytaylor is offline   Reply With Quote
Old 03-03-2003, 01:24 AM   #1569
Tech Master
 
squizzytaylor's Avatar
 
Join Date: Jun 2002
Location: Toronto NSW Australia
Posts: 1,119
Default im scared

Quote:
Originally posted by sausage_link
if i start racing and i get anyone being a cunt im gunna thro my car at them
Okay Sausage you win....please dont hit me!!!!!

Can we change the name here to the v-one-s swearing thread?

gt

squizzytaylor is offline   Reply With Quote
Old 03-03-2003, 01:40 AM   #1570
Tech Addict
 
Join Date: Aug 2002
Location: Australia, wollongong
Posts: 740
Send a message via ICQ to V-One S
Default

Quote:
Squizzy Taylor:
Oh by the way.....where is the website that is going to educate the world on how big this sport is........Id hate to think that all those company names I gave you weren't put to good use

Umm, yeah, that was me. and it sorta died in the rear end. I might get back around to it later though, i'll try and have it done by half way through this year.

Sorry Squizz.
V-One S is offline   Reply With Quote
Old 03-03-2003, 03:02 AM   #1571
Tech Adept
 
xGSiR's Avatar
 
Join Date: Jan 2003
Location: Sydney, Australia
Posts: 230
Default

exactly what i done with my V-One S today. I bashed it around!

The front bumper gone from new to damn wrecked! My car flipped 360 degrees when it hit a small lump on my road >.< twice....

Not only that, but my engine keeps on STALLING ARGHHh.

Stops here and there even when there is still fuel in there.

Could anyone list me there cause or solutions? im desperate. -_-
xGSiR is offline   Reply With Quote
Old 03-03-2003, 03:08 AM   #1572
Tech Master
 
squizzytaylor's Avatar
 
Join Date: Jun 2002
Location: Toronto NSW Australia
Posts: 1,119
Default

Quote:
Originally posted by xGSiR
exactly what i done with my V-One S today. I bashed it around!

The front bumper gone from new to damn wrecked! My car flipped 360 degrees when it hit a small lump on my road >.< twice....

Not only that, but my engine keeps on STALLING ARGHHh.

Stops here and there even when there is still fuel in there.

Could anyone list me there cause or solutions? im desperate. -_-

Rule #1 dont drive car on rough road

Is the car stalling when you are accelerating or when you stop accelerating and where are your top and low end currently set?

gt

squizzytaylor is offline   Reply With Quote
Old 03-03-2003, 03:22 AM   #1573
Tech Adept
 
xGSiR's Avatar
 
Join Date: Jan 2003
Location: Sydney, Australia
Posts: 230
Default

Well, several times it stops if i could remember:

- Car accelerates then stalls
- I do a donut with the car, then after it stalls
- Car runs around, then i hit the brakes, stops, and it stalls.

ALSO, when i pull my pullstart, it doesn't feel its holding onto anything anymore. Its like pulling on a string, without that pulling back feeling it use to have. It only goes back to normal when after the car runs around, it has that feeling again.

So its hard at first starting my car, then after that its fine because the recoil starter starts to give that thugging back feeling when u pull the string.
xGSiR is offline   Reply With Quote
Old 03-03-2003, 03:51 AM   #1574
Tech Master
 
sausage_link's Avatar
 
Join Date: Jun 2002
Location: Melb, Australia
Posts: 1,025
Send a message via ICQ to sausage_link
Default

does the pull starter do that after u have primed the engine? because mine does the same thing after i've primed the engine, id says its normal and a good way to tell u have primed the engine
sausage_link is offline   Reply With Quote
Old 03-03-2003, 04:03 AM   #1575
Tech Adept
 
xGSiR's Avatar
 
Join Date: Jan 2003
Location: Sydney, Australia
Posts: 230
Default

i admit today i treated my rc car as a lil basher >.<

I went physco with it. Im going to take very special care of the car now.

So many scratches on the chassis now.
xGSiR is offline   Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
All my FS in this thread Vincent_666 Australia For Sale/Trade 11 06-30-2007 03:13 AM
HK for sale thread/wanted to buy thread....finally Got Xray? Hong Kong Racing 1 04-06-2006 09:37 PM



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 01:52 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net