R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Nitro On-Road

Reply
 
Thread Tools Search this Thread
Old 02-04-2005, 07:52 AM   #1
Tech Elite
 
Join Date: Aug 2004
Location: Pole Position
Posts: 3,173
Trader Rating: 13 (93%+)
Default fw-05r - brake linkage problem ??

hey just a question regarding my brake linkage

i have it set up like the book however after i apply the brakes and then throttle, the car feels like the brakes are still slightly grabbing

i also tried leaving the bolts that screw the brake pads into the center bulkhead a bit more looser to help overcome

surely this cant be normal ?

what can i do to overcome this
thanks heaps
john
mrgsr is offline   Reply With Quote
Old 02-04-2005, 04:37 PM   #2
Tech Apprentice
 
V1R racer's Avatar
 
Join Date: Mar 2004
Location: UK
Posts: 56
Default

Hi
Make sure the brake pads are not catching on the bolts holding them on, or check the brake piston returns and does not stay out after the brake is let off

Hope that helps
V1R racer is offline   Reply With Quote
Old 02-04-2005, 10:27 PM   #3
Tech Elite
 
Join Date: Aug 2004
Location: Pole Position
Posts: 3,173
Trader Rating: 13 (93%+)
Default

yeh looks like the brake piston doesnt fully return after i throttle again

what could be the cause of this ?
mrgsr is offline   Reply With Quote
Old 02-27-2005, 02:14 AM   #4
Tech Master
 
NiMo's Avatar
 
Join Date: May 2004
Location: Luton, England
Posts: 1,704
Default

I've always thought it was the brake disk catching on the end of the pins.
What I do is to run an extra brake pad back plate which pushes the brake disk up the pins a bit more.
Had the same problem with the V-one R when I had it.
NiMo is offline   Reply With Quote
Old 02-27-2005, 04:23 AM   #5
Tech Regular
 
Join Date: Apr 2004
Location: batang kalokohan! ay kaloocan pala!!diretso ka lang,pag nasaksak ka! bahay na namin yung sa harap!
Posts: 328
Send a message via AIM to kyoshoBOY
Default Re: fw-05r - brake linkage problem ??

Quote:
Originally posted by mrgsr
hey just a question regarding my brake linkage

i have it set up like the book however after i apply the brakes and then throttle, the car feels like the brakes are still slightly grabbing

i also tried leaving the bolts that screw the brake pads into the center bulkhead a bit more looser to help overcome

surely this cant be normal ?

what can i do to overcome this
thanks heaps
john
put a short springs that would fit on the brake pads screw.
put them on the middle between the 2 brakepads.
cut the spring for desired length.
this is a 100% works!!
kyoshoBOY is offline   Reply With Quote
Old 02-27-2005, 03:03 PM   #6
Tech Elite
 
Join Date: Aug 2004
Location: Pole Position
Posts: 3,173
Trader Rating: 13 (93%+)
Default

that sounds like an awesome idea!

thanks heaps ill try it out
mrgsr is offline   Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
LOSI 8 THROTTLE/BRAKE LINKAGE HELP PLEASE mike williams Nitro Off-Road 3 05-18-2008 09:41 PM
how should throttle/brake linkage sit? cant get right. atebit Rookie Zone 2 10-11-2007 08:00 AM
Jammin .5 Throttle&Brake Linkage tooofast Nitro Off-Road 3 10-04-2007 09:51 PM
Throttle/Brake Linkage Setup dsl Electric Off-Road 1 04-17-2007 02:36 PM
hyper 7 brake linkage problem derricklong38 Electric Off-Road 1 02-14-2007 08:11 PM



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 04:58 AM.


Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net