R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Nitro On-Road

Reply
 
Thread Tools Search this Thread
Old 06-13-2002, 11:54 AM   #1
Tech Rookie
 
Join Date: Jun 2002
Posts: 11
Default more info on mugen prime 12

Folks,
I'm very new to this hobby.. just bought a used mugen prime 12 from ebay. I don't think it will come with any manuals so I'm trying to gather more info about the car via the web.

I'm trying to find a manual about the engine but all mugenracing.com tells me is that its a VX-12
does anybody know who manufactures the engine and where I can get a manual.. if anybody has a soft copy of it... could you please send it to me.
same goes for the car itself.

your help is greatly appreciated

my email is [email protected]

Slavka
slavka is offline   Reply With Quote
Old 06-21-2002, 06:25 AM   #2
Tech Regular
 
Brett's Avatar
 
Join Date: Jun 2002
Location: Shellharbour NSW Australia
Posts: 348
Default

slavka

i own a prime 12 aswell it was my first gas car, i have the instructions and all, the engine is made for mugen buy novarossi i have beed told, yes it is a vx 12 and it should have a slide carbie i am not shure on the specs of the engine because nothing that i got given when i purchased it (new that is) i have a full car if u want any info just ask. ill try and get everything scaned for u, hope i can help
Brett is offline   Reply With Quote
Old 06-21-2002, 09:08 AM   #3
Tech Rookie
 
Join Date: Jun 2002
Posts: 11
Default

Brett,

thank you very much for the reply,
I was able to get a hold of nitrohouse.com and they had a manual.. I've bought it from them. I appreciate your reply.

while we're at it.. maybe you can help me out with a different question. so I've got the car.. everything seems to be in working order. I was able to start it last night and when I do the wheels start rotating right away.. I didn't get much time to research it and was wondering do you know if its a trannie issue or do I have to "tweak" engine settings ?

Steve
slavka is offline   Reply With Quote
Old 06-21-2002, 11:16 PM   #4
Tech Regular
 
Brett's Avatar
 
Join Date: Jun 2002
Location: Shellharbour NSW Australia
Posts: 348
Default

well this is a dificult situation to talk about (well to explain so ill do my best) for starters when u put the car down(when running) does the car move when its idleing, if so turn down your idle, if the wheels turn when u pull the pullstarter that means your clutch has got stuck onto the cluch bell, when u have answered theses questions i can help u more
Brett is offline   Reply With Quote
Old 06-21-2002, 11:22 PM   #5
Tech Rookie
 
Join Date: Jun 2002
Posts: 11
Default

Brett,

I was mocking with it today and this is what I can tell ya.

I have the car off from the ground.. start the engine via pull start.. engine starts and wheels start spinning. my RPMs are irradic.. jumps up.. that dies down a little... I've tried decreasing idle RPM ( using the screw on the engine ) and it seems to help against the spinning wheels.. but my engine doesn't stay up ... maybe for 10 seconds and then RPM gradually die down until the engine shuts off. I've tried using a combination of both idle RPM and low RPM screws... to try and find a medium.. Just when I though I got it... ( no more spinning wheels ) when I give gas.. I see servo pulling on the carburator ? but car won't speed up.. I try several times and then starts going and WON'T stop... I have to steer it my way and hope to catch it

any ideas ? let me know if you need more info ..

thanx for your help Brett.

Steve
slavka is offline   Reply With Quote
Old 06-21-2002, 11:49 PM   #6
Tech Regular
 
Brett's Avatar
 
Join Date: Jun 2002
Location: Shellharbour NSW Australia
Posts: 348
Default

firstly set up your radio gear
1. take off your air filter so u can see your carbie
2. then set your trim on the throttel to netral
3. take the servo horn off
4. then shut the carbie up to the idle u have selected (it will go nofurther once it has touced the screw)
4then put the servo horn back on so now when u r not touching the remote the it shoud be in its idle postition
5. then make shure u can get full throttel and make shure u can get the breaks to work if not undoo the grub screw on the break linkage and slide it toard the leaver 9also make shure once it is at full and u release it it returns to the idle setting
6. try the car and get its idel ok then take it for a run if it just gets stuck on full u must have some sort of radio prob eg aerial or bad batts

hope this helps
Brett is offline   Reply With Quote
Old 06-22-2002, 09:23 AM   #7
Tech Rookie
 
Join Date: Jun 2002
Posts: 11
Default

Brett,

thanx for the help.. ( since I'm a VERY newbie.. what you've said is a little cryptic.. but I'll figure it out ) I'll and do what you've suggested.. and hopefully that will work.

Steve
slavka is offline   Reply With Quote
Old 06-23-2002, 04:42 PM   #8
Tech Rookie
 
Join Date: Jun 2002
Posts: 11
Default

Hey Brett,

I was able to figure out my problem(s)

1. spinning wheels = Break wasn't properly adjusted.. once I took care of that no more spinning wheels.

2. My engine was dying 5 secs after start = I've read that mixture was too rich.. leaned it.. my car is flying ( and of course I made sure i have a nice blue trail from exhaust )

I hope that I will get a chance to enjoy it for a little bit before I break it

thanx for all your help,

Steve
slavka is offline   Reply With Quote
Old 06-23-2002, 11:49 PM   #9
Tech Regular
 
Brett's Avatar
 
Join Date: Jun 2002
Location: Shellharbour NSW Australia
Posts: 348
Default

i am glad u got things sorted, if u need any other help just ask
Brett is offline   Reply With Quote
Old 06-28-2002, 07:59 AM   #10
Tech Regular
 
Join Date: Aug 2001
Posts: 262
Default

hi guys, i have a prime 12 that is fully decked out with all the alumn. chassis, arms, carriers, graphite brake disc and shock towers, 2 speed also has a stratus body to.
i will take $150.00 or if you have something to trade i am open to offers.
thanks mike jones
[email protected]
wwjd is offline   Reply With Quote
Old 06-28-2002, 01:58 PM   #11
Tech Rookie
 
Join Date: Jun 2002
Posts: 11
Default

Brett..

Please check your PM
slavka is offline   Reply With Quote
Old 06-30-2002, 04:42 PM   #12
Tech Initiate
 
Join Date: Jun 2002
Location: Fresno CA
Posts: 20
Send a message via AIM to HiepNOtik
Default

I ahave an msx 3 did you guys know they stop making the prime 12 cause teh msx3 came out cause it was a better engine. I was wondering if the sus arms and upright for the prime12 works for the msx3?
HiepNOtik is offline   Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
WTB a mugen Prime 12 Pepe R/C Items: Wanted to Buy 0 05-18-2006 01:51 PM
Mugen Prime 12 crashnburn R/C Items: For Sale/Trade 2 04-19-2006 11:15 AM
Mugen prime 12 2 speed gears? gt-boy Nitro On-Road 0 09-29-2003 01:29 AM
Mugen Prime 12 Lost Racer Nitro On-Road 3 04-16-2002 10:19 AM
Xpress mini and Mugen Prime 12 fs RIannitto R/C Items: For Sale/Trade 6 12-04-2001 06:42 PM



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 06:08 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net