R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Nitro On-Road

Reply
 
Thread Tools Search this Thread
Old 04-18-2011, 07:39 PM   #1
Tech Rookie
 
Join Date: Apr 2011
Posts: 1
Default New Kyosho inferno gt2, please help

Very new to R/C. Have a brand new inferno gt2. Having difficulty getting it started. I can get it to start after messing with the idle needle, the high speed needle, and the low speed needle. Also blowing into the exhaust seems to help. When I do get it to start, the wheels are turning super fast, and I basically have to hold the brake so it doesn't drive away. Need to know what should I do? Do I need to tweak the needles? Thanks for you help.
Nikosigs is offline   Reply With Quote
Old 04-18-2011, 08:42 PM   #2
Tech Champion
 
gashuffer's Avatar
 
Join Date: Nov 2006
Location: RcVille
Posts: 5,230
Trader Rating: 48 (100%+)
Default

Quote:
Originally Posted by Nikosigs View Post
Very new to R/C. Have a brand new inferno gt2. Having difficulty getting it started. I can get it to start after messing with the idle needle, the high speed needle, and the low speed needle. Also blowing into the exhaust seems to help. When I do get it to start, the wheels are turning super fast, and I basically have to hold the brake so it doesn't drive away. Need to know what should I do? Do I need to tweak the needles? Thanks for you help.
Your idle is too high. You need to set your carb up as per the instructions tell you. I would go back to factory needle settings.
What do you mean by blowing into the exhaust?
__________________
T-Sal
gashuffer is offline   Reply With Quote
Old 04-20-2011, 12:16 AM   #3
Tech Regular
 
Join Date: Apr 2009
Posts: 393
Trader Rating: 57 (98%+)
Default Inferno GT2

Quote:
Originally Posted by gashuffer View Post
Your idle is too high. You need to set your carb up as per the instructions tell you. I would go back to factory needle settings.
What do you mean by blowing into the exhaust?
Yes, it sounds like your idle is too high. If your idle is ok try checking your clutch spring. Maybe your clutch spring snapped.
INFERNOZ GTZ is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 12:53 PM.


Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net