R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Nitro On-Road

Reply
 
Thread Tools Search this Thread
Old 08-15-2010, 01:32 PM   #1
Tech Adept
 
Join Date: Aug 2010
Posts: 160
Trader Rating: 1 (100%+)
Default traxxas jato ez start problem help!!!!

hellow all i ave a question that no one can answer so maybe you guys can

ok i have had rc cars my whole life and i got into nitro about 4 years ago.i started out with a duratrax raze and it wasnt my favorite then i got a jato 3.3 3 years later.by far my favorite car runs on raod fine untill yesterday.

well it started when the famouse blue wire got abliterated so i got a new one and when i went to start it it didnt do anything motor light was on but glow plug light wasnt but the motor wouldnt turn so i took it to my lhs and we tried there ez starter on it and it did the same thing i would take this to traxxas but unfortinantly they are closed right now. so maybe you guys will kno please help

thanks
rustler jato is offline   Reply With Quote
Old 08-15-2010, 01:39 PM   #2
Tech Addict
 
Join Date: Jan 2007
Posts: 660
Default

If the electric start motor isn't turning then you don't have power running to that motor.

That's what I'd check first. Make sure you have it wired correctly.
Dredd is offline   Reply With Quote
Old 08-15-2010, 01:41 PM   #3
Tech Apprentice
 
Join Date: Jun 2010
Location: Bay area, CA
Posts: 90
Trader Rating: 12 (100%+)
Default

pull the glow plug and try to spin the motor...
ah4449 is offline   Reply With Quote
Old 08-15-2010, 01:45 PM   #4
Tech Adept
 
Join Date: Aug 2010
Posts: 160
Trader Rating: 1 (100%+)
Default

well its got to be wired correctly because the only wire that has ever been removed is the blur one and i took the spark pluge out earlyer and tried it and still had the same problem if thats what you mean weve tried new spark plugs old spark plugs new ez starters and it still wont work thats whats got me
rustler jato is offline   Reply With Quote
Old 08-15-2010, 02:06 PM   #5
Tech Adept
 
Join Date: Aug 2010
Posts: 160
Trader Rating: 1 (100%+)
Default

grr ok so now i puller off the motor wires and put them back on and it turned the mitor but still no glow plug light took out the golow plug and the glow plug wouldnt start up what the heck
rustler jato is offline   Reply With Quote
Old 08-15-2010, 02:15 PM   #6
Tech Addict
 
Join Date: Jan 2007
Posts: 660
Default

easy fix...use a standard glow igniter for the glow plug. I know you shouldn't have to, but if it gets you going...

Make sure the wire is firmly attached to the glow plug as well. Use a pair of needle nose pliers to press it on as tight as you can.

Your glow plug should glow orange/red when it's functioning properly. If it does not even with a standard glow igniter, then the glow plug is bad.
Dredd is offline   Reply With Quote
Old 04-17-2012, 01:52 AM   #7
Tech Rookie
 
Join Date: Mar 2012
Posts: 1
Default

I just got my jato today and have tge same problem i used 2 different glow plugs and the glow plug light still wont turn on
Slash4x4Cody is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 11:55 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net