NOVAROSSI Turbo Glow Plugs - BAD BATCH

You're on Page 1 of 2
Go to
  • Hi guys,

    We have been finding that there are some BAD Batches of
    Novarossi Turbo Glow Plugs in the market today.

    It's been on a few events where the plugs have just given up
    after only a tank of fuel and some even less. When we check
    the filament, its not distorted and is actually still shiny and in
    perfect spiral form. But it just doesn't illuminate... Very strange.

    A couple of weekends ago, one friend went thru 16 glow plugs
    during the entire weekend. And I know of a person who actually
    went thru 46 glow plugs during the Winternats.

    Very rediculous and also EXPENSIVE.
    Does anybody else been having the same experience?
  • Well that explains yesterday

    I went through 3 brand new #6 plugs in 3 heats. For the life of me I couldn't figure out why they were giving up. The engine was in tune, with good temps, and the plugs looked beautiful. They just wouldn't glow
  • That figures
    Yes, i've also been experiencing that. Not only turbo plugs but standard plugs too. No. 7 to be exact. I had 4 plugs last Saturday's practice which i picked up at me local track. And to make things matter worst, i only had 6 tanks full of practice runs. And if you look at the plugs, it looks fine but when you fire it up again, then it's gone.. WTF is going on!!
  • i hope this is temporary just because it is starting to cost a
    lot.
  • Just got back from Vegas (Speedline 2004) and was wondering what was going on with those plugs, two of us went through about 16 plugs. All would work fine until engine was shut down then some went bad. A few lasted several tanks but would still go bad. We tried lots of stuff before we put the blame on the plugs. Changed the tank, new exhaust line, motor, carb, ect. ------ Finally got different plugs and problem was gone.

    Others out there?
  • Same here in Indonesia.
    Mostly no.6 turbo.
    Seems like they having problem with their new plug body material.
  • Quote:
    Originally posted by GoldFinger
    Same here in Indonesia.
    Mostly no.6 turbo.
    Seems like they having problem with their new plug body material.
    no wonder....i thought my engine tuning problem. damn man
    yes that no.6 specifically.
  • Quote:
    Originally posted by Cat Skinner
    Just got back from Vegas (Speedline 2004) and was wondering what was going on with those plugs, two of us went through about 16 plugs. All would work fine until engine was shut down then some went bad. A few lasted several tanks but would still go bad. We tried lots of stuff before we put the blame on the plugs. Changed the tank, new exhaust line, motor, carb, ect. ------ Finally got different plugs and problem was gone.

    Others out there?
    Cat,

    That's exactly what happened to us.

    We started to put two and two together when we had gone
    thru about 11 plugs then ran out of #7s and #8s Turbo Plugs.
    So I had no choice but to put on one of my old plugs. Well what
    do you know, it lasted 2 entire qualifiers (with warm ups) and
    also a few tanks of practice runs after.

    Novarossi should fix this problem.
  • Sounds like a problem with the lower welding spot of the coil.
  • I too was experiencing the same thing. I was actually blowing a plug for every tank of fuel I ran and had never experienced that this kind of crap before. I switched the brand and it went away. We should atleast get something back. This is getting way too expensive.
  • Quote:
    Originally posted by stefan
    Sounds like a problem with the lower welding spot of the coil.
    I agree Stephan that that is whats happening...
    Since the coil seems perfect and shiny from the outside, it
    should be the inside connection that is giving up on these
    things. (Something we can't see when looking from the outside).
  • Man, that's why. I went through some NovaRossi plugs for my P5 motor for my buggy at the U.S. Gas Champs. I looked at the filament to see the condition, it looked ok. I ended buying some RB plugs I went through a few of those as well.
  • I hope this is sorted out soon because i can't afford to
    go through 5 to 10 plugs per weekend.
  • Quote:
    Originally posted by jwf_frani
    I hope this is sorted out soon because i can't afford to
    go through 5 to 10 plugs per weekend.
    I should be getting some plugs soon...I'll let you guys know if the problem goes away.
  • I just got 6 new plugs a couple of weeks ago.
    I hope none of them are from that bad batch.
    My brother sent them down from Washington state.
    Is Novarossi reimbursing us for any bad plugs?

Similar Threads