Go Back  R/C Tech Forums > General Forums > Nitro On-Road
Help me get this nitro Hpi rs4 3 evo Running >

Help me get this nitro Hpi rs4 3 evo Running

Help me get this nitro Hpi rs4 3 evo Running

Reply

Old 11-19-2009, 09:21 AM
  #1  
Tech Rookie
Thread Starter
 
Join Date: Nov 2009
Posts: 3
Default Help me get this nitro Hpi rs4 3 evo Running

I just got a hpi nitro rs4 from a guy on craigslist its looks great and i got everything to get it fired up but when i give it gas it just revs up and wont move but if i do lift it up and give it gas the wheels will move a little but not very fast. Please help me get this car running like it should
Bradwitt is offline  
Reply With Quote
Old 11-23-2009, 08:19 PM
  #2  
Tech Rookie
 
Join Date: Nov 2009
Location: Earth, I think...
Posts: 9
Lightbulb

I expect its the engine problem... do the servos still work? if so, try adjusting the two needles on the engine while powering it.

hope that helps
dayv1d0 is offline  
Reply With Quote
Old 11-23-2009, 08:20 PM
  #3  
Tech Rookie
 
Join Date: Nov 2009
Location: Earth, I think...
Posts: 9
Lightbulb

also maybe try change the glow plug. its usually the stock ones that fail
dayv1d0 is offline  
Reply With Quote
Old 11-23-2009, 11:08 PM
  #4  
Tech Regular
iTrader: (2)
 
Sniffer's Avatar
 
Join Date: Nov 2005
Location: Adelaide
Posts: 401
Trader Rating: 2 (100%+)
Default

Its probably missing the clutch shoes.

We sold one through our shop a few weeks ago and the shoes were missing (BNIB - never opened )

DN
Sniffer is offline  
Reply With Quote

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Thread Tools
Search this Thread

Contact Us Archive Advertising Cookie Policy Terms of Service