R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Nitro On-Road

Reply
 
Thread Tools Search this Thread
Old 08-19-2009, 09:35 AM   #1
Tech Initiate
 
Join Date: Aug 2009
Posts: 27
Trader Rating: 2 (100%+)
Default Centax new problem

I ve been running centax clutches for a while now with out any problems. Ive set the nut that holds the spring after the shoe 9mm as stated in the manuals. It runs fine for 10 mins then the clutches slip. Everytime I take it apart the nut that holds the spring has screwed its self fully in. Any ideas what might be causing this?
Thanks
one58 is offline   Reply With Quote
Old 08-19-2009, 09:37 AM   #2
Tech Fanatic
 
SERPENT7twenty's Avatar
 
Join Date: Jul 2009
Location: Newport Beach, CA
Posts: 812
Trader Rating: 20 (100%+)
Default

Call Serpent directly.
__________________
TEAM KAMIKAZE - SERPENT 966 - NOVAROSSI - HUDY - KO PROPO - XCEED
Kamikaze Development Driver - R&D = Rebuild & Destroy
www.Kamikazetoysandhobbies.com
SERPENT7twenty is offline   Reply With Quote
Old 08-19-2009, 10:17 AM   #3
Tech Champion
 
Roelof's Avatar
 
Join Date: Aug 2007
Location: Holland
Posts: 6,281
Send a message via ICQ to Roelof
Default

Be sure the nut and inside the clutchbell are smooth. When using a pin from the outside setting the nut you can bend some material of the nut to the outside touching the clutchbell.
And you can use some weak threadlock on the nut.
__________________
The quality of an answer comes with the quality of the question.
Roelof is online now   Reply With Quote
Old 08-19-2009, 10:48 AM   #4
Tech Lord
 
wingracer's Avatar
 
Join Date: Nov 2007
Posts: 12,861
Trader Rating: 24 (100%+)
Default

Quote:
Originally Posted by Roelof View Post
And you can use some weak threadlock on the nut.
That's what I do. I little dab of blue loctite and it's good to go. Once it's been done once, it forms a little ridge inside the nut so I usually don't have to reapply it. It can be moved easily until it gets to that ridge so it wont tighten up.
__________________
Sean. Certified speed crazed mowron.
Team Shepherd USA
www.ashfordhobby.com
wingracer is offline   Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Rc10ntc3 Taz_S Nitro On-Road 9437 05-28-2017 09:13 PM
HPI R40 Nitro Car Forum EVOLUTION Nitro On-Road 11979 06-26-2012 08:57 PM
RDLogics Mongoose KMac Nitro On-Road 2117 03-09-2011 01:57 AM
Serpent 710 Ron C. Nitro On-Road 23347 03-16-2010 02:47 PM
OS TZ running @ neutral bboy Nitro On-Road 6 05-01-2008 08:54 AM
Serpent 705 centax question. sstupid Nitro On-Road 16 01-21-2006 05:33 PM



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 01:27 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net