R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Nitro On-Road

Reply
 
Thread Tools Search this Thread
Old 05-26-2009, 12:39 AM   #1
Tech Rookie
 
ntc3bionicracer's Avatar
 
Join Date: Jan 2009
Location: mandeville,la.
Posts: 18
Send a message via ICQ to ntc3bionicracer Send a message via AIM to ntc3bionicracer Send a message via MSN to ntc3bionicracer Send a message via Yahoo to ntc3bionicracer Send a message via Skype™ to ntc3bionicracer
Default jatos brakes

i just broke in a new jato and when finished and started to run fast and wide open after the 5th tank of fuel,,the brakes do not work well at fast speeds they work well at lower speeds they are working correct it seems anyone have any info, is there a better system to replace the stock stuff ???? any info where to purchase
ntc3bionicracer is offline   Reply With Quote
Old 05-26-2009, 10:34 AM   #2
Tech Regular
 
Join Date: Nov 2008
Location: Virginia, USA
Posts: 480
Trader Rating: 3 (100%+)
Default

Have you tried adjusting the throttle/brake linkage to give you more braking power or tighening the screws on the brake pads?

Otherwise check towerhobbies for upgrade parts
Kyo83 is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 08:45 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net