R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Nitro On-Road

Reply
 
Thread Tools Search this Thread
Old 11-17-2003, 03:14 AM   #1
Tech Adept
 
Fiream's Avatar
 
Join Date: Oct 2002
Posts: 109
Send a message via AIM to Fiream
Default Been Awhile...Setup still needs work...lol

hey guys,

It's been awhlie since I last posted here......Let me update you....

Well the guy who owned the hobby store with the horrible track finaly moved into a new place.... Connecticut, USA now as the country's only Indoor Nitro Track 100ft X 60ft.....really flat really fast and really fun..... With that said, My setup still sucks, but it's better then it was..... here goes my setup:

Hpi RS4-2

Engine: Trinity Picco XP .15, Side Exhaust, Pull Start

Chassi: Stock, Side and front belt tensioners

Ride Height F/R: 3mm/5mm

Diff F/R: No Oil, light grease/40 weight,Red oil color....

Swaybars F/R: Red, Medium/Red, Medium

Shocks F/R: Stock oil Red Springs/ Stock oil Red Springs(White Springs on order)

Toe F/R: Stock/Stock

Camber F/R: 2*/2*

Tires F/R: Foams 35*/Foam 40*


Well thats pretty much it, tell me what you think.....the track is almost completely flat, very few bumps at all......

Track:

Size: 100ft x 60ft

Traction:

VHT Track Bite aplyed every 2 months, very sticky till about the 6 week, then it starts having alittle less bite but not too much less......

Conditions:

Fan ventalation, No heat, Humid durring summer, Cold in winter...

I was wondering if I could get away with running slicks, it's sticky enough, but durring the winter might be hard due to the cold.....

Let me know what you guys think.........


Thanks,
Rob
Attached Images
File Type: jpg dcp_0025.jpg (152.4 KB, 53 views)
Fiream is offline   Reply With Quote
Old 11-17-2003, 03:17 AM   #2
Tech Adept
 
Fiream's Avatar
 
Join Date: Oct 2002
Posts: 109
Send a message via AIM to Fiream
Default

2
Attached Images
File Type: jpg dcp_0025.jpg (152.4 KB, 60 views)
Fiream is offline   Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Been here for awhile but 1st post. Bmaxx Rookie Zone 5 04-08-2008 06:45 PM
Would this setup work Hayden Electric On-Road 0 06-12-2006 06:54 AM
Would this charge setup work (photos)? Michael_T Electric On-Road 6 12-28-2005 08:59 PM
it's been awhile, and not sure . gator Electric On-Road 18 10-04-2002 12:46 PM



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 03:18 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net