R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Nitro On-Road

Reply
 
Thread Tools Search this Thread
Old 01-03-2009, 10:07 PM   #1
Tech Initiate
 
cupton79's Avatar
 
Join Date: Dec 2008
Location: Tennessee, United states
Posts: 40
Default traxxas 2.5 issues

I had a traxxas 2.5 on my nitro 4-tec, until yesterday when it blew up. it had just been rebuilt with new rod,piston and sleeve set and only had little over a quart of fuel threw it after the factory recomended break-in was completed.

I pulled it apart and the clip that holds the wristpin in had come out and wedged itself between the piston and sleeve and busted the side out of the piston, is this typical of the 2.5s or just my luck?

I already have a traxxas 3.3 on the way to replace the 2.5, I know several people that have the 3.3s and they get at least 5 to 6 gallons out of them before they split the rod, plus the 3.3 has tons more power.


thanks,
chuck
cupton79 is offline   Reply With Quote
Old 01-04-2009, 04:56 AM   #2
Tech Regular
 
Join Date: Jul 2004
Posts: 364
Default

It could happen to any engine.
Edgar Millenium is offline   Reply With Quote
Old 01-04-2009, 06:37 AM   #3
Tech Initiate
 
cupton79's Avatar
 
Join Date: Dec 2008
Location: Tennessee, United states
Posts: 40
Default

thats kinda what I was thinking, just wanted someone else to say it! lol!!

thanks
cupton79 is offline   Reply With Quote
Old 01-05-2009, 05:51 AM   #4
Tech Master
 
JetMD's Avatar
 
Join Date: Jan 2006
Location: Richmond VA
Posts: 1,172
Trader Rating: 1 (100%+)
Default

Happened to my OS TZ. The piston and rod make a nice addition to my keychain though..
__________________
www.vorra.org

MINO Racing
JetMD is offline   Reply With Quote
Old 01-08-2009, 09:12 PM   #5
Tech Initiate
 
cupton79's Avatar
 
Join Date: Dec 2008
Location: Tennessee, United states
Posts: 40
Default

well I got my 3.3 today and got it installed on my 4-tec and ran the first break-in tank threw it and noticed it didnt seem to idle consistantly so I pressure tested and found that the front bearing is leaking a little.

is this normal for a new engine?
cupton79 is offline   Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Trukz Calgary - 1/10 Scale Off road Racing mfd Canadian R/C Scene 1666 12-08-2017 05:21 PM
Short Course Racing Flying Monkey Georgia Racing 35 04-06-2009 06:32 PM
RTR Traxxas Slash w/extras!!! slaytanic R/C Items: For Sale/Trade 18 02-02-2009 02:55 PM
T-maxx issues..many of them TRYMY4.0 Nitro Off-Road 6 01-02-2009 01:23 PM
*Complete* modified Revo part out chixwithtrix R/C Items: For Sale/Trade 25 09-17-2007 06:30 PM



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 05:11 PM.


Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net