R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Nitro On-Road

Reply
 
Thread Tools Search this Thread
Old 08-17-2008, 12:25 PM   #1
Tech Master
 
BIG DADDY8's Avatar
 
Join Date: Dec 2004
Location: AUSTIN, TX
Posts: 1,544
Trader Rating: 62 (100%+)
Send a message via AIM to BIG DADDY8
Unhappy Breaking in picco .12xp and keeps blowing plugs????????

I recently purchased a picco .12xp and i am trying to break it in. I didn't even get through a half a tank and have blown 3 plugs already . Im using 20% odonol fuel. THe first 2 were the macoy MC-59(midium hot) and the other was an odonal Hot plug. Can someone tell me whats wrong??????

Last edited by BIG DADDY8; 08-17-2008 at 10:20 PM.
BIG DADDY8 is offline   Reply With Quote
Old 08-17-2008, 12:53 PM   #2
Tech Addict
 
KyoshokiddT.D's Avatar
 
Join Date: Mar 2008
Location: st james city
Posts: 637
Default

whats the temp.
KyoshokiddT.D is offline   Reply With Quote
Old 08-17-2008, 05:15 PM   #3
Tech Master
 
BIG DADDY8's Avatar
 
Join Date: Dec 2004
Location: AUSTIN, TX
Posts: 1,544
Trader Rating: 62 (100%+)
Send a message via AIM to BIG DADDY8
Default

Quote:
Originally Posted by KyoshokiddT.D View Post
whats the temp.
Well it weird i put a R5 plug(cold) and went through a whole take. The temp it at 170. Seems to be working fine for now.

Anyone recommend a plug for it down here in TX? I think i used the MC-59's in my last picco motor. Maybe the OS #8 would be better? Any suggetions?
BIG DADDY8 is offline   Reply With Quote
Old 08-17-2008, 06:47 PM   #4
Tech Master
 
roadrage's Avatar
 
Join Date: Mar 2004
Location: Palm Bay, FL.
Posts: 1,224
Trader Rating: 14 (100%+)
Default

use a cold plug
__________________
Austin Wolfe
Serpent America-Trinity/Revtech-www.ActivRC.com
roadrage is offline   Reply With Quote
Old 08-17-2008, 07:21 PM   #5
Tech Master
 
BIG DADDY8's Avatar
 
Join Date: Dec 2004
Location: AUSTIN, TX
Posts: 1,544
Trader Rating: 62 (100%+)
Send a message via AIM to BIG DADDY8
Default

Quote:
Originally Posted by roadrage View Post
use a cold plug
That's was my last plug and it lasted through 2 tanks. Used the OS R5 cold plug. seems to run fine.
BIG DADDY8 is offline   Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
blowing plugs spudly12 Nitro Off-Road 6 12-28-2007 04:41 PM
Picco .12XP, New in original box! t4ftracer R/C Items: For Sale/Trade 4 10-29-2007 05:39 PM
Why? (Blowing plugs) Bob Moore Electric Off-Road 8 07-17-2006 01:19 PM
Picco 12XP in original box Shiloh R/C Items: For Sale/Trade 1 05-09-2006 03:17 PM
Picco .12Xp -help fox-crazy Australian Racing 1 09-07-2004 07:16 AM



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 06:45 AM.


Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net