R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Nitro On-Road

Reply
 
Thread Tools Search this Thread
Old 09-22-2007, 01:44 PM   #9181
Tech Master
 
Join Date: Mar 2002
Location: upstate New York
Posts: 1,364
Trader Rating: 21 (100%+)
Default

Quote:
Originally Posted by rollagen View Post
wont that wear out the bushings faster or is from crashin intocrap
It doesn't seem to wear them any quicker.Maybe the crap? I race mine,only replaced them once so far...And I hit some crap too.Just use some sort of dry lube on them.Teflon spray that dries..doesn't stay wet.Keep em lubed should last awhile.Mario.
lotus1 is offline   Reply With Quote
Old 09-22-2007, 06:46 PM   #9182
Tech Apprentice
 
rollagen's Avatar
 
Join Date: Jul 2007
Posts: 71
Trader Rating: 1 (100%+)
Default

cool i will try that thanks
rollagen is offline   Reply With Quote
Old 09-26-2007, 10:03 PM   #9183
Tech Apprentice
 
rollagen's Avatar
 
Join Date: Jul 2007
Posts: 71
Trader Rating: 1 (100%+)
Default

if i side swip someone or hit a corner marker and lifts the car off the ground sometime my steering gets stuck is that my servo or someting in the suspension hangin up? anyone have this problem? i replaced the swing rack bushings thinkin his would take of the problem but it did not. any help will be greatly appreciated. thanks in advance
rollagen is offline   Reply With Quote
Old 09-28-2007, 01:43 PM   #9184
Tech Master
 
Join Date: Mar 2002
Location: upstate New York
Posts: 1,364
Trader Rating: 21 (100%+)
Default

Quote:
Originally Posted by rollagen View Post
if i side swip someone or hit a corner marker and lifts the car off the ground sometime my steering gets stuck is that my servo or someting in the suspension hangin up? anyone have this problem? i replaced the swing rack bushings thinkin his would take of the problem but it did not. any help will be greatly appreciated. thanks in advance
Check the screw that holds the sevo saver together.It really needs to be shortened..can get hung up on the shaft.Try disconnecting the sevo and see if the steering is binding without it.Check the ball ends/turnbuckles(might have too much steering throw),and the pivot balls..too tight.If not either of these then probably the servo.Let me know how it goes.Mario.
lotus1 is offline   Reply With Quote
Old 09-30-2007, 02:11 AM   #9185
Tech Apprentice
 
rollagen's Avatar
 
Join Date: Jul 2007
Posts: 71
Trader Rating: 1 (100%+)
Default

ok i will try the screw thing cause i had to change the screw before. thanks
rollagen is offline   Reply With Quote
Old 09-30-2007, 10:02 AM   #9186
Tech Regular
 
badKarma's Avatar
 
Join Date: Nov 2004
Location: Madison, WI/Miami, FL
Posts: 443
Send a message via AIM to badKarma Send a message via Yahoo to badKarma
Default

bout to pull the old NTC3 out and do a restore...honestly,i havent touched the car in about 2 years...are they still putting out aftermarket parts for this car? if so, can anyone advise a trick exotic chassis i can start with? help me out please...
badKarma is offline   Reply With Quote
Old 09-30-2007, 10:03 PM   #9187
Tech Master
 
Join Date: Mar 2002
Location: upstate New York
Posts: 1,364
Trader Rating: 21 (100%+)
Default

Quote:
Originally Posted by badKarma View Post
bout to pull the old NTC3 out and do a restore...honestly,i havent touched the car in about 2 years...are they still putting out aftermarket parts for this car? if so, can anyone advise a trick exotic chassis i can start with? help me out please...
Try Rcmart.They still list one.Mario.
lotus1 is offline   Reply With Quote
Old 10-01-2007, 05:13 AM   #9188
Tech Regular
 
badKarma's Avatar
 
Join Date: Nov 2004
Location: Madison, WI/Miami, FL
Posts: 443
Send a message via AIM to badKarma Send a message via Yahoo to badKarma
Default

thanks...question... i was looking at the K Factory upgrade parts, besides the low CG fuel tanks, what other parts are actually of use and worth buying? can anyone advise on the aluminun steering hub carriers? of should i just stick with the regular nylon? how about the hard coated aluminum swing rack?

After a good inspection of the car, i see that i need new CVDs or Universals...Should i just go with the Factory Team ones that Team Associated makes? thanks alot guys for the help...if you guys want, i can snap a few pics as i put on each of the new trick parts...remember, anyone with ideas for trick parts, hit me up...this car is just gona be a tuner, not a track racer...thanks....
badKarma is offline   Reply With Quote
Old 10-01-2007, 03:48 PM   #9189
Tech Regular
 
badKarma's Avatar
 
Join Date: Nov 2004
Location: Madison, WI/Miami, FL
Posts: 443
Send a message via AIM to badKarma Send a message via Yahoo to badKarma
Default

anyone? come on, i know its still a few people out there with old school NTC3's!!!!
badKarma is offline   Reply With Quote
Old 10-01-2007, 05:49 PM   #9190
Tech Addict
 
wes95_z28's Avatar
 
Join Date: Dec 2006
Location: Norman, Ok
Posts: 747
Trader Rating: 3 (100%+)
Default NTC3 Two speed issues... NEED HELP

Okay, whenever i start running my nitro tc3, it starts and runs great except for right around the time it should engage into 2nd gear the motor free revs like its in nuetral. I have tried slight adjustments on both set screws on both clutchs shoes just thinking that the shoes are slipping on the clutch bell. after that didnt fix it i tried some major adjustments and that has yet to yeild any results. Then today i was running it and i would start it on the bump box and the tranny was engaged with the wheels and spinning them the way they should. When i blipped the throttle it engaged second gear and then i grabbed a handful of brake, the tires and driveshaft stopped but the spur gears and clutch bell kept turning. I stuck my tuning driver against the clutch bell to get the spur gears to slow down and then it seemed like the one-way engaged again. Is my one-way bad or is it just an adjustment issue? I am about at my wits end with this two speed and i am about to just buy all new components.
__________________
Wes

Kyosho 777 WC w/ big bores, RB S5, ACE 1313 s., Air 357 t., JP-3
HPI Savage X SS, Axial .28, Hitec 5645 Steering servo
Nitro TC3, O.S. .18 CV-R
Associated RC18T, Brushless, Lipo
wes95_z28 is offline   Reply With Quote
Old 10-01-2007, 07:37 PM   #9191
Tech Elite
 
lil-bump's Avatar
 
Join Date: Aug 2006
Location: The Cold Great Lakes
Posts: 2,963
Trader Rating: 83 (100%+)
Default

I haven't ran a ntc3 in couple of years but it seems like your one needle bearing is going bad. Try to clean your oneway needle bearing with some motor spray or brake clean( something with no oil in it) this should help keep your oneway engaged if it still occurs you may want to replace your 1st gear oneway. but check out the Rcntc3 thread it has a ton of info in it.... hope this helps


Also you may need to take the 2speed apart and check for the cross pin that latches the 2 speed shoes to the shaft.
lil-bump is offline   Reply With Quote
Old 10-01-2007, 07:44 PM   #9192
Tech Addict
 
Zootcapri's Avatar
 
Join Date: Jun 2004
Location: Utah
Posts: 714
Trader Rating: 6 (100%+)
Default

Change the one-way and the problem will go away.

You can try to clean it... but generally... you will have the same problem pretty quickly after you run some more. Either way, clean or replace, make sure that you put some of the clear diff grease (not a lot) in the bearing....this is something that not all of the instructions tell you... but needs to be done on assembly.

Last edited by Zootcapri; 10-01-2007 at 08:24 PM. Reason: clarification
Zootcapri is offline   Reply With Quote
Old 10-02-2007, 01:52 AM   #9193
Tech Addict
 
hooked_on's Avatar
 
Join Date: Apr 2002
Location: Australia
Posts: 725
Trader Rating: 1 (100%+)
Default

Hi

I have just finished assembly of a team edition, installed a OS Tz and it won't start. The engine ran fine in my R40, it is the needle setting because of the different fuel pressure and exhaust pipe?
__________________
- - - - 2013 Dick Johnson Racing Team Mate Member - - - -
hooked_on is offline   Reply With Quote
Old 10-02-2007, 07:56 AM   #9194
Tech Elite
 
lil-bump's Avatar
 
Join Date: Aug 2006
Location: The Cold Great Lakes
Posts: 2,963
Trader Rating: 83 (100%+)
Default

Check your pressure line,fuel lines, glow plug if worked in one car it should work in another car.
lil-bump is offline   Reply With Quote
Old 11-01-2007, 03:39 AM   #9195
Tech Regular
 
paul73rc's Avatar
 
Join Date: Apr 2007
Location: Gold Coast, QLD
Posts: 443
Trader Rating: 5 (78%+)
Default

Hi guys, I have a couple NTC3's and one of them I have a problem with. I noticed it when one day it took a 5m area just to do a u-turn. Not sure if I'm making sense but what I mean it has a lack of steering. I had a look at my other cars and the steering setup looks exact same as eachother but for some reason it doesn't turn good. It is affecting me heaps because in races I can't turn corners at all.

Has anyone had this problem or does someone have a solution to this. I changed the servo, the setup and for some reason it still doesn't turn that much. The angles of the tyres at full turn are shallower than my other NTC3's.

Does someone have a photo of the front of their NTC3 they could post so I can see how it is exactly setup?

Thanks, any help appreciated
paul73rc is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 07:44 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net