Like Tree2Likes

Rc10ntc3

Old 02-25-2002, 06:20 PM
  #316  
Tech Fanatic
 
kitracer's Avatar
 
Join Date: Sep 2001
Location: hong kong
Posts: 986
Default

Originally posted by Manticore


It seems this kind of story never end. Do you agree ernest?? hahahaha
yeah.... I was announced TQ after 1st round
wasn't hard, didn't I tell u we only had 12 people on the touring class.......
But by the last round , my a$$ got kicked. end up 3rd
kitracer is offline  
Old 02-25-2002, 06:30 PM
  #317  
Tech Fanatic
 
kitracer's Avatar
 
Join Date: Sep 2001
Location: hong kong
Posts: 986
Default

Originally posted by ernestf
kitracer, thanks for sharing the setting info.
a few more questions : which starter box u are using on the ntc3 ? where u can get this type of starter box in HK ? which body are u running now ? TC body or VDS ?
I bought must of my stuff from International Hobby.
I used the Taiwan box in red color.... I can't remember the name sorry!

I haven't tried the VDS or lola body, you have to cut so much off for pipes and the front shock mount, it will affect the handling. I saw one with the vds and it looks really shiiiiiii

Will be in MK today for sure
kitracer is offline  
Old 02-25-2002, 08:07 PM
  #318  
Tech Elite
iTrader: (2)
 
ernestf's Avatar
 
Join Date: Aug 2001
Location: Singapore
Posts: 2,045
Trader Rating: 2 (100%+)
Default

kitracer, so i guess the red in color starter box u bought from on-tau (international hobby) fit NTC3 nicely. i have another Taiwan starter box but it cannot fit the fly wheel position of NTC3 even tho i rolate the rubber wheel direction in the starter box.
i will check out international hobby for the starter box. thanks !
ernestf is offline  
Old 02-27-2002, 09:24 PM
  #319  
Regional Moderator
iTrader: (3)
 
kansasracer's Avatar
 
Join Date: Aug 2001
Location: Olathe, KS
Posts: 1,615
Trader Rating: 3 (100%+)
Default

OK,

now that were done with that!!!

Has anyone used the blade sway bar setup yet?
kansasracer is offline  
Old 02-27-2002, 10:01 PM
  #320  
Tech Fanatic
 
kitracer's Avatar
 
Join Date: Sep 2001
Location: hong kong
Posts: 986
Default

what about the one way.. Anybody tried if it will work and last a 30 mins main final?
kitracer is offline  
Old 02-28-2002, 06:15 AM
  #321  
Tech Elite
iTrader: (2)
 
TPhalen's Avatar
 
Join Date: Aug 2001
Location: Irvine, CA
Posts: 2,916
Trader Rating: 2 (100%+)
Default

Kansasracer: Ya, the blade is really the way to go. It's much easier to adjust than the bar type. Just pivot the blades to get more or less, ummm, stiffness, on the front end....good tuning tool, especially if you run foams.

kitracer: Yes, the one-way will last a 30 minute main without a problem (we've run 45 minutes mains without a problem). I would suggest a little maintenance after every long race, though, just as you might do with the rest of your car.
TPhalen is offline  
Old 03-01-2002, 03:55 AM
  #322  
Tech Regular
iTrader: (8)
 
Join Date: Aug 2001
Location: Columbus, OH
Posts: 259
Trader Rating: 8 (100%+)
Default

Hey guys...I need some help. I'm assembling my NTC3 and I'm at the part where I'm building my two speed. The instuction manual says the shaft shouldn't be able to rock once the clutch shoe balls are touching the two flat sides of the shaft. It also says that if it is able to be rocked the balls should be tightened to the point where the shoes do not separate. Problem I'm having is I can't seem to get the shaft to remain stable even once the clutch balls have been tightened. If I tighten them too much the shoes start to separate. Am I doing something wrong? The rocking back and forth of the shaft is not pronounced....it's almost like a slight slip from side to side when I try and turn it. Any assistance would be appreciated

Tony - Any chance we'll see some pics of your car soon? Have you had a chance to run with foams? If so, what set up are you using?
Schuie Driver is offline  
Old 03-01-2002, 08:24 AM
  #323  
Regional Moderator
iTrader: (3)
 
kansasracer's Avatar
 
Join Date: Aug 2001
Location: Olathe, KS
Posts: 1,615
Trader Rating: 3 (100%+)
Default

S Driver:

Mine moved ever so slightly even though I tightened it down all the way, even with the shoes spreading. I backed them off until they were as tight as I could get them before spreading. I haven't really broke them it in yet, but I would assume that the shaft will move slightly, just not sloppy.

I could be wrong, and if I am...please someone let me know because that means that I have it wrong as well...
kansasracer is offline  
Old 03-01-2002, 08:58 AM
  #324  
Tech Elite
iTrader: (2)
 
TPhalen's Avatar
 
Join Date: Aug 2001
Location: Irvine, CA
Posts: 2,916
Trader Rating: 2 (100%+)
Default

Should have pix of mine on my site this weekend...
TPhalen is offline  
Old 03-01-2002, 10:05 AM
  #325  
Tech Elite
 
Corse-R's Avatar
 
Join Date: Aug 2001
Location: Madrid (Spain)
Posts: 2,121
Default New car, new ammo....

Hi guys:

After reading so much about the ntc3 and the hype created I went lazy and got one and a RB X12 and start to assemble probably next week (this weekend and the next I have my favourite 'drug': Competition).

So, during this week I'm totally open to little tricks suggestions and setups to test (I'm totally newbie to those smokey and greasy things ). With the car I got a solid axle (sorry: one-way not available, bummer!) and some springs that I haven't used on my electric TC3.

I'll post some pics when I finish them and paint the body.
Corse-R is offline  
Old 03-01-2002, 08:15 PM
  #326  
Tech Fanatic
 
kitracer's Avatar
 
Join Date: Sep 2001
Location: hong kong
Posts: 986
Default

Originally posted by Schuie Driver
Hey guys...I need some help. I'm assembling my NTC3 and I'm at the part where I'm building my two speed. The instuction manual says the shaft shouldn't be able to rock once the clutch shoe balls are touching the two flat sides of the shaft. It also says that if it is able to be rocked the balls should be tightened to the point where the shoes do not separate. Problem I'm having is I can't seem to get the shaft to remain stable even once the clutch balls have been tightened. If I tighten them too much the shoes start to separate. Am I doing something wrong? The rocking back and forth of the shaft is not pronounced....it's almost like a slight slip from side to side when I try and turn it. Any assistance would be appreciated

Tony - Any chance we'll see some pics of your car soon? Have you had a chance to run with foams? If so, what set up are you using?
On mine, just tighten it until it just starting to spread the shoe and then back it off. The shoe will rock a bit but it doesn't affect the performance or the durability. other words, NO problem.
kitracer is offline  
Old 03-02-2002, 05:09 AM
  #327  
Tech Regular
iTrader: (8)
 
Join Date: Aug 2001
Location: Columbus, OH
Posts: 259
Trader Rating: 8 (100%+)
Default

Thanks for the help guys! Construction continues this weekend Just out of curiousity, what engines and air filters are all of you running with your cars? I'll be using a Mugen MT12 slide carb but I have not decided on an air filter yet. Trying to decide between the Motorsaver or the Trinity one that RC Extreme used in their test of the NTC3.
Schuie Driver is offline  
Old 03-02-2002, 06:09 AM
  #328  
Tech Apprentice
 
Join Date: Dec 2001
Location: central ohio
Posts: 62
Default

Originally posted by Schuie Driver
Thanks for the help guys! Construction continues this weekend Just out of curiousity, what engines and air filters are all of you running with your cars? I'll be using a Mugen MT12 slide carb but I have not decided on an air filter yet. Trying to decide between the Motorsaver or the Trinity one that RC Extreme used in their test of the NTC3.
I'm using the OS TR 12.Nice motor!I'm about halfway through the break in.I'm currently using the stock OS filter.In the past I have had very good results with Motorsaver so I will probably go there again.Looks like we may actually have temps good enough to finish the break in today! First race at CORCAR is May 5!
blimey is offline  
Old 03-02-2002, 06:57 AM
  #329  
Regional Moderator
iTrader: (3)
 
kansasracer's Avatar
 
Join Date: Aug 2001
Location: Olathe, KS
Posts: 1,615
Trader Rating: 3 (100%+)
Default

I'm using a MT12....can't go wrong with the best!!!

Last edited by kansasracer; 03-02-2002 at 08:05 AM.
kansasracer is offline  
Old 03-02-2002, 07:02 AM
  #330  
Tech Apprentice
 
Join Date: Dec 2001
Location: central ohio
Posts: 62
Default

.

Last edited by blimey; 03-02-2002 at 01:40 PM.
blimey is offline  

Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service -

Copyright © 2024 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.