R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Nitro On-Road

Reply
 
Thread Tools Search this Thread
Old 08-01-2003, 09:19 PM   #301
Tech Adept
 
Jim Reeves's Avatar
 
Join Date: Aug 2002
Location: New Port Richey, FL
Posts: 119
Default

Quote:
Originally posted by alucard13
i would put some threal lock on it as well.
Definately! Put blue thread lock on all metal to metal connections! Thanks alucard13!
Jim Reeves is offline   Reply With Quote
Old 08-02-2003, 06:46 AM   #302
Tech Addict
 
hooked_on's Avatar
 
Join Date: Apr 2002
Location: Australia
Posts: 725
Trader Rating: 1 (100%+)
Default

Thanks Jim!
__________________
- - - - 2013 Dick Johnson Racing Team Mate Member - - - -
hooked_on is offline   Reply With Quote
Old 08-02-2003, 07:22 PM   #303
Tech Addict
 
hooked_on's Avatar
 
Join Date: Apr 2002
Location: Australia
Posts: 725
Trader Rating: 1 (100%+)
Default

Quote:
Originally posted by Jim Reeves
Definately! Put blue thread lock on all metal to metal connections! Thanks alucard13!
Would you include "The Fix" as well for thread lock?
__________________
- - - - 2013 Dick Johnson Racing Team Mate Member - - - -
hooked_on is offline   Reply With Quote
Old 08-02-2003, 09:25 PM   #304
Tech Master
 
Number 11's Avatar
 
Join Date: Sep 2002
Location: Kenmore, WA
Posts: 1,377
Default

Well I got to run my chassis today and I was really impressed. The car handled extremely well. I noticed it seems to be much more responsive or quicker through turns and my lap times where much faster.
Number 11 is offline   Reply With Quote
Old 08-05-2003, 06:45 PM   #305
Tech Rookie
 
Join Date: Jul 2003
Location: Ten-Uh-C
Posts: 9
Default Finished!

Been kinda busy with work past couple weeks, have had my Chassis for a couple weeks and just got finished building it up today!

WOW!

Dropped a new RB Concept X12 tuned by Rody Roem in it with a 2 speed clutch and all sorts of other goodies. Thing I'll hate going through will be breaking in yet ANOTHER new motor but I'm pretty pumped nonetheless.

Ran into a couple small problems during buildup on the car. Seems the left rear brace needs a wee-bit modification done to it for an exact fit without performing a Dremel-octomy to it, the car is much too nice to have unnecessary grinding done to it. (Jim if you guys redesign that brace hook me up with 1 please)

Throttle servo mounts don't appear to be tall enough without adding spacers. Hitec 525 did NOT want to go. It's in now but geesh, I HATE using those things.

I use Golden Horizon control arm mounts and the holes for the rears didn't exactly lineup with the mounts. Fronts went on fine. After about 20 minutes of baby-talkin' the damn things, they went on.

I did fabricate and install 1 item on the car. With the motor I put on it and the great handling I hope to get.....I felt the need to fabricate and install a tow-hook to drag the rest of the field around the track.

I at least want it to look like a race!

Ice FN Man!
Ice FN Man is offline   Reply With Quote
Old 08-05-2003, 08:16 PM   #306
Tech Adept
 
Jim Reeves's Avatar
 
Join Date: Aug 2002
Location: New Port Richey, FL
Posts: 119
Default

Hooked_On, probably won't need thread lock for The Fix since you should've cut new threads into the plastic in the process of installing it and the caps are a snug fit, can't hurt though.

Number 11, glad to hear initial success with The Chassis, get out there and set new fastest lap times!

ICE FN Man, you're NTC3 should be stupid fast with that motor in it, the RB was one engine we've found caused more difficulty with installation, still don't have one here to see if the crankcase mounts are slightly different. We'll be moving the slots back .003 to conform to stock, then any further mounting issues will at least be no different than stock! Glad you've overcome them anyway. You can drop your 525 lower if you follow my suggestion earlier on the previous page (see pic) but be careful your servo doesn't extend below the bottom of the chassis. First I've heard of problems with rear control arm mounts, we'll take a closer look at that. Let us know your results with the car, if you're like the rest of us you should be very pleased! Thanks again to all of you for your support of The Chassis! Jim
Jim Reeves is offline   Reply With Quote
Old 08-06-2003, 01:57 AM   #307
Tech Addict
 
hooked_on's Avatar
 
Join Date: Apr 2002
Location: Australia
Posts: 725
Trader Rating: 1 (100%+)
Default Re: Finished!

Quote:
Originally posted by Ice FN Man
Been kinda busy with work past couple weeks, have had my Chassis for a couple weeks and just got finished building it up today!

WOW!

Dropped a new RB Concept X12 tuned by Rody Roem in it with a 2 speed clutch and all sorts of other goodies. Thing I'll hate going through will be breaking in yet ANOTHER new motor but I'm pretty pumped nonetheless.

Ran into a couple small problems during buildup on the car. Seems the left rear brace needs a wee-bit modification done to it for an exact fit without performing a Dremel-octomy to it, the car is much too nice to have unnecessary grinding done to it. (Jim if you guys redesign that brace hook me up with 1 please)

Throttle servo mounts don't appear to be tall enough without adding spacers. Hitec 525 did NOT want to go. It's in now but geesh, I HATE using those things.

I use Golden Horizon control arm mounts and the holes for the rears didn't exactly lineup with the mounts. Fronts went on fine. After about 20 minutes of baby-talkin' the damn things, they went on.

I did fabricate and install 1 item on the car. With the motor I put on it and the great handling I hope to get.....I felt the need to fabricate and install a tow-hook to drag the rest of the field around the track.

I at least want it to look like a race!

Ice FN Man!
Ice:

I take it the Rb Rody lined up nicely on the orginal mounts?
__________________
- - - - 2013 Dick Johnson Racing Team Mate Member - - - -
hooked_on is offline   Reply With Quote
Old 08-06-2003, 01:59 AM   #308
Tech Addict
 
hooked_on's Avatar
 
Join Date: Apr 2002
Location: Australia
Posts: 725
Trader Rating: 1 (100%+)
Default

My car is now complete ready for the motor to be bolted in. I am looking forward to eventually hitting the track with it. Can't expect too much, havent driven for 6mnths.
__________________
- - - - 2013 Dick Johnson Racing Team Mate Member - - - -
hooked_on is offline   Reply With Quote
Old 08-06-2003, 05:18 AM   #309
Tech Rookie
 
Join Date: Jul 2003
Location: Ten-Uh-C
Posts: 9
Default Re: Re: Finished!

Quote:
Originally posted by hooked_on
Ice:

I take it the Rb Rody lined up nicely on the orginal mounts?
You betcha! I used the Factory Team non-pullstart mounts, the lil' blue ones...popped right in without a hitch, PERFECTLY!

Only prob I had in that area was that nuisance left rear brace that everyone seems to be grinding on to get the 2-speed clutch bell to fit.

I'll let you guys know how stupid fast this heathen' is after I get it broke in. Hope to find a cop with a radar gun sitting in the parking lot doing paperwork where I break mine in.

Ice!
Ice FN Man is offline   Reply With Quote
Old 08-06-2003, 05:51 AM   #310
Tech Rookie
 
Join Date: Jul 2003
Location: Ten-Uh-C
Posts: 9
Default

Quote:
Originally posted by Jim Reeves

ICE FN Man, you're NTC3 should be stupid fast with that motor in it, the RB was one engine we've found caused more difficulty with installation, still don't have one here to see if the crankcase mounts are slightly different. We'll be moving the slots back .003 to conform to stock, then any further mounting issues will at least be no different than stock! Glad you've overcome them anyway. You can drop your 525 lower if you follow my suggestion earlier on the previous page (see pic) but be careful your servo doesn't extend below the bottom of the chassis. First I've heard of problems with rear control arm mounts, we'll take a closer look at that. Let us know your results with the car, if you're like the rest of us you should be very pleased! Thanks again to all of you for your support of The Chassis! Jim [/B]
Jim,
The RB popped in like The Chassis was built around it, not 1 prob...used Factory Team NPS mounts.

If you move those mounts back I think you'll have a worse prob with the 2-speed clutch bell vs. left rear brace than now. I think it'll end up you (or consumer) will have to totally cut that forward spine off the brace to fit.

Installed my Fixes too, what a dream part! Hopefully I won't blow another gear case now. Seems like the past few races I've blown 1 each race weekend. My only negative thought about The Fix was "where the hell they getting those long screws"? Ever thought of adding a couple spares to the package and getting another $1 out of it? I'd pay it not to get a headache from running those down.

I have 1 idea you guys might want to look into. I busted 2 fuel tanks out of 3 race weekends, 1 my fault, other I was t-boned. Seems the pipe is getting slammed into the tank. My idea: when you have the CNC cutting the tank side of The Chassis maybe you could re-program it to cut like a "scallop" along that side for the pipe to slam instead of a tank. Just a thought. In case you're unsure what "scallop" is, think of wood designer trim at Home Depot, like lil' wavy trim, a scallop.

Ice!
Ice FN Man is offline   Reply With Quote
Old 08-06-2003, 08:32 PM   #311
Registered User
 
Join Date: Aug 2001
Location: Charleston WV
Posts: 939
Send a message via AIM to bbntc3
Default

I'm using the RB 5port engine x12 with k-factory centax clutch and k-factory fuel tank. Stock mounts won't work for me because no endplay for the clutch bell also the clutchbell hits the chassis braces, and the exhaust header hits the rear, and top of the fuel tank bad with the rd- pipe, and the AE tank won't fit at all with the rd pipe.
I use 3 different engines on the car,with the same pipe and clutch set up,(RD pipe,and K-factory fuel tank,K- centax clutch, and to me there should be a happy spot for the mounting slots maybe where everything should work, with a chassis brace change,(leftside).. I'm sure Jay is on top of this. But with the first run of chassis's, it seems to me that you must make or find different mounts for each engine. But... The chassis is worth the mount problem!.
I never knew there was such a difference between engine manufactors before, but there must be. I mean we're only talking a few thousandths here and there.
bbntc3 is offline   Reply With Quote
Old 08-06-2003, 09:23 PM   #312
Tech Rookie
 
Join Date: Jul 2003
Location: Ten-Uh-C
Posts: 9
Default

Quote:
Originally posted by bbntc3
I'm using the RB 5port engine x12 with k-factory centax clutch and k-factory fuel tank. Stock mounts won't work for me because no endplay for the clutch bell also the clutchbell hits the chassis braces, and the exhaust header hits the rear, and top of the fuel tank bad with the rd- pipe, and the AE tank won't fit at all with the rd pipe.
I use 3 different engines on the car,with the same pipe and clutch set up,(RD pipe,and K-factory fuel tank,K- centax clutch, and to me there should be a happy spot for the mounting slots maybe where everything should work, with a chassis brace change,(leftside).. I'm sure Jay is on top of this. But with the first run of chassis's, it seems to me that you must make or find different mounts for each engine. But... The chassis is worth the mount problem!.
I never knew there was such a difference between engine manufactors before, but there must be. I mean we're only talking a few thousandths here and there.
Having a hard time locating a K-Factory Centax, opted for the Associated in the meantime. Is that K-Factory clutch longer than the Associated? My Associated went in without a hitch, granted there is damn near ZERO tolerance but it's in there!

The Factory Team mounts worked fine for me and I must admit, I was totally surprised after reading several posts where folks had to experiment. I may have the damn things on backwards for all I know but hey, it worked! What mounts are you using?

I also opted for the RD Logic pipe for the NTC3 with factory tank. It's a snug fit but it is working for me. Once again, I have probs running down one of those Low CG K-Factory tanks and once I did find it (eBay) I paid out the ass for it. MSRP on that tank is $39, but you can't find them...at least I can't. I got into a bidding war on eBay with 2 others and exceded the MSRP so I stopped bidding until 43 seconds left in the auction. I admit, I sniped those guys but damn, I NEED that tank...ended up paying $46 + $5 shipping for it.

If any of you guys can help me out with a link or 2 of places to purchase this race stuff I'd certainly appreciate it!

Ice!
Ice FN Man is offline   Reply With Quote
Old 08-07-2003, 05:52 PM   #313
Registered User
 
Join Date: Aug 2001
Location: Charleston WV
Posts: 939
Send a message via AIM to bbntc3
Default

I have made my mounts. I have a few sets to choose from. Yes the K centax is longer and it has to have some endplay for the push clutch. The problem I ran into was not the length, but when the clutch was engaged and all the endplay removed from the bell , second gear on the bell rubbed first gear on the spur. When using the clutch you also have to taper the rear hinge pin mount so the clutch screw and thrust brg, does'nt rub it. By moving the mounts back about .060 it clears with no tappering needed, but then the tank issues plays into effect.
Boy, I guess I'm lucky! I buy from LHS, the K tank only cost me $30, but I only pay about 10% above cost and no shipping charges!
http://shop.the-border.nl/customer/home.php?cat=312
Heres a pretty good and cheaper place to buy K parts. Maybe this will help.
bbntc3 is offline   Reply With Quote
Old 08-13-2003, 02:50 PM   #314
Tech Elite
 
Join Date: Aug 2001
Location: Maryland
Posts: 3,984
Trader Rating: 5 (100%+)
Default

What's going on. Well if there are any updates being built I would like one. My Hitec 605 sits high as a throttle servo. Chassis too pretty to dremel. Although I have been running. I agree it's worth the effort but I would like the updates. Motor mounts for Novarossies and throttle servos.

Isaac
[email protected]
Isaac is offline   Reply With Quote
Old 08-13-2003, 03:31 PM   #315
Tech Adept
 
Join Date: Jul 2003
Location: Grand Rapids, Michigan
Posts: 171
Default KFactory Centax availability

Try Trinity at www.teamtrinity.com. I have ordered two from them in the last six weeks along with some spare parts.
jcrouse is offline   Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Nitro Tc3 Chassis sean R/C Items: Wanted to Buy 2 08-08-2004 05:12 PM
RTR Kyosho USA-1 Nitro Crusher trade for HPI Nitro mt or mt2 rolling chassis RCNitroDude999 R/C Items: For Sale/Trade 2 05-13-2004 04:55 PM
WTB: Nitro TC3 Stock Chassis rod_b R/C Items: Wanted to Buy 2 10-21-2003 08:11 PM
HPI NITRO RS4 (rolling chassis) mistercrash R/C Items: For Sale/Trade 2 06-15-2003 04:46 PM
WTB Nitro sedan chassis coastaltony R/C Items: Wanted to Buy 0 01-14-2002 01:21 PM



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 07:04 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net