R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Nitro On-Road

Reply
 
Thread Tools Search this Thread
Old 06-09-2003, 04:43 AM   #1
Tech Initiate
 
tamiya451's Avatar
 
Join Date: Apr 2002
Location: Melbourne, Australia
Posts: 25
Default Pull start assembly

my pull start never goes back in after i pull it !! i think i assembled it wrong!! heres some pix!! tell me what i have done wrong plz!! and if u could post pix of the correct way that would be kewl!!





tamiya451 is offline   Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
NEW 2.5R or 3.3 PULL START ASSEMBLY CHEAP racersnow R/C Items: For Sale/Trade 1 03-24-2007 07:40 PM
T-maxx pull start hard to pull.. t-maxx_boi Monster Trucks 1 04-28-2006 07:03 PM
Wanted Pull start/roto start for collari .30 seajj2 R/C Items: Wanted to Buy 5 08-31-2005 05:51 PM
Exactly how do you start a pull-start motor? <Don't flame me because I'm dumb!> Vyrus Track Locator Forum 1 08-20-2004 06:39 PM
NTC3 pull start to non-pull question SeventyGTX Nitro On-Road 4 02-16-2004 08:05 PM



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 07:08 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net