R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Nitro On-Road

Reply
 
Thread Tools Search this Thread
Old 09-16-2007, 08:16 AM   #1
Tech Elite
 
maskedrider's Avatar
 
Join Date: Dec 2005
Location: MP9 is here ...stay tune !
Posts: 2,039
Trader Rating: 4 (100%+)
Unhappy PT

hi guys,

do you think is my PT still able to repair ? the Led orange light is able to on, but cannot be detected !!


maskedrider is offline   Reply With Quote
Old 09-16-2007, 10:59 AM   #2
Tech Elite
 
quietstorm76's Avatar
 
Join Date: Apr 2005
Location: Atlanta
Posts: 2,265
Trader Rating: 10 (100%+)
Default

Might be better off buying a new one. Contact AMB
__________________
Team Shepherd USA:Nugget's Ranch Raceway
Primary Weapon: ?
Secondary Weapon: ?
Tires>>> I don't know yet
quietstorm76 is offline   Reply With Quote
Old 09-16-2007, 03:38 PM   #3
Tech Fanatic
 
Serpentd's Avatar
 
Join Date: Jul 2004
Location: Evans, CO. USA
Posts: 798
Default

Oh dude that sucks bro!! How did you manage that? Were you in a wreck? It almost looks melted. Anyway I would contact AMB like quietstorm76 mentioned and ask about repair or replacement costs. Find out if you have any options other then just throwing it away and getting a new one. Good luck man. Later
__________________
Blessed are the SIC
Serpentd is offline   Reply With Quote
Old 09-16-2007, 08:22 PM   #4
Tech Fanatic
 
mcsquish's Avatar
 
Join Date: May 2003
Location: Live at work, play in Toledo, OH
Posts: 828
Trader Rating: 1 (100%+)
Default

Good luck, I can't believe what they are charging now for new ones!!!!
mcsquish is offline   Reply With Quote
Old 09-16-2007, 08:37 PM   #5
Tech Master
 
Ed Anderson's Avatar
 
Join Date: Jun 2006
Location: N.J.
Posts: 1,373
Trader Rating: 26 (100%+)
Default

Check out this thread.

http://www.rctech.net/forum/showthread.php?t=170758

I know Getto sent his in, and he got a new one for "around" half price.

You also may have the option to get it cloned. Talk to Terry at MRT, show him the picture, let him know its not counting. He might be able to tell you if he can clone it or not before you send it to him.

http://www.rctech.net/forum/showthread.php?t=164588
Ed Anderson is offline   Reply With Quote
Old 09-18-2007, 11:01 AM   #6
Tech Elite
 
maskedrider's Avatar
 
Join Date: Dec 2005
Location: MP9 is here ...stay tune !
Posts: 2,039
Trader Rating: 4 (100%+)
Default

just my luck....
its came off from the mount on the Top plate in my On Road and bonding niceing between my spur gear during my heats run, and rub against it till shown in the picture
maskedrider is offline   Reply With Quote
Old 09-18-2007, 11:08 AM   #7
Tech Fanatic
 
Serpentd's Avatar
 
Join Date: Jul 2004
Location: Evans, CO. USA
Posts: 798
Default

Quote:
Originally Posted by maskedrider View Post
just my luck....
its came off from the mount on the Top plate in my On Road and bonding niceing between my spur gear during my heats run, and rub against it till shown in the picture
Dude, didn't you feel a small lack of power with it rubbing against your spur? Hmmm, it must have just found that perfect spot to land without you noticing. You should really use more then servo tape to mount those suckers. I zip tie mine along with the servo tape just in case. Sorry to here that still. Have you been able to contact AMB yet with any success? I'm curious to how they might handle this sort of issue. The best of luck to you man.
__________________
Blessed are the SIC
Serpentd is offline   Reply With Quote
Old 09-18-2007, 10:48 PM   #8
Tech Elite
 
maskedrider's Avatar
 
Join Date: Dec 2005
Location: MP9 is here ...stay tune !
Posts: 2,039
Trader Rating: 4 (100%+)
Default

Quote:
Originally Posted by Serpentd View Post
Dude, didn't you feel a small lack of power with it rubbing against your spur? Hmmm, it must have just found that perfect spot to land without you noticing. You should really use more then servo tape to mount those suckers. I zip tie mine along with the servo tape just in case. Sorry to here that still. Have you been able to contact AMB yet with any success? I'm curious to how they might handle this sort of issue. The best of luck to you man.
half way thur the 7min heat run, i did feel my car slow down a bit but, since it a heat run, i just dash it thru it without any care at all.....
make it thru 45min long main in 4th place, but lose a PT ... shit##$**^
I had email to AMB for advise but till now, still no reply yet
maskedrider is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 02:36 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net