R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Nitro On-Road

Closed Thread
 
Thread Tools Search this Thread
Old 05-21-2006, 10:57 AM   #1
Tech Regular
 
The Fog's Avatar
 
Join Date: Feb 2004
Location: Hear, Now.
Posts: 450
Default OS TZ Motor Page

So, who's doing what and who's making what for the TZ motors. Is there anybody making better con rods for these motors. I need to change out my .12 rod as it has a stretched feel to it, having endured the really heavy wedge these engines have. We had two .21 engines break their rods right above the crank pin this w/end at Time Zone Raceway in Washington. These were motors owned by very experienced racers and I don't want to suffer their frustrations.

So far, I've run a gallon of fuel with nothing but praise for its speediness, having had it finnessed by our local motor man Mike Ellis. He mentioned some one talked on a thread about this rod problem, so here I am, checking out the fixes.

What do you know ??

Jacko
The Fog is offline  
Old 05-21-2006, 12:45 PM   #2
Tech Master
 
drfritz's Avatar
 
Join Date: Sep 2001
Location: Vancouver Wa usa
Posts: 1,769
Default

Quote:
Originally Posted by The Fog
So, who's doing what and who's making what for the TZ motors. Is there anybody making better con rods for these motors. I need to change out my .12 rod as it has a stretched feel to it, having endured the really heavy wedge these engines have. We had two .21 engines break their rods right above the crank pin this w/end at Time Zone Raceway in Washington. These were motors owned by very experienced racers and I don't want to suffer their frustrations.

So far, I've run a gallon of fuel with nothing but praise for its speediness, having had it finnessed by our local motor man Mike Ellis. He mentioned some one talked on a thread about this rod problem, so here I am, checking out the fixes.

What do you know ??

Jacko
Who was the other 21 ?
drfritz is offline  
Old 05-21-2006, 02:09 PM   #3
Moderator
 
Artificial-I's Avatar
 
Join Date: Jan 2005
Location: Rurouni Kenshin
Posts: 3,459
Trader Rating: 17 (100%+)
Send a message via AIM to Artificial-I
Default

Hello , there is already a thread for the os tz. As well its in the engine forum. Do a search on this problem there. If you dont find anything , then post this question and follow ups there.

http://rctech.net/forum/showthread.php?t=60521
Artificial-I is offline  
Closed Thread

Similar Threads
Thread Thread Starter Forum Replies Last Post
The Rex page Swamp Rat Australian Racing 8 01-18-2008 08:31 PM
Page Bar Paladin R/C Tech Site Forum 1 07-11-2005 09:42 AM
Web Page cupdriver Web Links 1 04-06-2005 03:00 PM
Web Page? Bivens Tennessee-Kentucky Racing 4 11-20-2003 08:05 AM
I have a better RC web page than all of you! jeepinator Web Links 7 05-04-2002 10:54 PM



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 10:04 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net