Go Back  R/C Tech Forums > General Forums > Nitro On-Road
RADIO GEAR PROBLEMS >

RADIO GEAR PROBLEMS

RADIO GEAR PROBLEMS

Reply

Old 05-07-2006, 12:17 PM
  #1  
Tech Rookie
Thread Starter
 
Join Date: Apr 2006
Posts: 3
Default RADIO GEAR PROBLEMS

hi, i got my engine started on mc nitro car and the electrics worked fine while starting, when i gave it some throttle it sped off and wouldn't brake, it hit a kerb and stopped, i turned off the engine. the radio gear wont work now,

i have tried changing all the batteries

disconected the fail safe

reconnected the fail safe

The handset does not have any effect on the radio gear in the car, the engine still starts though, the handset shows full battery and the receiver is switched on. (it a ACOMMS)

i am a beginner and so help would be greatly appreciated,

Cheers
khany1 is offline  
Reply With Quote
Old 05-07-2006, 12:53 PM
  #2  
Tech Master
iTrader: (10)
 
Car Breaker's Avatar
 
Join Date: Apr 2004
Location: Grave Yard
Posts: 1,264
Trader Rating: 10 (100%+)
Default

have you set the failsafe right, it has to set to pull the break when lost signal, else failsafe is meaningless
Car Breaker is offline  
Reply With Quote
Old 05-07-2006, 01:15 PM
  #3  
Tech Adept
 
TRFTIM's Avatar
 
Join Date: Nov 2005
Posts: 196
Default

Originally Posted by Car Breaker
have you set the failsafe right, it has to set to pull the break when lost signal, else failsafe is meaningless
Disconnect the failsafe and try again.

Check the crystal isnt damaged by either changing it or trying it in a different receiver.

Check the ariel hasnt been pulled out of its housing.
TRFTIM is offline  
Reply With Quote
Old 05-07-2006, 02:42 PM
  #4  
Moderator
iTrader: (17)
 
Artificial-I's Avatar
 
Join Date: Jan 2005
Location: Rurouni Kenshin
Posts: 3,459
Trader Rating: 17 (100%+)
Default

Ok so did the TX aka transmitter aka remote in your hand. Work at any time? You said you hit throttle and thats all it did and now it wont work?

Make sure your battery isnt getting disconnected. If you have AA's in a plastic box , then that could be one problem. Get some eletrical tape and wrap the battery box so they wont come loose.

Next swap one thing or try one thing at a time.

DO NOT RUN YOUR CAR AGAIN ON THE GROUND. Leave it off the ground and do not turn it on until you can see that its responding to your input.

Then start the car and try playing with it again "OFF GROUND" , if you loose control again. Goto the car and return the carb to closed position and then shut it off.

If all is well then run it , if not.

Youll need to call your radio kits company to see if they can offer some help , also try taking it to your local hobby shop. There can sometimes be so many things its overwhelming for someone new.

Good luck.
Artificial-I is offline  
Reply With Quote

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Thread Tools
Search this Thread

Contact Us Archive Advertising Cookie Policy Terms of Service