R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Nitro On-Road

Reply
 
Thread Tools Search this Thread
Old 04-09-2006, 04:55 PM   #1
Tech Rookie
 
Join Date: Apr 2006
Posts: 11
Exclamation Nwebie Nitro questions (HPI RS4 Evo)

Hi everyone;

I just bought a new RS4 Evo RTR
In followed the instructions to the letter, but had trouble starting it.
In the manual it showed putting the glow charger on the glow plug, but did not say anything about how long (eg untill it starts, for 10 secs, etc). If I left it on there it would start, but die shortly after taking it off.
Also, while trying to start it, after turing over for a few secs (with the roto-starter) it sometimes would (seemingly) seize, or stop turning. I never held it on there once it stopped. I only let it turn for 5 secs or so at a time.
After I DID finally get it to idle, it would die, as soo as I tried to apply even a tiny bit of throttle. (Also, the wheels were not turning as they should, almost as if there was brake or clutch drag, but I don't think so, it rolls freely).
I let it sit a couple hours, because I thought it may have been flooded, and the roto-starter was turning VERY slowly, as if the battery was not charged. So I charged the battery for the roto-start, while I let it sit for a couple hours.
When I tried to restart it again, the roto-start failed, it actually smoked where the extension piece fits in to the roto-start, and the battery got real hot.
I am a couple hours away from the dealer where I bought it, and am wondering if I can just use the extension piece in a drill, or use something else.
If there is a link to find all this info, I would be glad to read it.
Thanks for any help.
somegeek is offline   Reply With Quote
Old 04-09-2006, 05:18 PM   #2
Tech Rookie
 
Join Date: Apr 2006
Posts: 11
Default Update-More Info

BTW;
It is getting fuel, no air in lines.
I looked at a similar post, so am going to target to buy a drill, try that.
It was properly primed, the Evo has a primer.
I am using 80 percent nitro.
Please someone tell me how long I need the glow plug heated for!!!!!!!!!
Thanks
somegeek is offline   Reply With Quote
Old 04-09-2006, 05:46 PM   #3
Tech Fanatic
 
Johnathan's Avatar
 
Join Date: Jun 2005
Location: Texas!
Posts: 765
Trader Rating: 1 (100%+)
Default

check the starter batteries' connector. is it black, or melted? is it a cheep tamiya connector?

also, make sure the engine isnt flooded. have a good ignitor battery.

good luck!
Johnathan is offline   Reply With Quote
Old 04-09-2006, 06:40 PM   #4
Tech Rookie
 
Join Date: Apr 2006
Posts: 11
Red face RS4 Problems

Johnathon;
Thanks for the reply, the battery connectors are not melted, the stater itself smells burnt inside though (where the rod goes in, where it smoked)
Can you tell me how long to heat the glow plug before I start it?
Thanks again
somegeek is offline   Reply With Quote
Old 04-09-2006, 07:39 PM   #5
Tech Regular
 
integra evan's Avatar
 
Join Date: Mar 2006
Location: East coast, NJ
Posts: 260
Trader Rating: 1 (100%+)
Send a message via AIM to integra evan Send a message via MSN to integra evan
Default

The glow plug should heat up instantly (as long as the ignitor is fully charged). Leave the ignitor on the plug until after you have started the engine. It sounds like you're running TOO rich (too much fuel, so that it 'drowns' the engine when you give it throttle). Try leaning out the mixture (turn the high speed screw to the left in 1/8" increments. About the roto start-a guy at the hobby shop where I bought my RS4 said that roto-starts are infamous for shorting out, and if that was to happen, to bring it back to exchange for a new one...I'm not sure how true it is, but mine wasn't defective ::knocks on wood::
integra evan is offline   Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Nitro Questions hrnts69 Nitro Off-Road 12 04-26-2008 04:15 PM
New to nitro!! Have a few questions. traxxataxx Rookie Zone 15 01-19-2008 11:46 AM
Few nitro questions Snipesr82 Rookie Zone 7 04-02-2007 06:38 PM
Questions on Nitro Car kmaheartless Rookie Zone 14 01-13-2007 09:12 PM
Questions about nitro... 86Lude20Si Monster Trucks 17 05-13-2006 06:28 AM



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 04:13 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net