Go Back  R/C Tech Forums > General Forums > Nitro Off-Road
HELP in new to nitro and my engine is not starting well >

HELP in new to nitro and my engine is not starting well

HELP in new to nitro and my engine is not starting well

Old 07-21-2014, 02:35 PM
  #1  
Tech Rookie
Thread Starter
 
Join Date: May 2013
Posts: 6
Default HELP in new to nitro and my engine is not starting well

just broke in a dynamite mach 2 .19 and it was starting great when i was breaking it in and a few times after that. now it takes for ever to start(eazy start on a revo just turns motor have a glow plug igniter) but now it takes for ever to start like 5 min of holding the exhaust closed then when it does fire up it will go but if i get just over 1/2 throttle it just dies please help me!!!
reclaimer429 is offline  
Old 07-21-2014, 03:18 PM
  #2  
Tech Rookie
Thread Starter
 
Join Date: May 2013
Posts: 6
Default

i got it to start but the temp shot up to 310 after abut 5 min of running and now its hard to start again im lost
reclaimer429 is offline  
Old 07-21-2014, 04:53 PM
  #3  
Tech Master
 
nitroexpress's Avatar
 
Join Date: Sep 2006
Posts: 1,919
Default

http://www.youtube.com/watch?v=fWvlEAWVBEM
nitroexpress is offline  
Old 07-21-2014, 05:34 PM
  #4  
JsK
Tech Master
iTrader: (10)
 
JsK's Avatar
 
Join Date: Aug 2009
Location: S.Oregon
Posts: 1,672
Trader Rating: 10 (100%+)
Default

Originally Posted by reclaimer429 View Post
just broke in a dynamite mach 2 .19 and it was starting great when i was breaking it in and a few times after that. now it takes for ever to start(eazy start on a revo just turns motor have a glow plug igniter) but now it takes for ever to start like 5 min of holding the exhaust closed then when it does fire up it will go but if i get just over 1/2 throttle it just dies please help me!!!
Did you change the glow plug after breakin? Also be careful turning it over for prolonged periods with that easy start. Let it cool down for a few minutes in between attempts. It's very easy to overheat the little easy start motor.
JsK is offline  
Old 07-22-2014, 08:36 AM
  #5  
Tech Rookie
Thread Starter
 
Join Date: May 2013
Posts: 6
Default

i have not changed the glow plug. can i run 3.3 glow plugs in the dynamite engine? im guessing no
reclaimer429 is offline  
Old 07-23-2014, 06:16 PM
  #6  
Tech Rookie
Thread Starter
 
Join Date: May 2013
Posts: 6
Default

wow so much help here!!! thank everyone!!
reclaimer429 is offline  
Old 08-13-2014, 07:31 PM
  #7  
Suspended
iTrader: (2)
 
Join Date: Jan 2008
Posts: 1,450
Trader Rating: 2 (100%+)
Default

I'm no expert but every nitro engine iveowed got harder to start After break in. And setting the tune good.

The trick is learning how to start them. 3-4 seconds covering the exhaust outlet WITHOUT the glow igniter. I usually do it till I can hear the starter box speed up slightly. mine usually fires right up after priming it this way.
mtpocketsracing is offline  
Old 08-13-2014, 10:08 PM
  #8  
Tech Fanatic
iTrader: (15)
 
I Wheelie A LOT's Avatar
 
Join Date: Mar 2011
Posts: 960
Trader Rating: 15 (100%+)
Default

Originally Posted by JsK View Post
Did you change the glow plug after breakin? Also be careful turning it over for prolonged periods with that easy start. Let it cool down for a few minutes in between attempts. It's very easy to overheat the little easy start motor.
+1 Glow plugs usually die out during break in sessions or after. I would suggest a new plug before you play with the needles. You may risk the chance of completely messing up the tune if you do, and will just end up chasing it around.

I'm not so sure, but the MC59 would probably work with your engine. It's a hot plug so it'll make tuning a bit easier. Good luck!

http://www3.towerhobbies.com/cgi-bin...P?I=LXRA06&P=8
I Wheelie A LOT is offline  

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information

Copyright 2018 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.