Go Back  R/C Tech Forums > General Forums > Nitro Off-Road
2 Issues with my RC8RS! >

2 Issues with my RC8RS!

2 Issues with my RC8RS!

Old 01-28-2014, 10:27 PM
  #1  
Tech Rookie
Thread Starter
 
Join Date: Jan 2014
Posts: 6
Default 2 Issues with my RC8RS!

So recently picked up my first nitro rc and all is great so far. I took it out today for the second time and ran through 2 tanks today.

One issue I noticed near the end, one of my front wheels wobbles as the car rolls forward. I noticed it when I drove the car towards me with very little throttle.

The other issue, every time the car bumped/crashed into something the receiver went dead. I would have to remove the body and open the receiver box and wiggle the batteries and unplug and replug the connections on the receiver. After doing that, it would work fine until the next bump. Same thing repeated about 4/5 times today.

What should I inspect or replace?

Anyone have a cheap source for glow plugs? McCoy?
bluemonkey is offline  

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information

Copyright 2018 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.