Go Back  R/C Tech Forums > General Forums > Nitro Off-Road
new to SC10GT - need help. >

new to SC10GT - need help.

new to SC10GT - need help.

Old 01-18-2014, 12:13 PM
  #1  
Tech Rookie
Thread Starter
 
Join Date: Jan 2014
Posts: 1
Default new to SC10GT - need help.

Hey guy's I just moved to AZ and brought my SC10GT with me, can't wait to start running it but i'm having some problems.

First of all, I bought this SC10gt off of some jackwagon on craigslist up in portland for what I thought was a good deal.. now all i'm having is problems. I used to have an 80mph rs4 so i'm stoked to get back into the hobby.

sc10gt was running fine the other day for like 2min then died (so i guess not running fine but it seemed healthy).. i think it was running way too hot possibly. So.. finally let it cool down... adjusted my carb a little and it idled for like 5min then puttered out... so i tried to lean it out a little... couldn't get it running right so I left it alone for the day.

The next day I finally got it fired up again and it started to idle... noticed some wet gas on the concrete so decided to lean it out a little more.... the it started smoking where it appeared to be the clutch...

long story short... the carb fuel/air adjustment screw came loose completely... and i think then that's why it started surging going full throttle like crazy (maybe) the truck starts freaking out and I look at the spur gear on the end and it's got teeth that were grinded right off of it. The weird part is when it started going like full throttle the carb was slightly open(like when idling) and the truck didn't want to move at all.

running 20% gas btw.

I'm a really techy dude but i can't figure this out because i'm a noob with this stuff, my HPI back in the day was always simple and reliable, and hadn't been abused. If anyone has time to help me sort this out it would be awesome. The cool thing is I can trade in my broken motor for a brand new one for $75 but i don't know if it's the motor or the clutch or what. Any idea's would be really helpful. Thanks.

sidenote: noticed fearfarm looks awesome but went to their website today and it's down. what's up with that?

------------

update:

I took the transmission apart and the larger gear that connects the axles was grinding when you spun the two axle mount pieces. Is there a mod for that or do I have to replace the whole piece? Also the housing for the trans was crack by the rear top bolt and it fell apart when i was taking it apart. Any ideas would be super helpful... also... if i buy an aluminum housing can I still race in the normal races?

Last edited by MillertimeAZ; 01-19-2014 at 09:54 AM.
MillertimeAZ is offline  

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information

Copyright 2018 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.