losi question

Old 05-08-2013, 05:19 PM
  #1  
Tech Rookie
Thread Starter
 
Join Date: May 2013
Posts: 18
Default losi question

I know im new and this is my first post so ill add a quick hello my names robert and i live in vegas!

now onto my question, i picked up a losi sct nitro and on day one while doing half throttle runs to break in the motor the throttle linkage fell off and caused the car to take off with only control of the steering, i did my best to avoid crashing but it ended up flipping and upon inspection not only did the linkage pop off but the back plate on the motor was falling off as the screws were backing out. Ive hit up losi about a week ago about a warranty and havent heard back, have they gone downhill lately? I used to love losi and had nothing but good in the past.

Second Q now the car constantly revs at a high RPM ive tightened the back plate back on and ive returned the HSN and LSN to stock and closed the idle needle as far as i can and it still persists. This car has half a tank of fuel (byron 20% if it matters) and im pissed that its messing up like this.
07yzryder is offline  
Old 05-09-2013, 11:19 AM
  #2  
Tech Elite
 
Join Date: Mar 2009
Location: Aurora, Colorado
Posts: 4,030
Default

So first off, I dont care what car you get, ALWAYS double check EVERY screw. A throttle return spring is also a good thing to have, it prevents this very thing.

I dont know whats up the Losi, but you should contact Horizon, in the past they had excellent customer service..
token is offline  
Old 05-09-2013, 03:11 PM
  #3  
Tech Rookie
Thread Starter
 
Join Date: May 2013
Posts: 18
Default

i went ahead and shipped it to horizon hobby, hopefully it will be a warranty.

i know i failed a VERY important point in anything and that's not verifying everything myself. It was my first off road car in 3 years so i pulled a MAJOR bone head move and assumed it would be good to go. It seems like (based on the 15 page thread on the car) that alot of others love it and i know every know and then a bad apple comes off the line. Now i gotta wait a few weeks lol.
07yzryder is offline  
Old 05-09-2013, 03:30 PM
  #4  
Tech Elite
 
Join Date: Mar 2009
Location: Aurora, Colorado
Posts: 4,030
Default

Originally Posted by 07yzryder View Post
i went ahead and shipped it to horizon hobby, hopefully it will be a warranty.

i know i failed a VERY important point in anything and that's not verifying everything myself. It was my first off road car in 3 years so i pulled a MAJOR bone head move and assumed it would be good to go. It seems like (based on the 15 page thread on the car) that alot of others love it and i know every know and then a bad apple comes off the line. Now i gotta wait a few weeks lol.
You need to call them and set up a RA for returns.
token is offline  
Old 05-09-2013, 05:09 PM
  #5  
Tech Rookie
Thread Starter
 
Join Date: May 2013
Posts: 18
Default

man i was worried for a second, i had already shipped it out after using the online service center system. but after you said that i was like crap do i need an RA so i called and they said that the online system is what they use now, the have the call ahead just so they can try and do some basic trouble shooting of the cars before hand.

thanks for the help, and you were right, almost no wait time and the rep was extremely helpful!
07yzryder is offline  

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information

Copyright 2018 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.