Go Back  R/C Tech Forums > General Forums > Nitro Off-Road
Gen III Tray problems >

Gen III Tray problems

Gen III Tray problems

Old 07-09-2012, 01:21 PM
  #1  
Tech Addict
Thread Starter
iTrader: (10)
 
71schaeffer's Avatar
 
Join Date: Jul 2012
Location: Kansas city, MO
Posts: 568
Trader Rating: 10 (92%+)
Arrow Gen III Tray problems

I am having a bit of trouble with my tracy, first of all when i use the throttle i can litteraly see the chassis flex and was wandering if i need t stiffen the mounts, also that long rod keeps hitting the inside of the three way mount when i use the throttle, i will post a picture once i figure out how to to make it a bit clearer
71schaeffer is offline  
Old 07-09-2012, 01:29 PM
  #2  
Tech Elite
iTrader: (127)
 
cavwrench's Avatar
 
Join Date: Jan 2008
Location: IL
Posts: 2,594
Trader Rating: 127 (100%+)
Default

Hey pal. I have the gen 3 tray in both my truggy and my buggy. I have had zero problems. It sounds to me like your throttle EPA is set to high. If your EPA is set to high it will pull the throttle further then it needs to and it will flex the chassis. Same if you have the EPA for brakes set to high. Take off your air filter and set your EPA to just where the carb opens all the way with your throttle pulled full open and THAT IS IT. Then push the trigger to set the brake EPA to where the brakes are just lightly applied. NOT PULLING real hard at all and that is it. Try that. It should help you for sure.
cavwrench is offline  
Old 07-09-2012, 01:34 PM
  #3  
Tech Elite
 
cornerspeed's Avatar
 
Join Date: Sep 2001
Location: San Diego
Posts: 2,424
Default

It also sounds like the line marks are not set. There are lines marked on both the tri-horn and throttle servo arm that have to be lined up on the lines on the tray. Those are set for when the throttle is at nuetral position.
cornerspeed is offline  
Old 07-09-2012, 06:41 PM
  #4  
Tech Addict
Thread Starter
iTrader: (10)
 
71schaeffer's Avatar
 
Join Date: Jul 2012
Location: Kansas city, MO
Posts: 568
Trader Rating: 10 (92%+)
Default

Ok thanks guys, i will try to adjust my EPA i just dont know exactly how to do that, also, talking brake bias how do i do that on the radio? If i dont i can find exactly were to set it on the car can someone help with that? Sorry i am kinda new to Losi
71schaeffer is offline  
Old 07-09-2012, 07:33 PM
  #5  
Tech Addict
Thread Starter
iTrader: (10)
 
71schaeffer's Avatar
 
Join Date: Jul 2012
Location: Kansas city, MO
Posts: 568
Trader Rating: 10 (92%+)
Default

Ok i adjusted my EPA on brake and throttle and it seemed to calm it down, i also moved the throttle servo a bit over to match it up with the lines... it worked, then i cut the tubbing for the rear brake and it seemed to respond a little smoother with less pull. Now i just need to learn to adjust brake bias
71schaeffer is offline  
Old 07-09-2012, 09:38 PM
  #6  
Tech Elite
 
vito's Avatar
 
Join Date: Nov 2011
Location: roseburg or
Posts: 3,936
Default

vito is offline  
Old 07-10-2012, 03:44 AM
  #7  
JsK
Tech Master
iTrader: (10)
 
JsK's Avatar
 
Join Date: Aug 2009
Location: S.Oregon
Posts: 1,672
Trader Rating: 10 (100%+)
Default

Originally Posted by vito View Post
Now get down to Jville for round 3 of the OSS series and get that thing dirty
JsK is offline  
Old 07-10-2012, 09:15 AM
  #8  
Tech Addict
Thread Starter
iTrader: (10)
 
71schaeffer's Avatar
 
Join Date: Jul 2012
Location: Kansas city, MO
Posts: 568
Trader Rating: 10 (92%+)
Default

That thing looks to good to be on the track
71schaeffer is offline  
Old 07-11-2012, 05:15 AM
  #9  
Tech Master
iTrader: (32)
 
sickpuppy1's Avatar
 
Join Date: Feb 2006
Location: Gardner,KS
Posts: 1,623
Trader Rating: 32 (100%+)
Default

Aint that funny. They look so good, it almost seems a shame to get it dirty. but ya get over pretty quick,huh?
sickpuppy1 is offline  

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information

Copyright 2018 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.