Go Back  R/C Tech Forums > General Forums > Nitro Off-Road
setup xray xb808 shock rebound >

setup xray xb808 shock rebound

setup xray xb808 shock rebound

Old 05-15-2012, 03:55 AM
  #1  
Tech Apprentice
Thread Starter
 
Join Date: Jan 2011
Posts: 59
Default setup xray xb808 shock rebound

Hello,

I have xray xb808 2011 shock absorbers.
I find difficult to set them up with the correct rebound.
If I set them up with 25% rebound the buggy bottoms out too much (the track that I am racing has not big jumps but there are a lot of bumps).
If I set them up with 75% -100%, the buggy is bouncy...
I use the xray foams behind the bladder and the new progressive springs.

Do you have any suggestions?
mike80 is offline  
Old 05-15-2012, 04:25 AM
  #2  
Tech Master
 
Sideshow Bob's Avatar
 
Join Date: Apr 2009
Location: South Africa
Posts: 1,056
Default

bottoming out is sortoff an xray 808 thing..their shocks werent that great and the limited droop makes them bottom out easier than say the mugens...that being said, although my 808 did slap hard over the odd big jump or two..it never did it all the time...perhaps your shock oils are a bit thin? i used to run blue grey front spring and stock silver rear coupled with about 35 in the rear with 40 up front...that worked on most tracks. If you use the stock larger hole shock pistons (instead of 10 or 8 holes option ones) try going a bit thicker in shock oil. a smaller hole piston will give you more "pack" as the shock compresses so that may be why my 808 did not bottom out AS much..although it still did on some areas.
Sideshow Bob is offline  
Old 05-15-2012, 05:14 AM
  #3  
Tech Elite
 
Zerodefect's Avatar
 
Join Date: Apr 2008
Location: Columbus, OH
Posts: 4,814
Default

Try 1.2x8 (F) and 1.1x10 (R) pistons and 40wt AE oil. 1.3x8 in the rear is normal, 1.2 or 1.1 pistons will pack better.

Use the bottom row of holes in the tower and inside holes on the arms to increase droop. Run full droop.


Or better yet, upgrade to Xb9 shocks, towers, arms, rear V2 carriers.
Zerodefect is offline  
Old 05-15-2012, 06:22 AM
  #4  
Tech Apprentice
Thread Starter
 
Join Date: Jan 2011
Posts: 59
Default

I run 1.3 x 8 holes rear with 700cps oil and still slaps very easily.
mike80 is offline  

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information

Copyright 2018 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.