Go Back  R/C Tech Forums > General Forums > Nitro Off-Road
Brakes won't work... >

Brakes won't work...

Brakes won't work...

Old 04-28-2012, 07:48 PM
  #1  
Tech Initiate
Thread Starter
 
aus1003's Avatar
 
Join Date: Sep 2010
Location: Arkansas
Posts: 20
Default Brakes won't work...

I have a Traxxas Nitro Rustler with a 2.5 TRX motor. I have been running it just fine with the brakes working perfect. Then I tried to take it out and run it today and the brakes won't work at all. The servo doesn't even push that away when I apply them on my reciever. Any suggestions?
aus1003 is offline  
Old 04-28-2012, 08:10 PM
  #2  
Tech Addict
iTrader: (13)
 
SolderGlob's Avatar
 
Join Date: Nov 2011
Location: Wilm.Il.
Posts: 588
Trader Rating: 13 (100%+)
Default

With the radio and receiver off, turn the servo horn to mimic braking and check for binding in the linkage.

Also, if using a non-stock radio/receiver, check to see if your EPA is adjusted correctly.
SolderGlob is offline  
Old 04-28-2012, 08:33 PM
  #3  
Tech Initiate
Thread Starter
 
aus1003's Avatar
 
Join Date: Sep 2010
Location: Arkansas
Posts: 20
Default

There is a little bit of binding...how do I fix this issue?
aus1003 is offline  
Old 04-28-2012, 09:24 PM
  #4  
Tech Addict
iTrader: (13)
 
SolderGlob's Avatar
 
Join Date: Nov 2011
Location: Wilm.Il.
Posts: 588
Trader Rating: 13 (100%+)
Default

Without knowing where the binding is occurring exactly it would be difficult to guide you through fixing it. I looked at the manual and the pictures on the Traxxas website and I couldn't get a clear idea of what the issue could be.

My best advise is to look at it logically and work on it in steps. Start at the transmission/brake disc and move along the linkage to the servo looking for anything that might be causing the issue.
SolderGlob is offline  

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information

Copyright 2018 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.