Go Back  R/C Tech Forums > General Forums > Nitro Off-Road
Glow Plug Igniter Issue >

Glow Plug Igniter Issue

Glow Plug Igniter Issue

Old 03-01-2011, 11:09 PM
  #1  
Tech Rookie
Thread Starter
 
Join Date: Feb 2011
Posts: 11
Default Glow Plug Igniter Issue

Hi all,

New member here. Just picked up a Kyosho DBX a few weeks ago and ran into a strange problem earlier today.

I have a Dynamite metered rechargeable glow igniter and it's been acting funky ever since running my car earlier today. I charged the unit overnight (12 hours) and it worked well for a day and all of a sudden it died out on me today (ran good for 1 start). I figured it lost its charge, but I plugged it in to charge for ~4-5 hours and placed it over the glow plug (to see if there was any current) and the meter still shows 0. I also took out the glow plug to test if the plug was good but it wouldn't glow red. Keep in mind I just replaced the glow plug a few days ago so that shouldn't be the problem.

Any ideas?

Thanks,

Phyek
phyek is offline  

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information

Copyright 2018 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.