Losi 8ight t 2.0 RTR Problem

  • I decided today was the day that I would break in my Losi 8ight t 2.0 RTR and before i put fuel in the engine i binded the remote with the bind plug. I turned on all power and turned the steering wheel clockwise and nothing. I turned it left and the wheels turned all the way left and did not return to center and I was unable to return them to the center either. I havent even put gas in the fuel tank yet and I dont know what is wrong with the steering. Any help would be appreciated!
  • Probably a bad steering servo, they don't last long.

    With everything off, can you turn the front wheels left to right freely minus the drag from the servo? I doubt something is binding, but you never know.
    You can also try removing the servo horn, turn everything on, and see what happens.


    Start with the basics though. Did you charge the receiver pack first? It really sounds like the batteries are dead.
  • I charged the receiver pack fully, and get nothing, i will recharge receiver pack again tonight and try in the morning.
  • Does it do this while its on the ground? Will it work right if the wheels are lifted in the air?

    If this is the case, its a bad servo. I would no be surprised for the same thing happen with my 2.0b rtr. Horizon should replace the servo (they did for me) but it will just happen again. I ended up getting a nice steering servo and moving the stock one to the throttle.
  • Quote: I decided today was the day that I would break in my Losi 8ight t 2.0 RTR and before i put fuel in the engine i binded the remote with the bind plug. I turned on all power and turned the steering wheel clockwise and nothing. I turned it left and the wheels turned all the way left and did not return to center and I was unable to return them to the center either. I havent even put gas in the fuel tank yet and I dont know what is wrong with the steering. Any help would be appreciated!
    Why did you bind it? There bound from the factory. Alls you had to do was turn it on and it should have worked fine. The only reason they give you the bind plug is if you want to bind your control to another car......
  • yeah that too, I never bound mine when i got it
  • Quote: Does it do this while its on the ground? Will it work right if the wheels are lifted in the air?

    If this is the case, its a bad servo. I would no be surprised for the same thing happen with my 2.0b rtr. Horizon should replace the servo (they did for me) but it will just happen again. I ended up getting a nice steering servo and moving the stock one to the throttle.
    So what was your pick for the steering servo.

    same boat
  • Ace 1313, still going strong (knock on wood).
  • Quote: I charged the receiver pack fully, and get nothing, i will recharge receiver pack again tonight and try in the morning.
    I'm having the same exact problem with my steering. This is after a day of babying it in a parking lot. I'm just going to order the same Hitec you got and be done with it. I still want this one replaced though since I paid for it. Did you get it replaced?
  • Horizon should replace it if you've not had it long, especially if you just now broke it in. I suggest getting it replaced and using it on throttle. It will not last long as steering, trust me a new good servo makes a world of difference in handling and your driving

Similar Threads