Go Back  R/C Tech Forums > General Forums > Nitro Off-Road
bad glow plug or what? >

bad glow plug or what?

bad glow plug or what?

Old 12-12-2009, 12:52 PM
  #1  
Tech Initiate
Thread Starter
 
linnix13's Avatar
 
Join Date: Nov 2009
Posts: 23
Default bad glow plug or what?

i have a traxxas stampede, it was running great, i took it out today and it starts ok, and idles great with the glow plug igniter on, then when i remove the glow plug igniter the idle gets rougher but it still runs, then if i give it gas it has good pickup, but then dies once the rpms get up, i let the engine warm up and i tried richening the mixture, but get this, if i leave the glow plug igniter on and drive it, then it drives fine, has lots of power and revs up great, if i hold the wheels of the ground and floor it without the glow plug igniter on it revs up but doesnt go to high before it begins to run rough then it just stalls, but if i leave the glow plug igniter on and try that, it runs perfect, i took the glow plug out and hooked it up to the igniter and it burns a nice cherry red,
linnix13 is offline  
Old 12-12-2009, 01:03 PM
  #2  
Tech Elite
iTrader: (84)
 
DPowers's Avatar
 
Join Date: Jun 2007
Location: Where the fast guys are
Posts: 3,696
Trader Rating: 84 (100%+)
Default

Originally Posted by linnix13 View Post
i have a traxxas stampede, it was running great, i took it out today and it starts ok, and idles great with the glow plug igniter on, then when i remove the glow plug igniter the idle gets rougher but it still runs, then if i give it gas it has good pickup, but then dies once the rpms get up, i let the engine warm up and i tried richening the mixture, but get this, if i leave the glow plug igniter on and drive it, then it drives fine, has lots of power and revs up great, if i hold the wheels of the ground and floor it without the glow plug igniter on it revs up but doesnt go to high before it begins to run rough then it just stalls, but if i leave the glow plug igniter on and try that, it runs perfect, i took the glow plug out and hooked it up to the igniter and it burns a nice cherry red,
yeah i would say it is your glow plug if it runs while your ignitor is on it.
DPowers is offline  
Old 12-12-2009, 02:12 PM
  #3  
Tech Fanatic
iTrader: (18)
 
1bigshane's Avatar
 
Join Date: Aug 2009
Location: $$$ las vegas N,V $$$
Posts: 865
Trader Rating: 18 (100%+)
Default

yes sir!!!!glow plug!!!
1bigshane is offline  
Old 12-12-2009, 06:58 PM
  #4  
Tech Master
 
pitpop's Avatar
 
Join Date: Mar 2006
Posts: 1,445
Default

just because the plug lights up with the igniter on doesn't mean it's ok...
pitpop is offline  
Old 12-13-2009, 04:13 AM
  #5  
Tech Fanatic
iTrader: (1)
 
Join Date: Jan 2008
Location: All Over So. Fla.
Posts: 985
Trader Rating: 1 (100%+)
Default

Change it. I know at 5 bucks a pop it sucks but it is what it is. Any time you think it's a plug it is. And do yourself a favor and don't save them for "just in case" ether.
The Working Man is offline  

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information

Copyright 2018 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.