RC10gt NO GO!

Old 08-24-2009, 02:32 PM
  #1  
Tech Regular
Thread Starter
iTrader: (1)
 
sand viper's Avatar
 
Join Date: Jul 2008
Location: Grimshaw
Posts: 465
Trader Rating: 1 (100%+)
Default RC10gt NO GO!

Hello my name is ryan and i aquired a rc10 gt last year around the middle of the summer and it ran like a dream. I was running traxxas %20 fuel in it, and maintenced it offen. Before i put it away for the year i took it apart and cleaned it up nice. I replaced all the old fuel tubing and redid the shocks. When the time came again this spring when i was able to drive it i attempted to start it but it wont even fire. I got it to fire once after continuely swapping out glow plugs and turning over the engine. I charged the glow plug igniter up to a fully charge and it still wont start. I can see gas going into the carbuerator as its traveling throught the fuel line but its still a no go. I was just wondering what could cause it not to start? Bad fuel? wrong fuel tubing? air leak perhaps? It fired only once but once i applied a little throttle just to idle it up it quit! Can someone please help me out!!!!
sand viper is offline  
Old 08-24-2009, 02:53 PM
  #2  
Tech Master
iTrader: (11)
 
JoeyTheRocket's Avatar
 
Join Date: Sep 2008
Location: Oswego, IL
Posts: 1,901
Trader Rating: 11 (100%+)
Default

Originally Posted by sand viper View Post
Hello my name is ryan and i aquired a rc10 gt last year around the middle of the summer and it ran like a dream. I was running traxxas %20 fuel in it, and maintenced it offen. Before i put it away for the year i took it apart and cleaned it up nice. I replaced all the old fuel tubing and redid the shocks. When the time came again this spring when i was able to drive it i attempted to start it but it wont even fire. I got it to fire once after continuely swapping out glow plugs and turning over the engine. I charged the glow plug igniter up to a fully charge and it still wont start. I can see gas going into the carbuerator as its traveling throught the fuel line but its still a no go. I was just wondering what could cause it not to start? Bad fuel? wrong fuel tubing? air leak perhaps? It fired only once but once i applied a little throttle just to idle it up it quit! Can someone please help me out!!!!
How old is the fuel? How old is your igniter, does it have a meter? Also Traxxas fuel is junk!
JoeyTheRocket is offline  
Old 08-24-2009, 09:47 PM
  #3  
Tech Master
iTrader: (10)
 
Join Date: Jul 2007
Location: Rossville Ga
Posts: 1,398
Trader Rating: 10 (100%+)
Default

Test the glow ignighter on the glow plug and make the glow ignighter is working. Some times the ignighter gets dirty and does not light plug as well.
bigde2001 is offline  
Old 08-25-2009, 01:50 AM
  #4  
Tech Initiate
 
Join Date: Jun 2009
Location: Honolulu, Hawaii
Posts: 23
Default

if igniter works, glow plugs are good, fuel is flowing freely,etc...its definitely bad fuel if its really old
In3g_z33 is offline  
Old 09-19-2010, 05:53 PM
  #5  
Tech Apprentice
 
gt fast's Avatar
 
Join Date: Sep 2010
Posts: 58
Default

listen to these guys, fuel is only good for so long yea it will still burn but it needs to be really hot to run these little engines. try to hold one finger over the end of your pipe, the little part where the exhaust comes out and try starting it, like if your pull start do about 5 pulls then let go then 5 pulls without it blocked, it helps build uip fuel in chamber then maybe youll have some luck.
gt fast is offline  
Old 09-19-2010, 07:44 PM
  #6  
Tech Elite
iTrader: (65)
 
newuserlosi8t's Avatar
 
Join Date: Mar 2010
Location: sacramento
Posts: 2,051
Trader Rating: 65 (97%+)
Default

i was in a pinch at the track ran out of fuel and cut practice short but i had a little traxxas fuel i used for cleaningout motors used that truck wouldnt start and the fuel wasnt bad once i got more byrons it started right up
newuserlosi8t is offline  
Old 09-19-2010, 08:04 PM
  #7  
Tech Apprentice
 
gt fast's Avatar
 
Join Date: Sep 2010
Posts: 58
Default

yea man and traxxas fuel believe it or not is really high in oils. i run torco which is a knock off and ive never had a problem with it. traxxas was used for one quart on my car and everytime i went to start it i had to do several pulls. and at that it ran really lean all the time no matter how much i adjusted carb. but with other fuels i can pull 3 times max and engine is ready to roll. if youve got a old engine around you can actually run part diesel, and part 2 stoke oil. try it on a older motor just in case most people dont know these engines are diesel. it works
gt fast is offline  

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information

Copyright 2018 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.